By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,374 Members | 1,939 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,374 IT Pros & Developers. It's quick & easy.

remote psql

P: n/a
Hi,

I am trying to access PostgreSQL remotely with psql, and I am having some
trouble. I am running the server with the -i option to allow Tcp-sockets
and the pg_hba.conf is configed to let my subnet access it. I can access
the server locally and with the pgAdmin III on Win2K. What is even
stranger is that psql works remotely with the -l or -c option, but when I
just try to connect it sits there, no errors(on the server either), no
nothing.

Here is what I have installed:
-FreeBSD 4.8
-Postgres 7.3(on both sides)

thanks,
Andrew Olson
---------------------------(end of broadcast)---------------------------
TIP 7: don't forget to increase your free space map settings

Nov 12 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On Wednesday 01 October 2003 08:50 am, Andrew M. Olson wrote:
Hi,

I am trying to access PostgreSQL remotely with psql, and I am having some
trouble. I am running the server with the -i option to allow Tcp-sockets
and the pg_hba.conf is configed to let my subnet access it. I can access
the server locally and with the pgAdmin III on Win2K. What is even
stranger is that psql works remotely with the -l or -c option, but when I
just try to connect it sits there, no errors(on the server either), no
nothing.


What's the relevant line in your pg_hba.conf? I had some similar problems
like this when I used a funky authentication type. If I use "md5" the issues
went away.

--
/* Michael A. Nachbaur <mi**@nachbaur.com>
* http://nachbaur.com/pgpkey.asc
*/

"Anyone who is capable of getting themselves made President
should on no account be allowed to do the job."

---------------------------(end of broadcast)---------------------------
TIP 2: you can get off all lists at once with the unregister command
(send "unregister YourEmailAddressHere" to ma*******@postgresql.org)

Nov 12 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.