473,226 Members | 1,671 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 473,226 software developers and data experts.

psql error:cannot open libpq.so.3

Hi All,
Took a break from developing on pgsql 7.3 to set up network printing
where I added another host(localhost 193.168.1.2) in red hat network
settings. Later, I could start postmaster but when I started psql I got
the following error when I issue this command:

psql -h localhost -U postgres nba

-bash-2.05b$ psql -h localhost -U postgres nba
psql: error while loading shared libraries: libpq.so.3: cannot open
shared object file: No such file or directory
-bash-2.05b$

I tool this as an opportunity to upgrade from 7.3.2 rpm to 7.3.4.source.
Now I'm is a real pickle. I can create the test database but still get
the same error even though I wiped out the pgsql directories upon
installation.

I checked and libpq.so.3 has a path of /var/lib/pgsql/libpq.so.3, and
the database directory is /usr/local/pgsql. All the files in the pgsql
directories are owned by 'postgres'.
Any ideas what could be causing the problem?
Thanks in advance,
Phil Campaigne
---------------------------(end of broadcast)---------------------------
TIP 5: Have you checked our extensive FAQ?

http://www.postgresql.org/docs/faqs/FAQ.html

Nov 12 '05 #1
1 5642
Phil Campaigne <pc********@charter.net> writes:
-bash-2.05b$ psql -h localhost -U postgres nba
psql: error while loading shared libraries: libpq.so.3: cannot open
shared object file: No such file or directory


This could mean either that libpq.so itself is not where your dynamic
linker will look for it, or that some library it depends on (libssl
is a possible example) is not where your dynamic linker will look for
it.

Try first "ldd /path/to/psql" to verify that psql's reference to
libpq.so is being resolved sanely. If so, do ldd on libpq.so to see how
its references are resolved (or not). If necessary, check the
referenced libraries, etc, till you find what's not resolved.

Once you know where the problem is, install the needed library, or
update your ldconfig configuration so it can find that library.

regards, tom lane

---------------------------(end of broadcast)---------------------------
TIP 6: Have you searched our list archives?

http://archives.postgresql.org

Nov 12 '05 #2

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

1
by: Sorisio, Chris | last post by:
Ladies and gentlemen, I've imported some data from a MySQL database into a Python dictionary. I'm attempting to tidy up the date fields, but I'm receiving a 'mx.DateTime.Error: cannot convert...
1
by: Phil Campaigne | last post by:
Hi Tom, THanks for your response. Here are my results: -bash-2.05b$ ldd /usr/local/pgsql/bin/psql libpq.so.3 => /usr/local/pgsql/lib/libpq.so.3 (0x40013000) libz.so.1 => /usr/lib/libz.so.1...
8
by: Kragen Sitaker | last post by:
ERROR: Cannot insert a duplicate key into unique index pg_class_relname_nsp_index We've been getting this error in our application every once in a while --- typically once an hour to once a day,...
0
by: Matthew Louden | last post by:
I am trying to implement the sort event in data grid. I set the data grid's AllowSorting property = True. I implement the following code that should be the event will fire when the user click any...
5
by: Nathan Sokalski | last post by:
When running a page I am working on, I recieve the following error: Cannot use a leading .. to exit above the top directory. I suspect this has something to do with the problem I posted in a...
2
by: moondaddy | last post by:
I have a simple sample site I'm building in asp.net 2.0. I created a master page and a default.aspx content page in the project's root directory. Then I created a subfolder called content and...
1
by: Jim Michaels | last post by:
=> Array ( => UML:CLASS => open => 5 => Array ( => .:00000000000008EC => quiz_batteries => public
2
by: fniles | last post by:
I am using VB.NET 2005 and MS Access. I use OLEDbCommand ExecuteNonQuery to delete a record from a database. Whenever the program gets a message, it creates a new thread to process that message....
0
by: SMH | last post by:
Hi All, I am currently learning .Net 2, studying for 70-528. I've hit a bit of a brick wall with DataColumn.Expression. As I understand it, this can be used to (For example) concatenate two...
2
by: sam.barker0 | last post by:
Hi , I am having 3 functions.When I step through when func b returns to funca.it throws an error "cannot find function bounds" funca() { .... ... funcb(); }
1
isladogs
by: isladogs | last post by:
The next online meeting of the Access Europe User Group will be on Wednesday 6 Dec 2023 starting at 18:00 UK time (6PM UTC) and finishing at about 19:15 (7.15PM). In this month's session, Mike...
0
by: VivesProcSPL | last post by:
Obviously, one of the original purposes of SQL is to make data query processing easy. The language uses many English-like terms and syntax in an effort to make it easy to learn, particularly for...
0
by: jianzs | last post by:
Introduction Cloud-native applications are conventionally identified as those designed and nurtured on cloud infrastructure. Such applications, rooted in cloud technologies, skillfully benefit from...
0
by: mar23 | last post by:
Here's the situation. I have a form called frmDiceInventory with subform called subfrmDice. The subform's control source is linked to a query called qryDiceInventory. I've been trying to pick up the...
0
by: abbasky | last post by:
### Vandf component communication method one: data sharing ​ Vandf components can achieve data exchange through data sharing, state sharing, events, and other methods. Vandf's data exchange method...
2
by: jimatqsi | last post by:
The boss wants the word "CONFIDENTIAL" overlaying certain reports. He wants it large, slanted across the page, on every page, very light gray, outlined letters, not block letters. I thought Word Art...
2
isladogs
by: isladogs | last post by:
The next Access Europe meeting will be on Wednesday 7 Feb 2024 starting at 18:00 UK time (6PM UTC) and finishing at about 19:30 (7.30PM). In this month's session, the creator of the excellent VBE...
0
Git
by: egorbl4 | last post by:
Скачал я git, хотел начать настройку, а там вылезло вот это Что это? Что мне с этим делать? ...
1
by: davi5007 | last post by:
Hi, Basically, I am trying to automate a field named TraceabilityNo into a web page from an access form. I've got the serial held in the variable strSearchString. How can I get this into the...

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.