By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,372 Members | 1,950 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,372 IT Pros & Developers. It's quick & easy.

Help needed in Replicating pgsql

P: n/a
Hi
I am Hemasekhar K.P
I am trying to replicae pgsql on REDHATLinux 8,
but the site http://gborg.postgresql.org/genpage?...tion_72install. is
giving instructions on REDHATLinux 7,
is there any site which gives instructions on how to replicate on
REDHATLinux 8,

Actually in postgresql.conf which is under
/usr/local/pgsql/data/postgresql.conf, I added the following lines

#
# Replication
#

repl_max_remote_processes = 2
repl_mgr_port = 5430
repl_spread_port = 4803
repl_spread_host = 'localhost'
repl_spread_group = 'replicationGroup'
repl_database = 'testing'
repl_user = 'qsip'

when i tried to run the postmaster, it is giving the following error

[qsip@ssf pgsql]$ postmaster -i -D /usr/local/pgsql/data/
FATAL 1: 'repl_max_remote_processes' is not a valid option name
[qsip@ssf pgsql]$

i tried commenting repl_max_remote_processes ,it is showing error at

[qsip@ssf pgsql]$ postmaster -i -D /usr/local/pgsql/data/
FATAL 1: 'repl_mgr_port' is not a valid option name
[qsip@ssf pgsql]$.

Please help me in this regard.

Thanks and Regards
Hemasekhar.

Nov 11 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a

Ummmm ... first thought is did you apply the patches to v7.2 for
replication? From the errors, I would guess not ... I'm also guessing
that you are using pgreplication here?

On Tue, 9 Sep 2003, Hema Sekhar wrote:
Hi
I am Hemasekhar K.P
I am trying to replicae pgsql on REDHATLinux 8,
but the site http://gborg.postgresql.org/genpage?...tion_72install. is
giving instructions on REDHATLinux 7,
is there any site which gives instructions on how to replicate on
REDHATLinux 8,

Actually in postgresql.conf which is under
/usr/local/pgsql/data/postgresql.conf, I added the following lines

#
# Replication
#

repl_max_remote_processes = 2
repl_mgr_port = 5430
repl_spread_port = 4803
repl_spread_host = 'localhost'
repl_spread_group = 'replicationGroup'
repl_database = 'testing'
repl_user = 'qsip'

when i tried to run the postmaster, it is giving the following error

[qsip@ssf pgsql]$ postmaster -i -D /usr/local/pgsql/data/
FATAL 1: 'repl_max_remote_processes' is not a valid option name
[qsip@ssf pgsql]$

i tried commenting repl_max_remote_processes ,it is showing error at

[qsip@ssf pgsql]$ postmaster -i -D /usr/local/pgsql/data/
FATAL 1: 'repl_mgr_port' is not a valid option name
[qsip@ssf pgsql]$.

Please help me in this regard.

Thanks and Regards
Hemasekhar.


---------------------------(end of broadcast)---------------------------
TIP 1: subscribe and unsubscribe commands go to ma*******@postgresql.org

Nov 11 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.