By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,661 Members | 1,330 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,661 IT Pros & Developers. It's quick & easy.

ERROR: PLPGSQL does not exist

P: n/a

Hi,
When I Try to write Functions I always become the error
That the language plpgsql doesn't exist.
I tried it this way:
createlang plpgsql template1
createlang -l template1

Procedural languages
Name | Trusted?
---------+----------
plpgsql | t
(1 row)

I also restart the database but no effect.
What am I doing wrong??
Sorry but I'm a Postgres newbie. I worked until yet with Oracle and now we want to change
On Postgres.

Best regards

Schoeib

4Tek Gesellschaft für angewandte Informationstechnologien mbH
Schoeib Amin
Tel. +49 (0) 69 697688-132
Fax. +49 (0) 69 697688-111
http://www.4tek.de
Nov 11 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On 3 Sep 2003 at 11:44, Amin Schoeib wrote:
When I Try to write Functions I always become the error
That the language plpgsql doesn't exist.
I tried it this way:
createlang plpgsql template1
createlang -l template1
Procedural languages
Name | Trusted?
---------+----------
plpgsql | t
(1 row)
I also restart the database but no effect.
What am I doing wrong??
Sorry but I'm a Postgres newbie. I worked until yet with Oracle and now we want
to change


You need to create the language pl/pgsql so that you can create a function in
that language.

Check documentation for create lnaguage syntax or man page of createlang
command. Most probably all you need is a 'createlang plpgsql' from shell prompt
but I am probably bit rusty on details..

Bye
Shridhar

--
Suffocating together ... would create heroic camaraderie. -- Khan Noonian
Singh, "Space Seed", stardate 3142.8
---------------------------(end of broadcast)---------------------------
TIP 4: Don't 'kill -9' the postmaster

Nov 11 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.