By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
464,301 Members | 1,280 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 464,301 IT Pros & Developers. It's quick & easy.

Installation problem: can't find $libdir

P: n/a
Hello,
I've been trying to automate the installation of a PG 7.3.3 database on
a new machine, starting with a tarball containing the 'binaries' for the
system (i.e., everything but PGDATA). (The idea is to avoid
distributing, compiling and cleaning up a full source distro.) I can get
the initdb to work correctly, and the postmaster starts, but my attempt
in install plpgsql into the database fails with:

[root@cheviot postgres]# LD_LIBRARY_PATH=/usr/antura/postgres/lib;export
LD_LIBRARY_PATH; su -l antura -c "createlang plpgsql template1"
ERROR: stat failed on file '$libdir/plpgsql': No such file or directory
createlang: language installation failed

Here, antura is the postgres superuser, and (for this example) I've
tried setting LD_LIBRARY_PATH as as shown, even tho' the plpgsql.so
shareable lives in LD_LIBRARY_PATH/postgresql in 7.3.3. I've tried all
combinations of libdir, LIBDIR, and paths, but always get the same
error. The env variable doesn't appear to be set when the language
handler is being created.

Has anyone seen anything like this?
Rich Cullingford
rc******@sysd.com
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 11 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.