472,811 Members | 1,377 Online
Bytes | Software Development & Data Engineering Community
Post Job

Home Posts Topics Members FAQ

Join Bytes to post your question to a community of 472,811 software developers and data experts.

Installation problem: can't find $libdir

I've been trying to automate the installation of a PG 7.3.3 database on
a new machine, starting with a tarball containing the 'binaries' for the
system (i.e., everything but PGDATA). (The idea is to avoid
distributing, compiling and cleaning up a full source distro.) I can get
the initdb to work correctly, and the postmaster starts, but my attempt
in install plpgsql into the database fails with:

[root@cheviot postgres]# LD_LIBRARY_PATH=/usr/antura/postgres/lib;export
LD_LIBRARY_PATH; su -l antura -c "createlang plpgsql template1"
ERROR: stat failed on file '$libdir/plpgsql': No such file or directory
createlang: language installation failed

Here, antura is the postgres superuser, and (for this example) I've
tried setting LD_LIBRARY_PATH as as shown, even tho' the plpgsql.so
shareable lives in LD_LIBRARY_PATH/postgresql in 7.3.3. I've tried all
combinations of libdir, LIBDIR, and paths, but always get the same
error. The env variable doesn't appear to be set when the language
handler is being created.

Has anyone seen anything like this?
Rich Cullingford
---------------------------(end of broadcast)---------------------------
TIP 3: if posting/reading through Usenet, please send an appropriate
subscribe-nomail command to ma*******@postgresql.org so that your
message can get through to the mailing list cleanly

Nov 11 '05 #1
0 3026

This thread has been closed and replies have been disabled. Please start a new discussion.

Similar topics

by: Ghislain Benrais | last post by:
Hello, My "problem" : install php's XSLT API. 1)I installed Sablotron (with the rpm) : ok 2) I read every where that the next step was to compile php with option --with-xslt-sablot. Since I have...
by: Chris Moy | last post by:
SEND-PR: -*- send-pr -*- SEND-PR: Lines starting with `SEND-PR' will be removed automatically, as SEND-PR: will all comments (text enclosed in `<' and `>'). SEND-PR: From: moyc To:...
by: Nigel J. Andrews | last post by:
The subject says it really. Is there a way to query the value of $libdir, and I don't mean the dynamic_library_path GUC? I ask because, I have scripts to create databases and I've come to make...
by: mb12036 | last post by:
All- Having a problem installing a DB2 client on a machine running AIX version 5.0. Client appeared to install one time succesfully, then was uninstalled and a reinstall was attempted. For...
by: Clodoaldo Pinto Neto | last post by:
Hi all, I'm restoring a database from 7.3.4 FC1 to 7.4.2 FC2: $ pg_restore -d KakaoStats KakaoStats.dump pg_restore: could not execute query: ERROR: could not access file...
by: David Parker | last post by:
I need to be able to build postgres (7.4.3) with a given --prefix, but then pack up the installation directory and deploy it in another directory (as part of a product install, for instance). I...
by: yogesh | last post by:
if i run my make file i am getting all the lines error .... can any one tell abt this my make file consist of the detais # cat Makefile_adm PRJ=adm.cgi _INSTALLDIR=../bin INSTALLUSER=root...
by: pbmods | last post by:
Today while troubleshooting a server that didn't want to upgrade to PHP5 (who knew that if you add the line in httpd.conf to load the php5 module and forget to comment out the line in httpd.conf that...
by: =?Utf-8?B?R3JlZw==?= | last post by:
I have no idea where to post this question, or even if its appropriate for me to post it here. I don't know if installing a VB.Net program has caused the problem I'm having or not. All I know is I...
by: erikbower65 | last post by:
Using CodiumAI's pr-agent is simple and powerful. Follow these steps: 1. Install CodiumAI CLI: Ensure Node.js is installed, then run 'npm install -g codiumai' in the terminal. 2. Connect to...
by: linyimin | last post by:
Spring Startup Analyzer generates an interactive Spring application startup report that lets you understand what contributes to the application startup time and helps to optimize it. Support for...
by: erikbower65 | last post by:
Here's a concise step-by-step guide for manually installing IntelliJ IDEA: 1. Download: Visit the official JetBrains website and download the IntelliJ IDEA Community or Ultimate edition based on...
by: kcodez | last post by:
As a H5 game development enthusiast, I recently wrote a very interesting little game - Toy Claw ((http://claw.kjeek.com/))。Here I will summarize and share the development experience here, and hope it...
by: Taofi | last post by:
I try to insert a new record but the error message says the number of query names and destination fields are not the same This are my field names ID, Budgeted, Actual, Status and Differences ...
by: DJRhino1175 | last post by:
When I run this code I get an error, its Run-time error# 424 Object required...This is my first attempt at doing something like this. I test the entire code and it worked until I added this - If...
by: DJRhino | last post by:
Private Sub CboDrawingID_BeforeUpdate(Cancel As Integer) If = 310029923 Or 310030138 Or 310030152 Or 310030346 Or 310030348 Or _ 310030356 Or 310030359 Or 310030362 Or...
by: lllomh | last post by:
How does React native implement an English player?
by: Mushico | last post by:
How to calculate date of retirement from date of birth

By using Bytes.com and it's services, you agree to our Privacy Policy and Terms of Use.

To disable or enable advertisements and analytics tracking please visit the manage ads & tracking page.