By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,640 Members | 2,279 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,640 IT Pros & Developers. It's quick & easy.

Installing GD-Lib on Win/IIS => PHP "dead"

P: n/a
Hello,

I have a windows-IIS-Webserver running PHP 4.3.0. However, there is no
GD-Lib, so I tried to install it.

What I did is this:
- copy the file php_gd2.dll (which I have from another win-webserver with
working GD-Lib) to C:\PHP\extensions
- set the extensions-folder in php.ini to C:\PHP\extensions
- remove the ";" before the php_gd2.dll-inclusion in the php.ini-file
- I even added C:\PHP\extension to the path-environment-variable

And what happens is this:
- PHP is completely "dead", there is no output, just endless waiting. Not
even phpinfo() works
- the webserver itself is fine, HTML-Files and images are sent to the
browser correctly
- as soon as I add the ";" in the php_gd2.dll-line in php.ini, PHP works
fine again - but without GD-Lib, of course

I spent quite some time searching in google for the solution, but I found
nothing helpful...
I'd grateful if someone could help me.

Kind regards and thanks,
Paul
-- www.eigelb.at
Jul 17 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
The reason is that PHP fail to startup.
Your extensions-dir is not correctly installed. Check
http://www.macromedia.com/devnet/mx/...s/php_iis.html
"Paul Schmidinger" <my************@my.website.eigelb.at> wrote in message
news:cr**********@news.hispeed.ch...
Hello,

I have a windows-IIS-Webserver running PHP 4.3.0. However, there is no
GD-Lib, so I tried to install it.

What I did is this:
- copy the file php_gd2.dll (which I have from another win-webserver with
working GD-Lib) to C:\PHP\extensions
- set the extensions-folder in php.ini to C:\PHP\extensions
- remove the ";" before the php_gd2.dll-inclusion in the php.ini-file
- I even added C:\PHP\extension to the path-environment-variable

And what happens is this:
- PHP is completely "dead", there is no output, just endless waiting. Not
even phpinfo() works
- the webserver itself is fine, HTML-Files and images are sent to the
browser correctly
- as soon as I add the ";" in the php_gd2.dll-line in php.ini, PHP works
fine again - but without GD-Lib, of course

I spent quite some time searching in google for the solution, but I found
nothing helpful...
I'd grateful if someone could help me.

Kind regards and thanks,
Paul
-- www.eigelb.at

Jul 17 '05 #2

P: n/a
I read the page, but it gives me no information that I've not had before...!
Any other ideas...?

"J.M. Sjouken" <sj*****@iae.nl> schrieb im Newsbeitrag
news:cr**********@voyager.news.surf.net...
The reason is that PHP fail to startup.
Your extensions-dir is not correctly installed. Check
http://www.macromedia.com/devnet/mx/...s/php_iis.html

Jul 17 '05 #3

P: n/a
I have one more but of information: I managed to install another extension
(curl) -- there were no problems, so the extension-directory is OK.
The problem ist just with the GD-Lib...
Jul 17 '05 #4

P: n/a
The problem is solved! I hade to change "permissions" for the php_gd2.dll.
That was not necessary for some other extensions like e. g. curl -- strange.

Thanks everybody,
Paul
Jul 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.