By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,731 Members | 1,123 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,731 IT Pros & Developers. It's quick & easy.

Warning: fopen(): URL file-access is disabled in the server

P: n/a
I ve been trying php script sent by rchaplin and all goes ok
automatically appears a new file copied after script execution but it
appears a messaje like next one:

Warning: fopen(): URL file-access is disabled in the server
configuration in /home/freehost/t35.com/n/a/nacion/p/new.php on line
10

and then the new file is empty.
How can I solve that?
Marcos
Jul 17 '05 #1
Share this Question
Share on Google+
8 Replies


P: n/a
Hello,

on 12/29/2004 02:08 AM ARGENTINA said the following:
I ve been trying php script sent by rchaplin and all goes ok
automatically appears a new file copied after script execution but it
appears a messaje like next one:

Warning: fopen(): URL file-access is disabled in the server
configuration in /home/freehost/t35.com/n/a/nacion/p/new.php on line
10

and then the new file is empty.
How can I solve that?


It seems your host disallowed getting remote pages with fopen. You may
want to try this HTTP client class but I suspect that fsockopen calls
may be disallowed too. In any case, you can always try it to see if you
have any luck.

http://www.phpclasses.org/httpclient

--

Regards,
Manuel Lemos

PHP Classes - Free ready to use OOP components written in PHP
http://www.phpclasses.org/

PHP Reviews - Reviews of PHP books and other products
http://www.phpclasses.org/reviews/

Metastorage - Data object relational mapping layer generator
http://www.meta-language.net/metastorage.html
Jul 17 '05 #2

P: n/a
Errr dude, i suggest just chmod 'ing the file.. you can do this a few
ways, the chmod() function.. ( chmod(file,number) ) , read up on
php.net about that one if you really want to use it.. because some
servers may or may not let you do that. Otherwise, log onto either
your webservers filemanager, or use IE (eh i know, but i'm not quite
sure how to get firefox to do this) to FTP to the page, right click,
and change the file permissions to allow users to write/access/execute
the file as nessicary.

Jul 17 '05 #3

P: n/a
"jblanch" <jb*****@gmail.com> wrote in message
news:11**********************@f14g2000cwb.googlegr oups.com...
Errr dude, i suggest just chmod 'ing the file..


Errr dude, I suggest reading the OP's question carefully first:

Warning: fopen(): URL file-access is disabled in the server
^^^^^^^^^^^^^^^
configuration in /home/freehost/t35.com/n/a/nacion/p/new.php on line
10

Jul 17 '05 #4

P: n/a
Do we need to be a dick? i'm trying to help.

Jul 17 '05 #5

P: n/a
Do we need to be a dick? i'm trying to help.

Jul 17 '05 #6

P: n/a
Do we need to be a dick? i'm trying to help.

Jul 17 '05 #7

P: n/a
"jblanch" <jb*****@gmail.com> wrote in message
news:11**********************@c13g2000cwb.googlegr oups.com...
Do we need to be a dick? i'm trying to help.


You might try looking in a mirror before casting aspersions.
Jul 17 '05 #8

P: n/a
"Manuel Lemos" <ml****@acm.org> wrote in message
news:33*************@individual.net...
Hello,

on 12/29/2004 02:08 AM ARGENTINA said the following:
I ve been trying php script sent by rchaplin and all goes ok
automatically appears a new file copied after script execution but it
appears a messaje like next one:

Warning: fopen(): URL file-access is disabled in the server
configuration in /home/freehost/t35.com/n/a/nacion/p/new.php on line
10

and then the new file is empty.
How can I solve that?


It seems your host disallowed getting remote pages with fopen. You may
want to try this HTTP client class but I suspect that fsockopen calls
may be disallowed too. In any case, you can always try it to see if you
have any luck.

http://www.phpclasses.org/httpclient


allow_url_fopen only controls stream wrappers. The ISP might have disabled
it just to prevent PHP injection exploits. fsockopen should still work
unless it's explicitly forbidden.
Jul 17 '05 #9

This discussion thread is closed

Replies have been disabled for this discussion.