By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,661 Members | 781 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,661 IT Pros & Developers. It's quick & easy.

PHP Session Problem

P: n/a
Hello,

When I use Session in my php code, the first time a session is
establish, every link on that page (where the session starts)
contains the PHPSESSID in the query.

For example:
session.php?PHPSESSID=d3994a591c42b9d3bba48ae65434 1482

If we follow the link, the PHPSESSID disapears, which makes sence to me
because the ID was added as a "cookie" to the browser and there is no
need to continue to be in the URL.

My question is, can I avoid this? (because of search engines)

I have tried in 3 different hosts and it happens in all of them. Except
in my localhost machine, don't know the reason why.

Can someone help me?

Here is the code. Just paste it in a file named session.php

<?php
session_start();
print "<html><a href=\"session.php\">Test the problem</a></html>";
?>

Thanks,
Fred

Jul 17 '05 #1
Share this Question
Share on Google+
3 Replies


P: n/a
Fred wrote [edited]:
My question is, can I avoid [session ids in URLs]?
<snip>
Here is the code. Just paste it in a file named session.php

<?php
Try one or both of these:

ini_set('session.use_trans_sid', '0');
ini_set('session.use_only_cookies', '1');
session_start();
print "<html><a href=\"session.php\">Test the problem</a></html>";
?>


--
Mail to my "From:" address is readable by all at http://www.dodgeit.com/
== ** ## !! ------------------------------------------------ !! ## ** ==
TEXT-ONLY mail to the whole "Reply-To:" address ("My Name" <my@address>)
may bypass my spam filter. If it does, I may reply from another address!
Jul 17 '05 #2

P: n/a
Dear Pedro,

I have tried your sugestion.

It works on PHP Version 4.2.3 but NOT on the recent Version 4.3.9.
Bad luck for me, because what I want is in Version 4.3.9
Any other ideas? :(

Thank you,
Fred

Jul 17 '05 #3

P: n/a
Hello,

So, I tried with ini_set("url_rewriter.tags",""); and it worked.

http://martin.f2o.org/php/session, this page has it all.

Thanks for the help anyway. Could not have done it without you.
Regards,
Fred

Jul 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.