By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,082 Members | 2,135 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,082 IT Pros & Developers. It's quick & easy.

cannot load mysql extension

P: n/a
I posted this to the sourceforge phpMyAdmin ng, but there was a comment
that it was properly a php question, so I'm posting it here.

I'm on Windows XP, and have just installed Apache, php 5, and
phpMyadmin from zipped binaries. The only thing irregular thing I’m
conscious of doing is unpack phpMyadmin, files and directories,
directly into \Apache2\htdocs, because that was the only place I knew I
could reach with the <http://localhost> syntax. The phpMyadmin book I’m
using focuses on domains, and not local file-based installations, so
I’m floundering a bit here.

I believe I have php flying, because I can use Firefox to browse to
http://localhost/phpinfo.php and see the HTML-like display in the
browser. I created a little echo-the-date .php and put it in
\Apache2\htdocs, it renders the date in Firefox properly. The
_SERVER["SERVER_SOFTWARE"] entry reported by phpinfo is “Apache/2.0.52
(Win32) PHP/5.0.2.”

I have uncommented extension=php_mysql.dll in php.ini, and set
extension_dir to "c:\php5\ext". I copied libmysql.dll and php_mysql.dll
to ..\system32. In fact, I have nine copies of libmysql.dll in six
different file sizes on my system. (Could that be the problem-battling
DLLs?)

Per page 18 of Jason Gilmore’s “Beginning PHP 5 and MySQL,” I added
“index.php” to httpd.conf’s DirectoryIndex entry.

However, when I attempt to browse to <http://localhost/index.php>,
which is the configuration test for phpMyadmin, I get the dread--
cannot load mysql extension,
please check PHP Configuration
Documentation

I imagine this is some little thing in my.ini, httpd.conf, or php.ini.
Any suggestions?

Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Kevin wrote:
I posted this to the sourceforge phpMyAdmin ng, but there was a
comment that it was properly a php question, so I'm posting it here.

I'm on Windows XP, and have just installed Apache, php 5, and
phpMyadmin from zipped binaries. The only thing irregular thing I’m
conscious of doing is unpack phpMyadmin, files and directories,
directly into \Apache2\htdocs, because that was the only place I knew
I could reach with the <http://localhost> syntax. The phpMyadmin book
I’m using focuses on domains, and not local file-based installations,
so I’m floundering a bit here.

I believe I have php flying, because I can use Firefox to browse to
http://localhost/phpinfo.php and see the HTML-like display in the
browser. I created a little echo-the-date .php and put it in
\Apache2\htdocs, it renders the date in Firefox properly. The
_SERVER["SERVER_SOFTWARE"] entry reported by phpinfo is “Apache/2.0.52
(Win32) PHP/5.0.2.”

I have uncommented extension=php_mysql.dll in php.ini, and set
extension_dir to "c:\php5\ext". I copied libmysql.dll and
php_mysql.dll to ..\system32. In fact, I have nine copies of
libmysql.dll in six different file sizes on my system. (Could that be
the problem-battling DLLs?)

Per page 18 of Jason Gilmore’s “Beginning PHP 5 and MySQL,” I added
“index.php” to httpd.conf’s DirectoryIndex entry.

However, when I attempt to browse to <http://localhost/index.php>,
which is the configuration test for phpMyadmin, I get the dread--
cannot load mysql extension,
please check PHP Configuration
Documentation

I imagine this is some little thing in my.ini, httpd.conf, or php.ini.
Any suggestions?


Added php5 to my path. That did it.
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.