By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,303 Members | 1,245 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,303 IT Pros & Developers. It's quick & easy.

Error failed dependecies : libmysqlclient.so.10 is needed?

P: n/a
BT
Hi,

I am trying to install php-mysql-4.0.6-7.i386.rpm(to get php to work
with mysql as suggested for my earlier error). I get the following
error for
rpm -i php-mysql-4.0.6-7.i386.rpm.

Error failed dependecies : libmysqlclient.so.10 is needed is needed by
php-mysql-4.0.6-7.

The libmysqlclient.so.12 exists at /var/lib/ but not
libmysqlclient.so.10.

I have the following rpms installed on RH 7.2.
MySQL-client-4.0.14-0
MySQL-shared-4.0.14-0
MySQL-server-4.0.14-0
MySQL-devel-4.0.14-0
php-imap-4.0.6-7
php-4.0.6-7
apache-1.3.20-16
apache-devel-1.3.20-16
apacheconf-0.8.1-1

What am i missing? And how can i correct this problem?
There were no errors while installing the above rpms.

I would appreciate your help and suggestions.

TIA
-BT
Jul 16 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.