470,862 Members | 1,776 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,862 developers. It's quick & easy.

Sessions problems

I'm trying to use session_set_save_handler to save session to mysql. I
have found alot of great examples and everything works except garbage
collection. which results in the following.

Unknown: A session is active. You cannot change the session module's
ini settings at this time. in Unknown on line 0

after a few hours of googleing and bug searching at php.net I have
found alot of posts regarding this problem. None appear to be recent
and none appear to have a solution.

I'm using gentoo with kernal 2.6.8.1, php 5.0.1, mysql 4.

Is this still a bug or has it been fixed?

Thanks in advance.

Jason
Jul 17 '05 #1
2 1540
py
Jason wrote:
I'm trying to use session_set_save_handler to save session to mysql. I
have found alot of great examples and everything works except garbage
collection. which results in the following.

Unknown: A session is active. You cannot change the session module's
ini settings at this time. in Unknown on line 0

after a few hours of googleing and bug searching at php.net I have
found alot of posts regarding this problem. None appear to be recent
and none appear to have a solution.

I'm using gentoo with kernal 2.6.8.1, php 5.0.1, mysql 4.

Is this still a bug or has it been fixed?

Thanks in advance.

Jason


If you look at your code closely, are you sure you did not start the
session in the page you are having a problem before an ini_set command
like :
ini_set("session.gc_probability", "100");

By the way you should leave this to 100 while debugging...

py

p.s. you should post your code.
Jul 17 '05 #2
"Jason" <jw******@sfcn.org> wrote in message
news:3c**************************@posting.google.c om...
I'm trying to use session_set_save_handler to save session to mysql. I
have found alot of great examples and everything works except garbage
collection. which results in the following.

Unknown: A session is active. You cannot change the session module's
ini settings at this time. in Unknown on line 0

after a few hours of googleing and bug searching at php.net I have
found alot of posts regarding this problem. None appear to be recent
and none appear to have a solution.

I'm using gentoo with kernal 2.6.8.1, php 5.0.1, mysql 4.

Is this still a bug or has it been fixed?

Thanks in advance.

Jason


Check your php.ini. session.auto_start might be turned on.
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

2 posts views Thread by The Plankmeister | last post: by
22 posts views Thread by Theo | last post: by
9 posts views Thread by Bartosz Wegrzyn | last post: by
10 posts views Thread by Mark H | last post: by
1 post views Thread by Nick McGrath | last post: by
6 posts views Thread by Paul | last post: by
2 posts views Thread by Harald | last post: by
6 posts views Thread by Daniel Walzenbach | last post: by
3 posts views Thread by jantox | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.