By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,721 Members | 1,217 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,721 IT Pros & Developers. It's quick & easy.

mt_rand not at all random?

P: n/a
Hi,

The following script:

<?php echo mt_rand();?>

always outputs "1755202938" on my machine. I'm running PHP 4.2.3 under
Windows XP.

According to the docs:
"As of PHP 4.2.0, there is no need to seed the random number generator with
srand() or mt_srand() as this is now done automatically."

So why the non-random behavior?
- Kevin
Jul 17 '05 #1
Share this Question
Share on Google+
2 Replies


P: n/a
*** Kevin Lin wrote/escribió (Thu, 07 Oct 2004 01:20:32 GMT):
<?php echo mt_rand();?>

always outputs "1755202938" on my machine. I'm running PHP 4.2.3 under
Windows XP.

According to the docs:
"As of PHP 4.2.0, there is no need to seed the random number generator with
srand() or mt_srand() as this is now done automatically."


It might be a bug in your release. I've tested under 4.2.2 (Red Hat Linux)
and values are always different. Do you get random values if you do seed
the generator?

It could also be that it doesn't work this way under Windows but docs do
not mention it :-?
--
-- Álvaro G. Vicario - Burgos, Spain
-- Thank you for not e-mailing me your questions
--
Jul 17 '05 #2

P: n/a
Follow-up for anyone who runs into this same problem:

I upgraded to PHP 4.2.9 and the bug seems to be fixed.

"Kevin Lin" <ke***@wx3REMOVE4SPAM.com> wrote in message
news:AR09d.200976$D%.61311@attbi_s51...
Hi,

The following script:

<?php echo mt_rand();?>

always outputs "1755202938" on my machine. I'm running PHP 4.2.3 under
Windows XP.

According to the docs:
"As of PHP 4.2.0, there is no need to seed the random number generator with srand() or mt_srand() as this is now done automatically."

So why the non-random behavior?
- Kevin

Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.