By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
435,131 Members | 1,494 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 435,131 IT Pros & Developers. It's quick & easy.

phpMyAdmin MY#1045 - Access denied for user 'root'@'localhost' (using password: NO)

P: 4
Hello All

I have successfully installed the following

IIS ver 6
php ver 4.4.9
MYSQL ver 5.0.67

when i tested through command line i get no error and i am view the php pages on the browser without any hitch. In the beginning when i was trying to connect to MYSQL through simple php script i was getting an authentication error which i could resolve by using OLD_PASSWORD.

Now during final stages ,
Now when i have installed phpMyAdmin ver 2.0.8.3and have also configured config.inc.php. There is persistent error i am getting which is something like

MYSQL says #1045 - Access denied for user 'root'@'localhost' (using password: NO)


I have tried OLD_PASSWORD technique which won't work. I have almost wasted 2 days on this. Can someone really suggest how to come out of this and make phpMyAdmin work .
Oct 29 '08 #1
Share this Question
Share on Google+
4 Replies


P: 18
hi,

you just blank the password. not need key in any password.
Oct 29 '08 #2

P: 4
HI
Configuration in my conf.inc.php looks like this.

Expand|Select|Wrap|Line Numbers
  1. $cfg['Servers'][$i]['host']          = 'localhost'; // MySQL hostname or IP address
  2. $cfg['Servers'][$i]['port']          = '3306';          // MySQL port - leave blank for default port
  3. $cfg['Servers'][$i]['socket']        = '';          // Path to the socket - leave blank for default socket
  4. $cfg['Servers'][$i]['connect_type']  = 'tcp';       // How to connect to MySQL server ('tcp' or 'socket')
  5. $cfg['Servers'][$i]['extension']     = 'mysql';     // The php MySQL extension to use ('mysql' or 'mysqli')
  6. $cfg['Servers'][$i]['compress']      = FALSE;       // Use compressed protocol for the MySQL connection
  7.                                                     // (requires PHP >= 4.3.0)
  8. $cfg['Servers'][$i]['controluser']   = '';          // MySQL control user settings
  9.                                                     // (this user must have read-only
  10. $cfg['Servers'][$i]['controlpass']   = '';          // access to the "mysql/user"
  11.                                                     // and "mysql/db" tables).
  12.                                                     // The controluser is also
  13.                                                     // used for all relational
  14.                                                     // features (pmadb)
  15. $cfg['Servers'][$i]['auth_type']     = 'config';    // Authentication method (config, http or cookie based)?
  16. $cfg['Servers'][$i]['user']          = 'root';      // MySQL user
  17. $cfg['Servers'][$i]['password']      = 'password';          // MySQL password (only needed
  18.                                                     // with 'config' auth_type)
  19.  
Blanking the password does,nt do any good to me. I still get the same error. User is root and Password is password in my configuration. through command line everything is ok.

pearl
Oct 29 '08 #3

P: 4
hi,

you just blank the password. not need key in any password.
It's not helping that way..thanks though for early response..any other way out.
Oct 29 '08 #4

dlite922
Expert 100+
P: 1,584
It's not helping that way..thanks though for early response..any other way out.
can you "ping localhost" from the command line.

If it's Linux, you may not have localhost set as a host name.



Dan
Oct 30 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.