By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,664 Members | 1,656 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,664 IT Pros & Developers. It's quick & easy.

https wrapper

P: n/a
We're running PHP4.3 on a Solaris 9 box. PHP was compiled with the
following option:

'--with-openssl=/usr/local/ssl'

phpinfo() suggests that openssl is enabled. However, when we try to use
fopen with an https:// URL we receive the following message:

[24-Oct-2008 14:20:12] PHP Notice: fopen(): Unable to find the wrapper
"https" - did you forget to enable it when you configured PHP?
in /u1/www/htdocs/f.php on line 8
[24-Oct-2008 14:20:12] PHP Warning: fopen(https://wwww.our.site/):
failed to open stream: No such file or directory in /u1/www/htdocs/f.php
on line 8
"www.our.site" is our intranet site, which runs Apache with the same
version of OpenSSL as PHP is using.

Has anyone else encountered this problem? I'm wondering if we need to
enable something in php.ini but a bit of googling seems to suggest that
it should just work...
Oct 24 '08 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.