By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,747 Members | 2,039 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,747 IT Pros & Developers. It's quick & easy.

Not displaying erros

P: n/a
Ok I have posted this before and did not get the answer I was looking for
so i will explain it again.

Whenever there is a syntax error, or parse error etc in php it does not
display the error. ie

Warning: main(./includes/file.php):failed to open stream ....... blah blah
blah

I dont get these errors at all ( even though they are there! ) all i get is
either nothing or a server 500 error. What the problem? .ini issue?

please help

ta
Oct 1 '08 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Tree*Rat wrote:
Ok I have posted this before and did not get the answer I was looking for
so i will explain it again.

Whenever there is a syntax error, or parse error etc in php it does not
display the error. ie

Warning: main(./includes/file.php):failed to open stream ....... blah blah
blah

I dont get these errors at all ( even though they are there! ) all i get is
either nothing or a server 500 error. What the problem? .ini issue?

please help

ta
Ensure the php.ini file in your development system has:

display_errors=on
error_reporting=E_ALL

(and ensure you are editing the correct php.ini file).
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Oct 1 '08 #2

P: n/a
Jerry Stuckle wrote:
Tree*Rat wrote:
>Ok I have posted this before and did not get the answer I was looking
for so i will explain it again.

Whenever there is a syntax error, or parse error etc in php it does
not display the error. ie

Warning: main(./includes/file.php):failed to open stream ....... blah
blah blah

I dont get these errors at all ( even though they are there! ) all i
get is either nothing or a server 500 error. What the problem? .ini
issue?

please help

ta

Ensure the php.ini file in your development system has:

display_errors=on
error_reporting=E_ALL

(and ensure you are editing the correct php.ini file).

DeJaVue ;)

scotty
Oct 2 '08 #3

This discussion thread is closed

Replies have been disabled for this discussion.