By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,851 Members | 1,041 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,851 IT Pros & Developers. It's quick & easy.

PHP5 ISAPI on IIS7 - cURL wont load

P: 3
I have installed PHP5 as ISAPI several times per every single guide I could find in the first 50 pages of results on google..

Server is Windows 2008 runing IIS7, phpinfo works and tells me the configuration..
but there is an issue.. i see the following..
Configuration File (php.ini) Path C:\Windows
Loaded Configuration File C:\php\php.ini

PHP in installed to C:\php and the php.ini ONLY exists in that location and the permissions for c:\php is set to EVERYONE - FULL ACCESS (did this for trouble shooting) I have the extension=php_curl.dll un-commented
but curl does not show up on the phpinfo configuration page.. oddly enough when i run "php.exe -i" from command-line it does in fact load curl

I installed php from .zip (manually) not from the installer

-I have added the path to the registry (per 2 different guides) I have set the permissions on the registry key to everyone full access (for testing)
- set PHPRC
- added C:\php to "Path"
- Set permissions on C:\php and all sub files and folder to everyone full access
- moved php.ini to c:\windows
- moved php.ini to c:\windows and set permission to everyone full access
- rebooted server 4 times
- restarted / shutdown - start IIS services va IIS Manager and command line about 30 times
- checked install of php against every guide i could find to make sure it was correct..

No matter what I do I cant get phpinfo to show curl as loaded..

Any help would be great..but dont tell me to load Apache every single post i find regarding this issue they say just load Apache.. that's not an option is this setup
Sep 29 '08 #1
Share this Question
Share on Google+
5 Replies


Atli
Expert 5K+
P: 5,058
Hi.

The only thing I can think up at the moment is...
Check the extension_dir directive in your PHP.ini file. Try setting that to an absolute path to your extension directory.

I'm not sure, but doesn't Curl require additional .dll's on Windows?
Make sure the path to that is also in the PATH variable.

And, seeing as this is Windows, try rebooting a few more times.
Sep 29 '08 #2

P: 3
Hi.

The only thing I can think up at the moment is...
Check the extension_dir directive in your PHP.ini file. Try setting that to an absolute path to your extension directory.

I'm not sure, but doesn't Curl require additional .dll's on Windows?
Make sure the path to that is also in the PATH variable.

And, seeing as this is Windows, try rebooting a few more times.
Checked extension_dir directive (saw several guides talking about this) didnt change anything..

cURL does require .dll's but i already copyed those to the ext folder AND the windows\system32 folder didnt make any difference..

I have now rebooted this server about 5 times today.. btw..

whats stumping me is changes I make to c:\php\php.ini are taking effect.. except when i enable cURL.. i get no errors is just doesn't load it, but it does when i execute php from command line..
Sep 29 '08 #3

Atli
Expert 5K+
P: 5,058
Strange.

Last time I needed Curl on Windows I just had to uncomment the line in the PHP.ini file.

The libeay32.dll and ssleay32.dll files were already in the PHP install path (I used the Zip package) and I had already added that directory to the PATH variable.

I was using Apache tho, but I can't see why that would matter.

But just in case, you could try installing Apache, just to see if the Curl extension is working. If it works with Apache, you would know the problem is with IIS rather than your PHP configuration.

If that is the case, you could even configure Apache to work on a different port and have your scripts redirect there whenever the Curl script is needed.
Or you could execute your Curl script in CGI mode as a shell command.
Sep 29 '08 #4

P: 3
Strange.

Last time I needed Curl on Windows I just had to uncomment the line in the PHP.ini file.

The libeay32.dll and ssleay32.dll files were already in the PHP install path (I used the Zip package) and I had already added that directory to the PATH variable.

I was using Apache tho, but I can't see why that would matter.

But just in case, you could try installing Apache, just to see if the Curl extension is working. If it works with Apache, you would know the problem is with IIS rather than your PHP configuration.

If that is the case, you could even configure Apache to work on a different port and have your scripts redirect there whenever the Curl script is needed.
Or you could execute your Curl script in CGI mode as a shell command.
Cant use Apache on the server I said that already.

For some reason IIS isnt executing curl I can manually run php.exe from command line all day long and it will load up curl just fine but when i start up IIS services its just not loading that portion of the config. I have even sat down with clean php.ini configs and started from scratch makes no difference.. It loads the add-ins only when executing php.exe directly

I have noticed that it doesn't seam to execute anything I tell it to add.. i can uncomment all the add-ins and it doesn't attempt to load any of them. but again if I manually execute php.exe it works fine..
Sep 29 '08 #5

SKJoy2001
P: 2
I have the same trouble. Additionally, when I check the PHPInfo(), I get the following;

Configuration File (php.ini) Path C:\Windows
Loaded Configuration File (none)

Using IIS 7 on Windows 7 Ultimate Beta Build 7077 x64 Bit with PHP 5.2.9-2 as an ISAPI module.

Anyone with any help?
May 17 '09 #6

Post your reply

Sign in to post your reply or Sign up for a free account.