By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
446,213 Members | 1,117 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 446,213 IT Pros & Developers. It's quick & easy.

oci8 not showing in phpinfo()

P: n/a
Hello All,

I have reviewed various posts in regard to Oracle and PHP.
I am running Apache 2.0.59, on Windows XP, with PHP 5.2.

I would like to connect using PHP to a remote oracle db (ver. 7)
I have uncommented out the php_oci8.dll and the older php_oracle.dll
in the php.ini file
the ini file resides in c:\php\php.ini

The oracle info page (http://www.oracle.com/technology/pub/notes/
technote_php_instant.html) outlines the steps for this.

I have stopped and restarted apache, no luck, I do not see support for
oracle on the info page.
I do see mysql, etc.

I have the path set to the location for the oracle dlls, etc.

I can connect to the db using MS Access and the file dsn.

any idea what I am missing?
eholz1
Jun 27 '08 #1
Share this Question
Share on Google+
7 Replies


P: n/a
eholz1 wrote:
I have uncommented out the php_oci8.dll and the older php_oracle.dll
in the php.ini file
the ini file resides in c:\php\php.ini
Let's make sure, just for the sake of it...

Put a call in any one of your pages to phpinfo(); check that the.ini file
loaded matches the oen you modified, and that there is some information
about the oci8 module being loaded.

--
----------------------------------
Iván Sánchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-

Más vale ser cobarde un minuto, que muerto todo el resto de la vida.
Jun 27 '08 #2

P: n/a
On Jun 19, 2:34 pm, Ivn Snchez Ortega <ivansanchez-...@rroba-
escomposlinux.-.punto.-.orgwrote:
eholz1 wrote:
I have uncommented out the php_oci8.dll and the older php_oracle.dll
in the php.ini file
the ini file resides in c:\php\php.ini

Let's make sure, just for the sake of it...

Put a call in any one of your pages to phpinfo(); check that the.ini file
loaded matches the oen you modified, and that there is some information
about the oci8 module being loaded.

--
----------------------------------
Ivn Snchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-

Ms vale ser cobarde un minuto, que muerto todo el resto de la vida.
Ha, I did think of that. I went to my php.ini file, and added a
comment char (;) to the mysqli extension line to see if it WOULD NOT
SHOW in my phpinfo page if I had a comment in front of the line. It
worked, put semi-colon in front of line, and no mysqli info on my
phpinfo page. if I remove the comment from that line, the mysqli
extension info appears.

So, for some unknown reason, the oci8 extension, commented or not does
not show. I do have a PATH statement that has the path to the oracle
dlls (for Oracle instantclient), and the php_oci8.dll file does exist
in my c:\php\ext directory. I guess I am out of luck.

Muchas Gracias

eholz1
Jun 27 '08 #3

P: n/a
eholz1 wrote:
[...] and the php_oci8.dll file does exist
in my c:\php\ext directory. I guess I am out of luck.
Well, I'm not a windows kind of guy, so let me ask: from where did you
download both PHP and the oracle libraries?

Also, have you tried to put the full path to the oracle library in php.ini?
Any relevant messages in the Apache logs?
Cheers,
--
----------------------------------
Iván Sánchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-

Proudly running Debian Linux with 2.6.24-1-amd64 kernel, KDE 3.5.9, and PHP
5.2.6-1 generating this signature.
Uptime: 00:54:42 up 11 days, 8:42, 4 users, load average: 0.93, 0.91,
0.82

Jun 27 '08 #4

P: n/a
eholz1 wrote:
On Jun 19, 2:34 pm, Ivn Snchez Ortega <ivansanchez-...@rroba-
escomposlinux.-.punto.-.orgwrote:
>eholz1 wrote:
>>I have uncommented out the php_oci8.dll and the older php_oracle.dll
in the php.ini file
the ini file resides in c:\php\php.ini
Let's make sure, just for the sake of it...

Put a call in any one of your pages to phpinfo(); check that the.ini file
loaded matches the oen you modified, and that there is some information
about the oci8 module being loaded.

--
----------------------------------
Ivn Snchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-

Ms vale ser cobarde un minuto, que muerto todo el resto de la vida.

Ha, I did think of that. I went to my php.ini file, and added a
comment char (;) to the mysqli extension line to see if it WOULD NOT
SHOW in my phpinfo page if I had a comment in front of the line. It
worked, put semi-colon in front of line, and no mysqli info on my
phpinfo page. if I remove the comment from that line, the mysqli
extension info appears.

So, for some unknown reason, the oci8 extension, commented or not does
not show. I do have a PATH statement that has the path to the oracle
dlls (for Oracle instantclient), and the php_oci8.dll file does exist
in my c:\php\ext directory. I guess I am out of luck.

Muchas Gracias

eholz1
This is a typical symptom of not having the correct libraries loaded.
It could be your extension directory, or more likely, the oracle
libraries (or something they require) are not available.

Check your phpinfo() command. Exactly what does it show for
"Configuration File (php.ini) Path". Also, under the "Apache
Environment" section, verify the PATH value - and ensure your Oracle
libraries (and everything they require) are in the PATH.

Also ensure you have the latest Oracle libraries on your system.

Finally - are you loading PHP as a CGI or Apache module?

It's a bit tricky to set up sometimes, but it does work.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Jun 27 '08 #5

P: n/a
On Jun 19, 4:59 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
eholz1 wrote:
On Jun 19, 2:34 pm, Ivn Snchez Ortega <ivansanchez-...@rroba-
escomposlinux.-.punto.-.orgwrote:
eholz1 wrote:
I have uncommented out the php_oci8.dll and the older php_oracle.dll
in the php.ini file
the ini file resides in c:\php\php.ini
Let's make sure, just for the sake of it...
Put a call in any one of your pages to phpinfo(); check that the.ini file
loaded matches the oen you modified, and that there is some information
about the oci8 module being loaded.
--
----------------------------------
Ivn Snchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-
Ms vale ser cobarde un minuto, que muerto todo el resto de la vida.
Ha, I did think of that. I went to my php.ini file, and added a
comment char (;) to the mysqli extension line to see if it WOULD NOT
SHOW in my phpinfo page if I had a comment in front of the line. It
worked, put semi-colon in front of line, and no mysqli info on my
phpinfo page. if I remove the comment from that line, the mysqli
extension info appears.
So, for some unknown reason, the oci8 extension, commented or not does
not show. I do have a PATH statement that has the path to the oracle
dlls (for Oracle instantclient), and the php_oci8.dll file does exist
in my c:\php\ext directory. I guess I am out of luck.
Muchas Gracias
eholz1

This is a typical symptom of not having the correct libraries loaded.
It could be your extension directory, or more likely, the oracle
libraries (or something they require) are not available.

Check your phpinfo() command. Exactly what does it show for
"Configuration File (php.ini) Path". Also, under the "Apache
Environment" section, verify the PATH value - and ensure your Oracle
libraries (and everything they require) are in the PATH.

Also ensure you have the latest Oracle libraries on your system.

Finally - are you loading PHP as a CGI or Apache module?

It's a bit tricky to set up sometimes, but it does work.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================
Hello again,

I will check the items that Jerry mentions - there is a lot to double
check.
I will get back to the group, if successful!
Thanks

eric
Jun 27 '08 #6

P: n/a
eholz1 wrote:
On Jun 19, 4:59 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
>eholz1 wrote:
>>On Jun 19, 2:34 pm, Ivn Snchez Ortega <ivansanchez-...@rroba-
escomposlinux.-.punto.-.orgwrote:
eholz1 wrote:
I have uncommented out the php_oci8.dll and the older php_oracle.dll
in the php.ini file
the ini file resides in c:\php\php.ini
Let's make sure, just for the sake of it...
Put a call in any one of your pages to phpinfo(); check that the.ini file
loaded matches the oen you modified, and that there is some information
about the oci8 module being loaded.
--
----------------------------------
Ivn Snchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-
Ms vale ser cobarde un minuto, que muerto todo el resto de la vida.
Ha, I did think of that. I went to my php.ini file, and added a
comment char (;) to the mysqli extension line to see if it WOULD NOT
SHOW in my phpinfo page if I had a comment in front of the line. It
worked, put semi-colon in front of line, and no mysqli info on my
phpinfo page. if I remove the comment from that line, the mysqli
extension info appears.
So, for some unknown reason, the oci8 extension, commented or not does
not show. I do have a PATH statement that has the path to the oracle
dlls (for Oracle instantclient), and the php_oci8.dll file does exist
in my c:\php\ext directory. I guess I am out of luck.
Muchas Gracias
eholz1
This is a typical symptom of not having the correct libraries loaded.
It could be your extension directory, or more likely, the oracle
libraries (or something they require) are not available.

Check your phpinfo() command. Exactly what does it show for
"Configuration File (php.ini) Path". Also, under the "Apache
Environment" section, verify the PATH value - and ensure your Oracle
libraries (and everything they require) are in the PATH.

Also ensure you have the latest Oracle libraries on your system.

Finally - are you loading PHP as a CGI or Apache module?

It's a bit tricky to set up sometimes, but it does work.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================

Hello again,

I will check the items that Jerry mentions - there is a lot to double
check.
I will get back to the group, if successful!
Thanks

eric
Come back if you're not successful, also - we'll try some other things! :-)

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Jun 27 '08 #7

P: n/a
On Jun 24, 1:07 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
eholz1 wrote:
On Jun 19, 4:59 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
eholz1 wrote:
On Jun 19, 2:34 pm, Ivn Snchez Ortega <ivansanchez-...@rroba-
escomposlinux.-.punto.-.orgwrote:
eholz1 wrote:
I have uncommented out the php_oci8.dll and the older php_oracle.dll
in the php.ini file
the ini file resides in c:\php\php.ini
Let's make sure, just for the sake of it...
Put a call in any one of your pages to phpinfo(); check that the.inifile
loaded matches the oen you modified, and that there is some information
about the oci8 module being loaded.
--
----------------------------------
Ivn Snchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-
Ms vale ser cobarde un minuto, que muerto todo el resto de la vida.
Ha, I did think of that. I went to my php.ini file, and added a
comment char (;) to the mysqli extension line to see if it WOULD NOT
SHOW in my phpinfo page if I had a comment in front of the line. It
worked, put semi-colon in front of line, and no mysqli info on my
phpinfo page. if I remove the comment from that line, the mysqli
extension info appears.
So, for some unknown reason, the oci8 extension, commented or not does
not show. I do have a PATH statement that has the path to the oracle
dlls (for Oracle instantclient), and the php_oci8.dll file does exist
in my c:\php\ext directory. I guess I am out of luck.
Muchas Gracias
eholz1
This is a typical symptom of not having the correct libraries loaded.
It could be your extension directory, or more likely, the oracle
libraries (or something they require) are not available.
Check your phpinfo() command. Exactly what does it show for
"Configuration File (php.ini) Path". Also, under the "Apache
Environment" section, verify the PATH value - and ensure your Oracle
libraries (and everything they require) are in the PATH.
Also ensure you have the latest Oracle libraries on your system.
Finally - are you loading PHP as a CGI or Apache module?
It's a bit tricky to set up sometimes, but it does work.
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================
Hello again,
I will check the items that Jerry mentions - there is a lot to double
check.
I will get back to the group, if successful!
Thanks
eric

Come back if you're not successful, also - we'll try some other things! :-)

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================
Hello Again,

I got the oracle stuff to show up in the phpinfo() area. Here is what
I did:
First - I double checked the items in your (Jerry's) email. Made sure
I thought I had the correct settings, etc.

Went back to this page from Oracle:
http://www.oracle.com/technology/pub...p_instant.html

Re-read (3 times) the section on windows install - me have PHP 5.2,
Apache loads it as a module (running Window XP SP2).

Made sure I had the dlls from the instant client. Then saw the note
in technote page,
add the instantclient path BEFORE ANY OTHER ORACLE PATH VAR.
I then modified my ENV vars (both PATH, and Path) with the path to the
Oracle dlls to put location before any others.

Rebooted the computer (!) - This put the PATH in the PHP info page,
and the "oci8" stuff showed up in the info page.

I have not tried to connect to the db yet....!:)

Thanks for the help,

eric
Jun 27 '08 #8

This discussion thread is closed

Replies have been disabled for this discussion.