469,600 Members | 2,453 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,600 developers. It's quick & easy.

Same error as many......

art

Hi,

I am running PHP 4.3.9 and Apache 2.0.52.

This is the error: an unknown filter was not added: PHP

I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?

Anything would help....

Thank you.....

Jun 27 '08 #1
19 1214
ar*@unsu.com wrote:
I am running PHP 4.3.9 and Apache 2.0.52.
First, update.
This is the error: an unknown filter was not added: PHP
Second, google for that. Really, just about anybody can find the answer in
less than 5 minutes.

--
----------------------------------
Iván Sánchez Ortega -ivansanchez-algarroba-escomposlinux-punto-org-

Now listening to: Enigma - Le Roi est mort, vive le Roi ! (1996) - [5]
Why!... (4:59) (95.818199%)
Jun 27 '08 #2
ar*@unsu.com wrote:
Hi,

I am running PHP 4.3.9 and Apache 2.0.52.

This is the error: an unknown filter was not added: PHP

I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?

Anything would help....
If only you told us what you did & didn't do.....

Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your Apache
config.

When in doubt, remove ALL references to PHP in your Apache config, and
just follow the manual:
http://www.php.net/manual/en/install.unix.apache2.php
--
Rik Wasmus
....spamrun finished
Jun 27 '08 #3
art
On Jun 2, 10:30 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
a...@unsu.com wrote:
Hi,
I am running PHP 4.3.9 and Apache 2.0.52.
This is the error: an unknown filter was not added: PHP
I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?
Anything would help....

If only you told us what you did & didn't do.....

Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your Apache
config.

When in doubt, remove ALL references to PHP in your Apache config, and
just follow the manual:http://www.php.net/manual/en/install.unix.apache2.php
--
Rik Wasmus
...spamrun finished
Here is what I put into my APACHE config file:

<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>

AddType application/x-httpd-php .php .php3 .php4 .phtml
AddType application/x-httpd-php4-source .php

Probably do not need them both, but I am trying anything. And, I
tried over 20 different suggestions......and nothing has removed the
warning yet........

Thanks.
Jun 27 '08 #4
ar*@unsu.com wrote:
On Jun 2, 10:30 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
>a...@unsu.com wrote:
>>Hi,
I am running PHP 4.3.9 and Apache 2.0.52.
This is the error: an unknown filter was not added: PHP
I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?
Anything would help....
If only you told us what you did & didn't do.....

Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your Apache
config.

When in doubt, remove ALL references to PHP in your Apache config, and
just follow the manual:http://www.php.net/manual/en/install.unix.apache2.php
--
Rik Wasmus
...spamrun finished

Here is what I put into my APACHE config file:

<Files *.php>
SetOutputFilter PHP
SetInputFilter PHP
</Files>
remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
Apache config
Go forth & do so, it shouldn't be that hard. Just let does lines down
easily, gently push them to /dev/null, promising them a graceful
retirement, tell them their work is over now, and never think of them again.

--
Rik Wasmus
....spamrun finished
Jun 27 '08 #5
ar*@unsu.com wrote:
On Jun 2, 10:30 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
>a...@unsu.com wrote:
>>Hi,
I am running PHP 4.3.9 and Apache 2.0.52.
This is the error: an unknown filter was not added: PHP
I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?
Anything would help....
If only you told us what you did & didn't do.....

Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your Apache
config.

When in doubt, remove ALL references to PHP in your Apache config, and
just follow the manual:http://www.php.net/manual/en/install.unix.apache2.php
--
Rik Wasmus
...spamrun finished

Here is what I put into my APACHE config file:
>
AddType application/x-httpd-php .php .php3 .php4 .phtml
AddType application/x-httpd-php4-source .php
Euhm, it should be:

AddType application/x-httpd-php4-source .phps

...(if you want it, I never use it, I have an editor with better syntax
highlighting). and NOT (I repeat NOT):

AddType application/x-httpd-php4-source .php

.... which essentially tells Apache to display the source of all your PHP
files, in a nicely formatted & syntax highlighted manner....
--
Rik Wasmus
....spamrun finished
Jun 27 '08 #6
On Mon, 2 Jun 2008 07:57:30 -0700 (PDT), ar*@unsu.com wrote:
>
Hi,

I am running PHP 4.3.9 and Apache 2.0.52.

This is the error: an unknown filter was not added: PHP

I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?

Anything would help....
http://bugs.php.net/bug.php?id=22881

(Short answer for the lazy: filter mechanism not supported anymore on
Apache 2. use apache2handler mechanism via AddType
application/x-httpd-php .php instead.)

--
For their next act, they'll no doubt be buying a firewall running under NT,
which makes about as much sense as building a prison out of meringue.
-- Tanuki
Jun 27 '08 #7
art
On Jun 2, 10:59 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
a...@unsu.com wrote:
On Jun 2, 10:30 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
a...@unsu.com wrote:
Hi,
I am running PHP 4.3.9 and Apache 2.0.52.
This is the error: an unknown filter was not added: PHP
I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?
Anything would help....
If only you told us what you did & didn't do.....
Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your Apache
config.
When in doubt, remove ALL references to PHP in your Apache config, and
just follow the manual:http://www.php.net/manual/en/install.unix.apache2.php
--
Rik Wasmus
...spamrun finished
Here is what I put into my APACHE config file:
AddType application/x-httpd-php .php .php3 .php4 .phtml
AddType application/x-httpd-php4-source .php

Euhm, it should be:

AddType application/x-httpd-php4-source .phps

..(if you want it, I never use it, I have an editor with better syntax
highlighting). and NOT (I repeat NOT):

AddType application/x-httpd-php4-source .php

... which essentially tells Apache to display the source of all your PHP
files, in a nicely formatted & syntax highlighted manner....
--
Rik Wasmus
...spamrun finished
Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:

AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps

<Files *.php>
SetOutputFilter PHP
</Files>

[Mon Jun 02 11:47:26 2008] [notice] Digest: generating secret for
digest authentication ...
[Mon Jun 02 11:47:26 2008] [notice] Digest: done
[Mon Jun 02 11:47:26 2008] [notice] LDAP: Built with OpenLDAP LDAP SDK
[Mon Jun 02 11:47:26 2008] [notice] LDAP: SSL support unavailable
[Mon Jun 02 11:47:26 2008] [notice] mod_python: Creating 4 session
mutexes based on 256 max processes and 0 max threads.
[Mon Jun 02 11:47:26 2008] [notice] Apache configured -- resuming
normal operations
[Mon Jun 02 11:47:32 2008] [error] an unknown filter was not added:
PHP
[Mon Jun 02 11:47:32 2008] [error] an unknown filter was not added:
PHP
[Mon Jun 02 11:47:32 2008] [error] an unknown filter was not added:
PHP
Jun 27 '08 #8
On Mon, 02 Jun 2008 18:29:14 +0200, ar*@unsu.com <am****@iwc.netwrote:
On Jun 2, 10:59 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
>a...@unsu.com wrote:
On Jun 2, 10:30 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
a...@unsu.com wrote:
Hi,
I am running PHP 4.3.9 and Apache 2.0.52.
This is the error: an unknown filter was not added: PHP
I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?
Anything would help....
If only you told us what you did & didn't do.....
>Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
Apache
>config.
>When in doubt, remove ALL references to PHP in your Apache config,
and
>just follow the
manual:http://www.php.net/manual/en/install.unix.apache2.php
>--
Rik Wasmus
...spamrun finished
Here is what I put into my APACHE config file:
AddType application/x-httpd-php .php .php3 .php4 .phtml
AddType application/x-httpd-php4-source .php

Euhm, it should be:

AddType application/x-httpd-php4-source .phps

..(if you want it, I never use it, I have an editor with better syntax
highlighting). and NOT (I repeat NOT):

AddType application/x-httpd-php4-source .php

... which essentially tells Apache to display the source of all your PHP
files, in a nicely formatted & syntax highlighted manner....

Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:

AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps

<Files *.php>
SetOutputFilter PHP
</Files>
No! No! No!

I'll say it just one more time, after that I'll totally give up.
NO! SETOUTPUTFILTER! ANYWHERE! IN! YOUR! APACHE! CONFIG!

NO (not, kein, pas, geen, you seem to be no native english speaker....)
SETOUTPUTFILTER!

If you dare to answer you have a SetOutputFilter PHP or SetInputFilter PHP
in your config again... Well, I can't do anything to you, I think I'll go
sit in a corner and sob quietly...
--
Rik Wasmus
....spamrun finished
Jun 27 '08 #9
..oO(ar*@unsu.com)
>Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:

AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps

<Files *.php>
SetOutputFilter PHP
</Files>
Drop that.

You should read and follow the instructions more carefully. To quote a
quote:

| remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
| Apache config

All you need are the directives for loading the module and maybe the
AddType stuff, even though there are other ways as well.

But why do you want to use PHP 4 anyway? It is dead. Really dead! It has
officially reached its end of life and the support for it will finally
end in some weeks. PHP 5 is the way to go and PHP 6 is coming soon.

Micha
Jun 27 '08 #10
On Mon, 2 Jun 2008 09:29:14 -0700 (PDT), ar*@unsu.com wrote:
On Jun 2, 10:59 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
>a...@unsu.com wrote:
On Jun 2, 10:30 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
a...@unsu.com wrote:
Hi,
I am running PHP 4.3.9 and Apache 2.0.52.
This is the error: an unknown filter was not added: PHP
I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?
Anything would help....
If only you told us what you did & didn't do.....
>Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your Apache
config.
>When in doubt, remove ALL references to PHP in your Apache config, and
just follow the manual:http://www.php.net/manual/en/install.unix.apache2.php
--
Rik Wasmus
...spamrun finished
Here is what I put into my APACHE config file:
AddType application/x-httpd-php .php .php3 .php4 .phtml
AddType application/x-httpd-php4-source .php

Euhm, it should be:

AddType application/x-httpd-php4-source .phps

..(if you want it, I never use it, I have an editor with better syntax
highlighting). and NOT (I repeat NOT):

AddType application/x-httpd-php4-source .php

... which essentially tells Apache to display the source of all your PHP
files, in a nicely formatted & syntax highlighted manner....
--
Rik Wasmus
...spamrun finished

Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:

AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps
I'm going to make this very simple.

+---REMOVE THE PART THAT LOOKS LIKE THIS---+
| |
v v

<Files *.php>
SetOutputFilter PHP
</Files>

^ ^
| |
+---REMOVE THE PART THAT LOOKS LIKE THIS---+

NO OUTPUT FILTER Don't use it. take it out. Make it gone. NO NO NO NO

All of this is part of where Rik said "remove ALL SetInputFilter PHP &
SetOutputFilter PHP's from your Apache config". Remember that? It's
still quoted above. If you make a single additional post where you have
NOT taken those filters out of your config, you will be branding
yourself a moron in front of the whole internet forever. Is it out of
your config yet? Go do it right now.

--
45. I will make sure I have a clear understanding of who is responsible for
what in my organization. For example, if my general screws up I will not
draw my weapon, point it at him, say "And here is the price for failure,"
then suddenly turn and kill some random underling. --Evil Overlord List
Jun 27 '08 #11
Rik Wasmus schreef:
On Mon, 02 Jun 2008 18:29:14 +0200, ar*@unsu.com <am****@iwc.netwrote:
>On Jun 2, 10:59 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
>>a...@unsu.com wrote:
On Jun 2, 10:30 am, Rik Wasmus <luiheidsgoe...@hotmail.comwrote:
a...@unsu.com wrote:
Hi,
I am running PHP 4.3.9 and Apache 2.0.52.
This is the error: an unknown filter was not added: PHP
I've read over 40 suggestions with no luck. Can anyone help? I am
running Cent-OS. does anyone need to see my config files?
Anything would help....
If only you told us what you did & didn't do.....

Long story short, what usually solves everything:
- load the PHP module (LoadModule php4_module modules/libphp4.so)
- just use a proper AddType application/x-httpd-php .php
- remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
Apache
config.

When in doubt, remove ALL references to PHP in your Apache config,
and
just follow the
manual:http://www.php.net/manual/en/install.unix.apache2.php
--
Rik Wasmus
...spamrun finished

Here is what I put into my APACHE config file:

AddType application/x-httpd-php .php .php3 .php4 .phtml
AddType application/x-httpd-php4-source .php

Euhm, it should be:

AddType application/x-httpd-php4-source .phps

..(if you want it, I never use it, I have an editor with better syntax
highlighting). and NOT (I repeat NOT):

AddType application/x-httpd-php4-source .php

... which essentially tells Apache to display the source of all your PHP
files, in a nicely formatted & syntax highlighted manner....

Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:

AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps

<Files *.php>
SetOutputFilter PHP
</Files>

No! No! No!

I'll say it just one more time, after that I'll totally give up.
NO! SETOUTPUTFILTER! ANYWHERE! IN! YOUR! APACHE! CONFIG!

NO (not, kein, pas, geen, you seem to be no native english speaker....)
SETOUTPUTFILTER!

If you dare to answer you have a SetOutputFilter PHP or SetInputFilter
PHP in your config again... Well, I can't do anything to you, I think
I'll go sit in a corner and sob quietly...
Dear Rik,

I think you should really be more clear.
After rereading your post a few times, I get the impression that you
actually suggest to remove the SetOutputFilter from the config.
Why don't you state that more clearly?

Regards,
Erwin Moller
Jun 27 '08 #12
art
On Jun 2, 12:01 pm, Michael Fesser <neti...@gmx.dewrote:
.oO(a...@unsu.com)
Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:
AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps
<Files *.php>
SetOutputFilter PHP
</Files>

Drop that.

You should read and follow the instructions more carefully. To quote a
quote:

| remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
| Apache config

All you need are the directives for loading the module and maybe the
AddType stuff, even though there are other ways as well.

But why do you want to use PHP 4 anyway? It is dead. Really dead! It has
officially reached its end of life and the support for it will finally
end in some weeks. PHP 5 is the way to go and PHP 6 is coming soon.

Micha
I orginally had that. It was still acting the same. Perhaps this has
something to do with it???

[root@nytelife cgi-bin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Mon Jun 02 13:05:17 2008] [warn] module php4_module
is already loaded, skipping
[ OK ]

Maybe I'll try upgrading first and see what happens.........

Jun 27 '08 #13
ar*@unsu.com wrote:
On Jun 2, 12:01 pm, Michael Fesser <neti...@gmx.dewrote:
>.oO(a...@unsu.com)
>>Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:
AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps
<Files *.php>
SetOutputFilter PHP
</Files>
Drop that.

You should read and follow the instructions more carefully. To quote a
quote:

| remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
| Apache config

All you need are the directives for loading the module and maybe the
AddType stuff, even though there are other ways as well.

But why do you want to use PHP 4 anyway? It is dead. Really dead! It has
officially reached its end of life and the support for it will finally
end in some weeks. PHP 5 is the way to go and PHP 6 is coming soon.

Micha

I orginally had that. It was still acting the same. Perhaps this has
something to do with it???

[root@nytelife cgi-bin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Mon Jun 02 13:05:17 2008] [warn] module php4_module
is already loaded, skipping
[ OK ]

Maybe I'll try upgrading first and see what happens.........
Which generally indicates you have loaded the module more than once....

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
Jun 27 '08 #14
art
On Jun 3, 7:50 am, Jerry Stuckle <jstuck...@attglobal.netwrote:
a...@unsu.com wrote:
On Jun 2, 12:01 pm, Michael Fesser <neti...@gmx.dewrote:
.oO(a...@unsu.com)
>Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:
AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps
<Files *.php>
SetOutputFilter PHP
</Files>
Drop that.
You should read and follow the instructions more carefully. To quote a
quote:
| remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
| Apache config
All you need are the directives for loading the module and maybe the
AddType stuff, even though there are other ways as well.
But why do you want to use PHP 4 anyway? It is dead. Really dead! It has
officially reached its end of life and the support for it will finally
end in some weeks. PHP 5 is the way to go and PHP 6 is coming soon.
Micha
I orginally had that. It was still acting the same. Perhaps this has
something to do with it???
[root@nytelife cgi-bin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Mon Jun 02 13:05:17 2008] [warn] module php4_module
is already loaded, skipping
[ OK ]
Maybe I'll try upgrading first and see what happens.........

Which generally indicates you have loaded the module more than once....

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================
Ok, well, then that has nothing to do with the warning message. Time
for a re-install I guess.....

Jun 27 '08 #15
ar*@unsu.com wrote:
On Jun 3, 7:50 am, Jerry Stuckle <jstuck...@attglobal.netwrote:
>a...@unsu.com wrote:
>>On Jun 2, 12:01 pm, Michael Fesser <neti...@gmx.dewrote:
.oO(a...@unsu.com)
Thanks for everyone's suggestions. Here is what I changed, but no
luck thus far. And, I am loading LoadModule php4_module modules/
libphp4.so:
AddType application/x-httpd-php .php
AddType application/x-httpd-php4-source .phps
<Files *.php>
SetOutputFilter PHP
</Files>
Drop that.
You should read and follow the instructions more carefully. To quote a
quote:
| remove ALL SetInputFilter PHP & SetOutputFilter PHP's from your
| Apache config
All you need are the directives for loading the module and maybe the
AddType stuff, even though there are other ways as well.
But why do you want to use PHP 4 anyway? It is dead. Really dead! It has
officially reached its end of life and the support for it will finally
end in some weeks. PHP 5 is the way to go and PHP 6 is coming soon.
Micha
I orginally had that. It was still acting the same. Perhaps this has
something to do with it???
[root@nytelife cgi-bin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Mon Jun 02 13:05:17 2008] [warn] module php4_module
is already loaded, skipping
[ OK ]
Maybe I'll try upgrading first and see what happens.........
Which generally indicates you have loaded the module more than once....

Ok, well, then that has nothing to do with the warning message. Time
for a re-install I guess.....
No, time to remove the extra LoadModule. You only need it once. But if
you're this uncomfortable altering configuration files a new automated
setup might just what the doctor ordered.
--
Rik Wasmus
....spamrun finished
Jun 27 '08 #16
On Tue, 03 Jun 2008 08:50:57 -0400, Jerry Stuckle wrote:
ar*@unsu.com wrote:
>I orginally had that. It was still acting the same. Perhaps this has
something to do with it???

[root@nytelife cgi-bin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Mon Jun 02 13:05:17 2008] [warn] module php4_module
is already loaded, skipping
[ OK ]

Maybe I'll try upgrading first and see what happens.........

Which generally indicates you have loaded the module more than once....
Which is pretty common, because the PHP installer, when used following
commonly-available directions, will cheerfully add a line to load the
module every time the install script is run, without bothering to check
closely whether that line already exists. (Granted, that's not
entirely unreasonable. It's complicated to parse out every permutation
of a config structure to tell if a line's actually going to be processed
or not, and the warning, being a non-fatal error, is generally enough to
let an operator know that human eyeballs are needed to fix it, but it
doesn't need to be fixed immediately.)

--
_ o
|/)
Jun 27 '08 #17
art
On Jun 3, 9:32 am, "Peter H. Coffin" <hell...@ninehells.comwrote:
On Tue, 03 Jun 2008 08:50:57 -0400, Jerry Stuckle wrote:
a...@unsu.com wrote:
I orginally had that. It was still acting the same. Perhaps this has
something to do with it???
[root@nytelife cgi-bin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Mon Jun 02 13:05:17 2008] [warn] module php4_module
is already loaded, skipping
[ OK ]
Maybe I'll try upgrading first and see what happens.........
Which generally indicates you have loaded the module more than once....

Which is pretty common, because the PHP installer, when used following
commonly-available directions, will cheerfully add a line to load the
module every time the install script is run, without bothering to check
closely whether that line already exists. (Granted, that's not
entirely unreasonable. It's complicated to parse out every permutation
of a config structure to tell if a line's actually going to be processed
or not, and the warning, being a non-fatal error, is generally enough to
let an operator know that human eyeballs are needed to fix it, but it
doesn't need to be fixed immediately.)

--
_ o
|/)
PHP is DUMB! An extra line.....sheesh!
Jun 27 '08 #18
ar*@unsu.com wrote:
On Jun 3, 9:32 am, "Peter H. Coffin" <hell...@ninehells.comwrote:
>On Tue, 03 Jun 2008 08:50:57 -0400, Jerry Stuckle wrote:
>>a...@unsu.com wrote:
I orginally had that. It was still acting the same. Perhaps this has
something to do with it???
[root@nytelife cgi-bin]# service httpd restart
Stopping httpd: [ OK ]
Starting httpd: [Mon Jun 02 13:05:17 2008] [warn] module php4_module
is already loaded, skipping
[ OK ]
Maybe I'll try upgrading first and see what happens.........
Which generally indicates you have loaded the module more than once....
Which is pretty common, because the PHP installer, when used following
commonly-available directions, will cheerfully add a line to load the
module every time the install script is run, without bothering to check
closely whether that line already exists. (Granted, that's not
entirely unreasonable. It's complicated to parse out every permutation
of a config structure to tell if a line's actually going to be processed
or not, and the warning, being a non-fatal error, is generally enough to
let an operator know that human eyeballs are needed to fix it, but it
doesn't need to be fixed immediately.)

--
_ o
|/)

PHP is DUMB! An extra line.....sheesh!
It has nothing to do with PHP. It's Apache generating the error - as it
will for ANY module you load more than once.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
Jun 27 '08 #19
On Tue, 3 Jun 2008 09:58:54 -0700 (PDT), ar*@unsu.com wrote:
>Which is pretty common, because the PHP installer, when used following
commonly-available directions, will cheerfully add a line to load the
module every time the install script is run, without bothering to check
closely whether that line already exists. (Granted, that's not
entirely unreasonable. It's complicated to parse out every permutation
of a config structure to tell if a line's actually going to be processed
or not, and the warning, being a non-fatal error, is generally enough to
let an operator know that human eyeballs are needed to fix it, but it
doesn't need to be fixed immediately.)

PHP is DUMB! An extra line.....sheesh!
If that's the worst you have to complain about in the whole deal, life's
pretty good.

--
69. All midwives will be banned from the realm. All babies will be delivered
at state-approved hospitals. Orphans will be placed in foster-homes, not
abandoned in the woods to be raised by creatures of the wild.
--Peter Anspach's list of things to do as an Evil Overlord
Jun 27 '08 #20

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

4 posts views Thread by Roger Withnell | last post: by
5 posts views Thread by Lumpierbritches | last post: by
14 posts views Thread by vince | last post: by
3 posts views Thread by Hamilton | last post: by
13 posts views Thread by Bill | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.