469,133 Members | 1,239 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,133 developers. It's quick & easy.

Fatal error: Call to undefined function xslt_create()

15
Hi Everybody,
I am getting the below error

Fatal error: Call to undefined function xslt_create()

In my phpinfo page it shows that xsl is enabled. What might be the problem?.I am using php 5 and apache server 2.2 . Please help me out.


Regards,
Raj
Jun 27 '08 #1
10 7952
realin
254 100+
i m not very sure but did u read the manual properly. Because it says that you ned some Sablot library

cheers !!
Jun 27 '08 #2
myshona
15
Hi,

Thanks for the reply. I do have the sablot library. I am not able to figure out where is the problem.


Thanks,
RAJ
Jun 27 '08 #3
fjm
348 100+
Have a look at this Raj, this may help you:

http://www.php.net/xslt_create
Jun 27 '08 #4
myshona
15
Have a look at this Raj, this may help you:

http://www.php.net/xslt_create
I have copied sablot.dll, Expat.dll, iconv.dll to system32 directory and have set the path in environment variables for all these DLL's. Still not working. Please help
Jun 27 '08 #5
myshona
15
Need you suggestions. Please help
Jun 27 '08 #6
myshona
15
I am still stuck with this. Need your suggestions
Jun 30 '08 #7
fjm
348 100+
Raj,

When you install php on windows, you must copy 3 files into the windows\system32 directory before using xslt_create()

These files are in your installed php/dlls directory
expat.dll
sablot.dll
iconv.dll

Then edit your php.ini file (c:\windowsdir\php.ini)
and uncomment the line extension=php_xslt.dll (remove the ; from the beginning)

Restart php and apache, it should work ;)

Let me know if that helped.

EDIT:
In my windows installation, my PHP dll directory is NOT under windows\system32 but rather under C:\Program Files\PHP\ext

I believe you placed those files in the wrong place.
Jun 30 '08 #8
myshona
15
Raj,

When you install php on windows, you must copy 3 files into the windows\system32 directory before using xslt_create()

These files are in your installed php/dlls directory
expat.dll
sablot.dll
iconv.dll

Then edit your php.ini file (c:\windowsdir\php.ini)
and uncomment the line extension=php_xslt.dll (remove the ; from the beginning)

Restart php and apache, it should work ;)

Let me know if that helped.
Thanks for the reply. I had done all these and also phpinfo page was showing that xsl is enabled. The way to sort this out in PHP 5 is when you are transforming the file from one format to other format (xml->php) use the below code for the transformation its for php 5

$xml = new DomDocument;
$xml->load($xmlfilename);

$xsl = new DomDocument;
$xsl->load($xsltfilename);

$proc = new xsltprocessor;
$proc->importStyleSheet($xsl);
$result = $proc->transformToXML($xml);

After changing the code dont forget to comment extension=php_domxml.dll in the ini file and restart the server. Now it should work.
Jun 30 '08 #9
fjm
348 100+
I updated my last post in case you don't get it working. We seemed to have posted at the same time. :)
Jun 30 '08 #10
myshona
15
Raj,

EDIT:
In my windows installation, my PHP dll directory is NOT under windows\system32 but rather under C:\Program Files\PHP\ext

I believe you placed those files in the wrong place.
Wherever the dll's are either in windows/system32 or in ext folder of php the extension directory in the ini file has to be changed. It works both the ways.
Jun 30 '08 #11

Post your reply

Sign in to post your reply or Sign up for a free account.

Similar topics

4 posts views Thread by gc | last post: by
8 posts views Thread by Tim Tyler | last post: by
1 post views Thread by drewmania001 | last post: by
1 post views Thread by CARIGAR | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.