By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
457,939 Members | 1,546 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 457,939 IT Pros & Developers. It's quick & easy.

extension won't load in php.ini, but loads with dl()

P: n/a
I'm having a weird problem. I can't seem to force php to load an
extension using php.ini, but it loads perfectly if I use dl() at the
beginning of a test script.

In php.ini I've got:

extension_dir = "/correct/verified/path/to/extension/dir/"
extension=imagick.so

Apache will not restart if both those lines are present in php.ini
(and apache's error_log doesn't report anything either).

If I remove the extension load line, e.g.:

extension_dir = "/correct/verified/path/to/extension/dir/"
; extension=imagick.so

Apache will restart normally (without the extension loaded, but with
the correct extension path).

The confusing thing is that the extension then loads fine with dl():

<?php
dl("imagick.so")
phpinfo();
?>

and phpinfo displays the extension info normally.

The problem seems to be with apache, but since there's nothing in the
error_log I'm unsure how to proceed.

system info:
freebsd 7 on x86_64 architecture
apache 1.3.41
php 5.2.5

Has anyone encountered this problem before?
Jun 2 '08 #1
Share this Question
Share on Google+
6 Replies


P: n/a
to********@gmail.com wrote:
I'm having a weird problem. I can't seem to force php to load an
extension using php.ini, but it loads perfectly if I use dl() at the
beginning of a test script.

In php.ini I've got:

extension_dir = "/correct/verified/path/to/extension/dir/"
extension=imagick.so

Apache will not restart if both those lines are present in php.ini
(and apache's error_log doesn't report anything either).

If I remove the extension load line, e.g.:

extension_dir = "/correct/verified/path/to/extension/dir/"
; extension=imagick.so

Apache will restart normally (without the extension loaded, but with
the correct extension path).

The confusing thing is that the extension then loads fine with dl():

<?php
dl("imagick.so")
phpinfo();
?>

and phpinfo displays the extension info normally.

The problem seems to be with apache, but since there's nothing in the
error_log I'm unsure how to proceed.

system info:
freebsd 7 on x86_64 architecture
apache 1.3.41
php 5.2.5

Has anyone encountered this problem before?
You need to be asking in an Apache newsgroup. This doesn't have
anything to do with PHP. Try alt.apache.configuration.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Jun 2 '08 #2

P: n/a
On May 2, 2:28 am, Jerry Stuckle <jstuck...@attglobal.netwrote:
tommybi...@gmail.com wrote:
I'm having a weird problem. I can't seem to force php to load an
extension using php.ini, but it loads perfectly if I use dl() at the
beginning of a test script.
In php.ini I've got:
extension_dir = "/correct/verified/path/to/extension/dir/"
extension=imagick.so
Apache will not restart if both those lines are present in php.ini
(and apache's error_log doesn't report anything either).
If I remove the extension load line, e.g.:
extension_dir = "/correct/verified/path/to/extension/dir/"
; extension=imagick.so
Apache will restart normally (without the extension loaded, but with
the correct extension path).
The confusing thing is that the extension then loads fine with dl():
<?php
dl("imagick.so")
phpinfo();
?>
and phpinfo displays the extension info normally.
The problem seems to be with apache, but since there's nothing in the
error_log I'm unsure how to proceed.
system info:
freebsd 7 on x86_64 architecture
apache 1.3.41
php 5.2.5
Has anyone encountered this problem before?

You need to be asking in an Apache newsgroup. This doesn't have
anything to do with PHP. Try alt.apache.configuration.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================
He asked politely, and it was reasonable to think that it was an issue
in either PHP or Apache and that it wouldn't hurt to ask on a PHP
group. There's absolutely no need to be such a total jerk about it.
Other than the fact that you are a total jerk of course. Instead of
attacking posters for asking perfectly reasonable questions why don't
you just shut up instead and go back to your hug box?
Jun 2 '08 #3

P: n/a
On 1 May, 22:39, tommybi...@gmail.com wrote:
I'm having a weird problem. I can't seem to force php to load an
extension using php.ini, but it loads perfectly if I use dl() at the
beginning of a test script.

In php.ini I've got:

extension_dir = "/correct/verified/path/to/extension/dir/"
extension=imagick.so

Apache will not restart if both those lines are present in php.ini
(and apache's error_log doesn't report anything either).

If I remove the extension load line, e.g.:

extension_dir = "/correct/verified/path/to/extension/dir/"
; extension=imagick.so

Apache will restart normally (without the extension loaded, but with
the correct extension path).
Are you running Apache in a chroot jail? If so it may be trying to
load the extension before the chroot()

What are the permissions on the extension?

Is this the only extension you load from this dir? Can you replicate
with any extension?

C.
Jun 2 '08 #4

P: n/a
On 2 May, 09:14, Gordon <gordon.mc...@ntlworld.comwrote:
He asked politely, and it was reasonable to think that it was an issue
in either PHP or Apache and that it wouldn't hurt to ask on a PHP
group. There's absolutely no need to be such a total jerk about it.
Other than the fact that you are a total jerk of course. Instead of
attacking posters for asking perfectly reasonable questions why don't
you just shut up instead and go back to your hug box?
What IS your problem. Did you actually read the post you're commenting
on? Someone asked a question. Someone helped by pointing out (quite
politely) where the answer might be best found.

Read your own post. Which one looks like it's been written by a jerk?
Jun 2 '08 #5

P: n/a
On Fri, 2 May 2008 02:14:56 -0700 (PDT), Gordon wrote:
He asked politely, and it was reasonable to think that it was an issue
in either PHP or Apache and that it wouldn't hurt to ask on a PHP
group. There's absolutely no need to be such a total jerk about it.
Other than the fact that you are a total jerk of course. Instead of
attacking posters for asking perfectly reasonable questions why don't
you just shut up instead and go back to your hug box?
Your definition of "total jerk" differ greatly from mine. OP asked
question, was told that it was indeed an apache problem, not a php one,
and it was suggested that better help would come from a particular
apache group. No aspersions were cast on the posters ancestors, nor were
threats made toward his pet.
--
27. I will never build only one of anything important. All important systems
will have redundant control panels and power supplies. For the same reason
I will always carry at least two fully loaded weapons at all times.
--Peter Anspach's list of things to do as an Evil Overlord
Jun 2 '08 #6

P: n/a
On May 2, 6:45*am, "C. (http://symcbean.blogspot.com/)"
<colin.mckin...@gmail.comwrote:
On 1 May, 22:39, tommybi...@gmail.com wrote:


I'm having a weird problem. *I can't seem to force php to load an
extension using php.ini, but it loads perfectly if I use dl() at the
beginning of a test script.
In php.ini I've got:
extension_dir = "/correct/verified/path/to/extension/dir/"
extension=imagick.so
Apache will not restart if both those lines are present in php.ini
(and apache's error_log doesn't report anything either).
If I remove the extension load line, e.g.:
extension_dir = "/correct/verified/path/to/extension/dir/"
; extension=imagick.so
Apache will restart normally (without the extension loaded, but with
the correct extension path).

Are you running Apache in a chroot jail? If so it may be trying to
load the extension before the chroot()
I have a pretty basic apache installation, so unless the default
behavior when compiling from the tarball is put the apache directory
tree into a chroot jail, the answer in no.
What are the permissions on the extension?
644 root.wheel, though the entire tree from /usr/local/lib is all
root.wheel as well. php.ini accepts dynamically loaded libraries
using the extension_dir with those permissions no problem.
>
Is this the only extension you load from this dir? Can you replicate
with any extension?
I tried with the other extension I've got installed, but I get a php
error with that one: Invalid library (maybe not a PHP library)
'libssh2.so' in ... (I should note that I've had problems in the past
with the libssh2 extension, so it's not a reliable test... I'll
download and phpize another extension from pecl to see if it works)

Thanks for the tips (and sorry my post started a flame war...)
>
C.- Hide quoted text -

- Show quoted text -
Jun 2 '08 #7

This discussion thread is closed

Replies have been disabled for this discussion.