469,267 Members | 922 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,267 developers. It's quick & easy.

Failed opening 'mysql.inc' for inclusion (include_path

Bob
Im setting up a fedora core 8 web server. Im currently running
everything on another fedora core 6 server (working fine). Ive
installed php 5.2.5 and apache 2.0.63

Im getting the following:

Warning: include_once() [function.include]: Failed opening 'mysql.inc'
for inclusion (include_path='/home/jeff/src/soccer/php_inc') in /home/
http/soc/show.php on line 13

the file, file.inc exists in my include path, which I specifically set
at the top of my php file:

set_include_path('/home/jeff/src/soccer/php_inc');
I dont need other incs, so I only include my own path in this btw.

Here's the directory with my files. Both files give me the same
problem btw:

180 ROOT fedora /home/jeff/src/soccer/php_inc ls -l
total 20
drwxr-xr-x 2 root root 4096 Mar 19 07:13 ./
drwxr-xr-x 5 root root 4096 Mar 19 07:16 ../
-rw-r--r-- 1 jeff root 1500 Nov 25 11:51 email.inc
-rw-r--r-- 1 nobody root 5083 Mar 19 07:04 mysql.inc

I tried even setting chmod to 777 with no luck and also owning
the directory myself.

httpd is running as 'nobody'

I tried reading about this on google but cant seem to figure it
out. I even tried editing /etc/php.ini for include_path with no
luck either.

What do I try next?
Thank you
Mar 19 '08 #1
1 3496
Bob
Warning: include_once() [function.include]: Failed opening 'mysql.inc'
for inclusion (include_path='/home/jeff/src/soccer/php_inc') in /home/
http/soc/show.php on line 13
I also tried fopen to see if that had an issue and it does also.
I tried moving around the fopen file just to see if that helped
at all with no luck.

Could this be an apache config issue ? Im at a loss.
Mar 19 '08 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

5 posts views Thread by john | last post: by
3 posts views Thread by big.sexy.jcw | last post: by
1 post views Thread by CARIGAR | last post: by
reply views Thread by suresh191 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.