By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
458,145 Members | 1,600 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 458,145 IT Pros & Developers. It's quick & easy.

how to solve this problem with REGISTER_GLOBALS='On'

P: n/a
Hi,

The CRM application said that need to add an option
"REGISTER_GLOBALS=On" to the php.ini file, so I did what it told.
But I still can't get rid off the following error:

The PHP variable "REGISTER_GLOBALS" is disabled (0). This is fatal.
Edit your php.ini and set REGISTER_GLOBALS to "On".

I changed the value "On" to "Yes", still getting the same error.
What is the correct way to fix this problem? It might be not reading the
php.ini file. The php.ini file is located at /usr/local/etc/ directory,
and I have also made a symbolic link to /etc/ as well.

The relevant content of the php.ini file is:

[PHP]

REGISTER_GLOBALS='yes'

......
Thanks
sam
Jul 17 '05 #1
Share this Question
Share on Google+
6 Replies


P: n/a
"wonder" <a@b.com> wrote in message news:cg***********@news.hgc.com.hk...
Hi,

The CRM application said that need to add an option
"REGISTER_GLOBALS=On" to the php.ini file, so I did what it told.
But I still can't get rid off the following error:

The PHP variable "REGISTER_GLOBALS" is disabled (0). This is fatal.
Edit your php.ini and set REGISTER_GLOBALS to "On".

I changed the value "On" to "Yes", still getting the same error.
What is the correct way to fix this problem? It might be not reading the
php.ini file. The php.ini file is located at /usr/local/etc/ directory,
and I have also made a symbolic link to /etc/ as well.

The relevant content of the php.ini file is:

[PHP]

REGISTER_GLOBALS='yes'

.....
Thanks
sam


Try not using quotes.

register_globals = On

instead of

register_globals = 'On'

Also, make sure you restart the server after making the changes.

- JP
Jul 17 '05 #2

P: n/a
wonder schrieb:
[PHP]

REGISTER_GLOBALS='yes'


This should be:

register_globals=on

Regards,
Matthias
Jul 17 '05 #3

P: n/a
"wonder" wrote:
Hi,

The CRM application said that need to add an option
"REGISTER_GLOBALS=On" to the php.ini file, so I did what it told.
But I still can’t get rid off the following error:

The PHP variable "REGISTER_GLOBALS" is disabled (0). This is fatal. Edit your php.ini and set REGISTER_GLOBALS to "On".

I changed the value "On" to "Yes", still getting the same error. What is the correct way to fix this problem? It might be not reading the
php.ini file. The php.ini file is located at /usr/local/etc/
directory,
and I have also made a symbolic link to /etc/ as well.

The relevant content of the php.ini file is:

[PHP]

REGISTER_GLOBALS=’yes’

......
Thanks
sam


I am suspecting also that it may not be reading the ini file. Try
renaming the ini file, and see if php fails. Is there another ini
file. Can you search?

--
http://www.dbForumz.com/ This article was posted by author's request
Articles individually checked for conformance to usenet standards
Topic URL: http://www.dbForumz.com/PHP-solve-problem-REGISTER_GLOBALS-ftopict141997.html
Visit Topic URL to contact author (reg. req'd). Report abuse: http://www.dbForumz.com/eform.php?p=474833
Jul 17 '05 #4

P: n/a
In message <41********@news.athenanews.com>, steve
<Us************@dbForumz.com> writes


I am suspecting also that it may not be reading the ini file. Try
renaming the ini file, and see if php fails. Is there another ini
file. Can you search?

To find out which php.ini file PHP thinks it is using, create a file
called "info.php" in the root of your website with the text:

<?php

phpinfo();

?>

If you then browse to info.php, you'll find the php.ini file's directory
listed near the top.
--
Rob...
Jul 17 '05 #5

P: n/a
wonder schrieb:
Hi,

The CRM application said that need to add an option
"REGISTER_GLOBALS=On" to the php.ini file, so I did what it told.
But I still can't get rid off the following error:

The PHP variable "REGISTER_GLOBALS" is disabled (0). This is fatal.
Edit your php.ini and set REGISTER_GLOBALS to "On".

I changed the value "On" to "Yes", still getting the same error.
What is the correct way to fix this problem? It might be not reading the
php.ini file. The php.ini file is located at /usr/local/etc/ directory,
and I have also made a symbolic link to /etc/ as well.

The relevant content of the php.ini file is:

[PHP]

REGISTER_GLOBALS='yes'

.....
Thanks
sam


Did you restarted your httpd service?

--
-------------------------------------------------------
Try this: SCA the Smart Class Archive for PHP
http://www.project-sca.org
-------------------------------------------------------
Jul 17 '05 #6

P: n/a
Personally I wouldn't use anything that still needs register_globals..
The author should fix their software, rather than force you to enable
autoglobals..

Just my $0.02 worth..

Regards,
Chris
Jul 17 '05 #7

This discussion thread is closed

Replies have been disabled for this discussion.