By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,949 Members | 1,869 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,949 IT Pros & Developers. It's quick & easy.

php.ini not being read in vista

P: n/a
I tried to turn on magic_quotes_gpc

behavior shows that it is Off
phpinfo shows it is Off
phpinfo shows path to config file as C:\php\php.ini
setting:
magic_quotes_gpc = On
in C:\php\php.ini does nothing

putting garbage into C:\php\php.ini results in NO error in
Apache's error.log

renaming C:\php\php.ini has No effect

So it must be using default settings. How do I fix?

I hate vista
Feb 27 '08 #1
Share this Question
Share on Google+
12 Replies


P: n/a
Jerry wrote:
I tried to turn on magic_quotes_gpc

behavior shows that it is Off
phpinfo shows it is Off
phpinfo shows path to config file as C:\php\php.ini
setting:
magic_quotes_gpc = On
in C:\php\php.ini does nothing

putting garbage into C:\php\php.ini results in NO error in Apache's
error.log

renaming C:\php\php.ini has No effect

So it must be using default settings. How do I fix?

I hate vista
Does the webserver's userid have access to the php.ini file?

Now you know why I don't use Vista :-)

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Feb 27 '08 #2

P: n/a
Jerry Stuckle wrote:
Jerry wrote:
>I tried to turn on magic_quotes_gpc

behavior shows that it is Off
phpinfo shows it is Off
phpinfo shows path to config file as C:\php\php.ini
setting:
magic_quotes_gpc = On
in C:\php\php.ini does nothing

putting garbage into C:\php\php.ini results in NO error in Apache's
error.log

renaming C:\php\php.ini has No effect

So it must be using default settings. How do I fix?

I hate vista

Does the webserver's userid have access to the php.ini file?
thanks. I guess there's no easy fix and I'll have to delve into
accomplishing that tomorrow. I had the quaint notion that I
shouldn't have the OS fighting me at every turn - and so I could
focus on actually using the computer instead of fighting the OS.
>
Now you know why I don't use Vista :-)
nobody had told me that it was permanent beta, either. As in how
it won't connect to some routers. As in how it might disconnect
dialup when switching users. On and on. Sometimes it won't come
out of sleep (why doesn't that happen to Bill gates?) hehe...
Feb 27 '08 #3

P: n/a
Jerry wrote:
Jerry Stuckle wrote:
>Jerry wrote:
>>I tried to turn on magic_quotes_gpc

behavior shows that it is Off
phpinfo shows it is Off
phpinfo shows path to config file as C:\php\php.ini
setting:
magic_quotes_gpc = On
in C:\php\php.ini does nothing

putting garbage into C:\php\php.ini results in NO error in Apache's
error.log

renaming C:\php\php.ini has No effect

So it must be using default settings. How do I fix?

I hate vista

Does the webserver's userid have access to the php.ini file?

thanks. I guess there's no easy fix and I'll have to delve into
accomplishing that tomorrow. I had the quaint notion that I shouldn't
have the OS fighting me at every turn - and so I could focus on actually
using the computer instead of fighting the OS.
If that's the problem, there is an easy fix. Get he webserver user
access to the php.ini file. It's pretty easy - at least on W2K and W2K3
servers.
>>
Now you know why I don't use Vista :-)

nobody had told me that it was permanent beta, either. As in how it
won't connect to some routers. As in how it might disconnect dialup when
switching users. On and on. Sometimes it won't come out of sleep (why
doesn't that happen to Bill gates?) hehe...
It's Microsoft. :-(. Seriously, I won't install an MS product until at
least 2 service packs have been issued. Then I only install it on a
test system to see if it works yet.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Feb 27 '08 #4

P: n/a
Jerry wrote:
I tried to turn on magic_quotes_gpc

behavior shows that it is Off
phpinfo shows it is Off
phpinfo shows path to config file as C:\php\php.ini
So I may not have the answer, but ....
setting:
magic_quotes_gpc = On
in C:\php\php.ini does nothing

putting garbage into C:\php\php.ini results in NO error in
Apache's error.log
...... have you set the path in httpd.conf?

# configure the path to php.ini
PHPIniDir "c:/php"

(I don't even know enough about Apache to know if this is necessary, but
it's in my config file.)
I hate vista
I hope I never have to use it. XP does just fine.

--
*****************************
Chuck Anderson Boulder, CO
http://www.CycleTourist.com
Nothing he's got he really needs
Twenty first century schizoid man.
***********************************

Feb 27 '08 #5

P: n/a
..oO(Jerry)
>I tried to turn on magic_quotes_gpc
Besides the other responses: Why do you want to turn them on?
Magic quotes are broken and will be completely removed in PHP 6.
There's no reason to use them.

Micha
Feb 27 '08 #6

P: n/a
Jerry wrote:
<snip>
>
nobody had told me that it was permanent beta, either. As in how it
won't connect to some routers. As in how it might disconnect dialup when
switching users. On and on. Sometimes it won't come out of sleep (why
doesn't that happen to Bill gates?) hehe...
Upgrade to Ubuntu, unless you use some Windows applications (like
photoshop, illustrator, etc). Recent WINE update has fixed quite a few
bugs related to Windows program running in Linux.

Unlike what people say, Linux was easier to install on an older laptop
of mine. No need to search for drivers. No need to insert CDs and do 10
re-starts to just install the basic device drivers.
Feb 27 '08 #7

P: n/a
Michael Fesser wrote:
>
Besides the other responses: Why do you want to turn them on?
Magic quotes are broken and will be completely removed in PHP 6.
There's no reason to use them.
well, the shared hosting server had them enabled.

But this morning, I determined how to disable them on the server
and so now I am going with magic_quotes_gpc disabled and using
mysql_real_escape_string() for every INSERT and SELECT to MySQL
(those are all the MySQL that I use.)

So: the PHP manual page on "mysql_real_escape_string" gives the
following example. My question: why are numbers or numeric
strings deliberately not escaped?

// Quote variable to make safe
function quote_smart($value)
{
// Stripslashes
if (get_magic_quotes_gpc()) {
$value = stripslashes($value);
}
// Quote if not a number or a numeric string
if (!is_numeric($value)) {
$value = "'" . mysql_real_escape_string($value) . "'";
}
return $value;
}
(sorry for the double-post before. The newsserver had told me
that the first posting had timed out.)
Feb 27 '08 #8

P: n/a
..oO(Jerry)
>Michael Fesser wrote:
>>
Besides the other responses: Why do you want to turn them on?
Magic quotes are broken and will be completely removed in PHP 6.
There's no reason to use them.

well, the shared hosting server had them enabled.

But this morning, I determined how to disable them on the server
and so now I am going with magic_quotes_gpc disabled
Good.
>and using
mysql_real_escape_string() for every INSERT and SELECT to MySQL
(those are all the MySQL that I use.)
You should also consider to use PDO and prepared statements instead.
On the long run this will be the much more flexible and powerful way.
>So: the PHP manual page on "mysql_real_escape_string" gives the
following example. My question: why are numbers or numeric
strings deliberately not escaped?
If you've checked that the value is a number actually, you don't have to
escape it, simply because a number can't do any harm to the database.
Strings OTOH may contain characters that have a special meaning in an
SQL query. If you want the DB to interpret those chars literarily, you
have to escape them. That's what mysql_real_escape_string() does.

Micha
Feb 27 '08 #9

P: n/a
Jerry wrote:
I tried to turn on magic_quotes_gpc

behavior shows that it is Off
phpinfo shows it is Off
phpinfo shows path to config file as C:\php\php.ini
setting:
magic_quotes_gpc = On
in C:\php\php.ini does nothing

putting garbage into C:\php\php.ini results in NO error in Apache's
error.log

renaming C:\php\php.ini has No effect

So it must be using default settings. How do I fix?
Did you restart Apache?

I hate vista
Doesn't thrill me either.
Feb 28 '08 #10

P: n/a
Tony wrote:
Did you restart Apache?
yes, thanks. Many times. It would have been nice if Apache gave a
notice that it was using a default ini config.

I am using .htaccess on the server to give a directive to disable
Magic Quotes. I suppose I could also use that approach to enable
them on my local machine, if ever necesary. IIRC there is a
performance hit that comes with using .htaccess (since each
subdirectory must then be searched for the existence of any
overriding .htaccess). But in my case, with low traffic, that
shouldn't matter much at all.
Feb 28 '08 #11

P: n/a
On Feb 28, 6:31 am, Jerry <Je...@nospam.notwrote:
Tony wrote:
Did you restart Apache?

yes, thanks. Many times. It would have been nice if Apache gave a
notice that it was using a default ini config.

I am using .htaccess on the server to give a directive to disable
Magic Quotes. I suppose I could also use that approach to enable
them on my local machine, if ever necesary. IIRC there is a
performance hit that comes with using .htaccess (since each
subdirectory must then be searched for the existence of any
overriding .htaccess). But in my case, with low traffic, that
shouldn't matter much at all.
If you installed it using xammp then it will use the php.ini in apache/
bin folder. and not one in other places. Check correctly in phpinfo()
output which php.ini they are using. Then change the php.ini and
restart apache. You may have tried it. Still telling!
Feb 28 '08 #12

P: n/a
Satya wrote:
On Feb 28, 6:31 am, Jerry <Je...@nospam.notwrote:
>Tony wrote:
>>Did you restart Apache?
yes, thanks. Many times. It would have been nice if Apache gave a
notice that it was using a default ini config.

I am using .htaccess on the server to give a directive to disable
Magic Quotes. I suppose I could also use that approach to enable
them on my local machine, if ever necesary. IIRC there is a
performance hit that comes with using .htaccess (since each
subdirectory must then be searched for the existence of any
overriding .htaccess). But in my case, with low traffic, that
shouldn't matter much at all.

If you installed it using xammp then it will use the php.ini in apache/
bin folder. and not one in other places. Check correctly in phpinfo()
output which php.ini they are using. Then change the php.ini and
restart apache. You may have tried it. Still telling!
Did you read his first post?

phpinfo shows path to config file as C:\php\php.ini
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Feb 28 '08 #13

This discussion thread is closed

Replies have been disabled for this discussion.