By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,216 Members | 1,032 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,216 IT Pros & Developers. It's quick & easy.

PHP file 'Hello.php" is not writing anything when run through IE6.0.2

P: n/a
Hi !

Out there, anybody could help tell me what could be the reason that my
php scripting is not giving output in IE6. Which I'm trying from my
webserver itself, having IIS 5 on W2k Advanced server.

I have updated registry HKLM\SOFTWARE\PHP with Per se directory with
value of C:\Inetpub\wwwroot.

Still it's not saying 'Hello' to the world :)

Can anybody guide me to the correct reason / resolution.

Thanks in anticipation.
Vasu
Feb 24 '08 #1
Share this Question
Share on Google+
14 Replies


P: n/a
Vasu wrote:
Hi !

Out there, anybody could help tell me what could be the reason that my
php scripting is not giving output in IE6. Which I'm trying from my
webserver itself, having IIS 5 on W2k Advanced server.

I have updated registry HKLM\SOFTWARE\PHP with Per se directory with
value of C:\Inetpub\wwwroot.

Still it's not saying 'Hello' to the world :)

Can anybody guide me to the correct reason / resolution.
Are you using "C:\Inetpub\wwwroot" as address for the browser?

--
Freundliche Gre,
Franz Marksteiner

Feb 24 '08 #2

P: n/a
On Feb 24, 3:55*pm, "Franz Marksteiner" <franzmarkstei...@gmail.com>
wrote:
Vasu wrote:
Hi !
Out there, anybody could help tell me what could be the reason that my
php scripting is not giving output in IE6. *Which I'm trying from my
webserver itself, having IIS 5 on W2k Advanced server.
I have updated registry HKLM\SOFTWARE\PHP with Per se directory with
value of C:\Inetpub\wwwroot.
Still it's not saying 'Hello' to the world :)
Can anybody guide me to the correct reason / resolution.

Are you using "C:\Inetpub\wwwroot" as address for the browser?

--
Freundliche Gre,
Franz Marksteiner
Hi Franz!

Thanks for your interest in the problem! I'm using the default URL/
Hello.php as address of the php file. Default URL is my web page which
the webserver serves when approached.
Thanks once again.
Vasu
Feb 24 '08 #3

P: n/a
On Feb 24, 3:55*pm, "Franz Marksteiner" <franzmarkstei...@gmail.com>
wrote:
Vasu wrote:
Hi !
Out there, anybody could help tell me what could be the reason that my
php scripting is not giving output in IE6. *Which I'm trying from my
webserver itself, having IIS 5 on W2k Advanced server.
I have updated registry HKLM\SOFTWARE\PHP with Per se directory with
value of C:\Inetpub\wwwroot.
Still it's not saying 'Hello' to the world :)
Can anybody guide me to the correct reason / resolution.

Are you using "C:\Inetpub\wwwroot" as address for the browser?

--
Freundliche Gre,
Franz Marksteiner
Hi Franz!

Sorry for forget to mention that my default URL is placed in the path
'C:\Inetpub\wwwroot\MyWeb'. Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'
browser doesn't prints 'Hello World'!

Thanks
Vasu
Feb 24 '08 #4

P: n/a
Vasu wrote:
On Feb 24, 3:55 pm, "Franz Marksteiner" <franzmarkstei...@gmail.com>
wrote:
>Vasu wrote:
>>Hi !
>>Out there, anybody could help tell me what could be the reason that
my php scripting is not giving output in IE6. Which I'm trying from
my webserver itself, having IIS 5 on W2k Advanced server.
>>I have updated registry HKLM\SOFTWARE\PHP with Per se directory with
value of C:\Inetpub\wwwroot.
>>Still it's not saying 'Hello' to the world :)
>>Can anybody guide me to the correct reason / resolution.

Are you using "C:\Inetpub\wwwroot" as address for the browser?

Sorry for forget to mention that my default URL is placed in the path
'C:\Inetpub\wwwroot\MyWeb'. Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'
browser doesn't prints 'Hello World'!
I suspect that you are trying to access the site via your filesystem, and
not via the webbrowser.
Are you sure that this is not the case?

--
Freundliche Gre,
Franz Marksteiner

Feb 24 '08 #5

P: n/a
Franz Marksteiner wrote:
Vasu wrote:
>On Feb 24, 3:55 pm, "Franz Marksteiner" <franzmarkstei...@gmail.com>
wrote:
>>Vasu wrote:
Hi !

Out there, anybody could help tell me what could be the reason that
my php scripting is not giving output in IE6. Which I'm trying from
my webserver itself, having IIS 5 on W2k Advanced server.

I have updated registry HKLM\SOFTWARE\PHP with Per se directory
with value of C:\Inetpub\wwwroot.

Still it's not saying 'Hello' to the world :)

Can anybody guide me to the correct reason / resolution.

Are you using "C:\Inetpub\wwwroot" as address for the browser?

Sorry for forget to mention that my default URL is placed in the path
'C:\Inetpub\wwwroot\MyWeb'. Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click
'yes' browser doesn't prints 'Hello World'!

I suspect that you are trying to access the site via your filesystem,
and not via the webbrowser.
Are you sure that this is not the case?
I am so sorry, of course I wanted to say webserver instead of webbrowser.

--
Freundliche Gre,
Franz Marksteiner

Feb 24 '08 #6

P: n/a
Greetings, Vasu.
In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'
What means - You've wrong settings for Your webserver.
And by the way, can You please post EXACT URL which You using to access Your
test page?
--
Sincerely Yours, AnrDaemon <an*******@freemail.ru>

Feb 26 '08 #7

P: n/a
On Feb 26, 12:13*pm, AnrDaemon <anrdae...@freemail.ruwrote:
Greetings, Vasu.
In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'

What means - You've wrong settings for Your webserver.
And by the way, can You please post EXACT URL which You using to access Your
test page?

--
Sincerely Yours, AnrDaemon <anrdae...@freemail.ru>
Greetings, AnrDaemon

my exact URL is www.bhaaratvarshmahaan.com, then I put /hello.php
after it but it doesn't run.
And I try to run this from the server m/c itself. If I put only URL
the default web page opens perfectly, but when I put the hello.php
behind then there is the problem. In the meantime I have experienced
that I'm not able to get my webpage from internet after recent problem
with my ISP. So I'm trying to get that resolved first. Then only I'll
focuse on this PHP problem.

Thanks anyway for your support / interest.
Vasu

Feb 26 '08 #8

P: n/a
Vasu wrote:
On Feb 26, 12:13 pm, AnrDaemon <anrdae...@freemail.ruwrote:
>Greetings, Vasu.
In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
>>Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'
What means - You've wrong settings for Your webserver.
And by the way, can You please post EXACT URL which You using to access Your
test page?

--
Sincerely Yours, AnrDaemon <anrdae...@freemail.ru>

Greetings, AnrDaemon

my exact URL is www.bhaaratvarshmahaan.com, then I put /hello.php
after it but it doesn't run.
And I try to run this from the server m/c itself. If I put only URL
the default web page opens perfectly, but when I put the hello.php
behind then there is the problem. In the meantime I have experienced
that I'm not able to get my webpage from internet after recent problem
with my ISP. So I'm trying to get that resolved first. Then only I'll
focuse on this PHP problem.

Thanks anyway for your support / interest.
Vasu

Default page:

401 Unauthorized
Authorization required for the URL '/'.

/hello.php:

404 Not Found
The requested URL '/hello.php' was not found on this server.

But your message indicates your server is not set up properly to parse
..php pages as PHP code.

You need to check your web server configuration.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Feb 26 '08 #9

P: n/a
On Feb 26, 8:41*pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Vasu wrote:
On Feb 26, 12:13 pm, AnrDaemon <anrdae...@freemail.ruwrote:
Greetings, Vasu.
In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
>Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'
What means - You've wrong settings for Your webserver.
And by the way, can You please post EXACT URL which You using to accessYour
test page?
--
Sincerely Yours, AnrDaemon <anrdae...@freemail.ru>
Greetings, AnrDaemon
my exact URL iswww.bhaaratvarshmahaan.com, then I put /hello.php
after it but it doesn't run.
And I try to run this from the server m/c itself. If I put only URL
the default web page opens perfectly, but when I put the hello.php
behind then there is the problem. *In the meantime I have experienced
that I'm not able to get my webpage from internet after recent problem
with my ISP. *So I'm trying to get that resolved first. Then only I'll
focuse on this PHP problem.
Thanks anyway for your support / interest.
Vasu

Default page:

401 Unauthorized
Authorization required for the URL '/'.

/hello.php:

404 Not Found
The requested URL '/hello.php' was not found on this server.

But your message indicates your server is not set up properly to parse
.php pages as PHP code.

You need to check your web server configuration.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -

- Show quoted text -
Hi Jerry!

As you might have seen that recently my modem created some problem
then I approached my ISP and they reset it, but after resetting the
modem, I could open any website from the server but my web pages could
not be opened from internet. Although before I faced problem with the
modem, my web pages were opening quite perfectly from the internet.

Thanks anyway for the interest you have shown.

I'm in touch with my ISP to get it rectified and once it is taken care
then I'll ask your kind help on the matter.

Thanks once again.
Vasu
Feb 27 '08 #10

P: n/a
On Wed, 27 Feb 2008 17:26:15 +0100, Vasu <va**************@yahoo.co.uk>
wrote:
As you might have seen that recently my modem created some problem
then I approached my ISP and they reset it, but after resetting the
modem, I could open any website from the server but my web pages could
not be opened from internet. Although before I faced problem with the
modem, my web pages were opening quite perfectly from the internet.

Thanks anyway for the interest you have shown.

I'm in touch with my ISP to get it rectified and once it is taken care
then I'll ask your kind help on the matter.
Sounds to me you should simply forward port 80 on the modem to the server
the page is actually on in your local network?
--
Rik Wasmus
Feb 27 '08 #11

P: n/a
Vasu wrote:
On Feb 26, 8:41 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
>Vasu wrote:
>>On Feb 26, 12:13 pm, AnrDaemon <anrdae...@freemail.ruwrote:
Greetings, Vasu.
In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'
What means - You've wrong settings for Your webserver.
And by the way, can You please post EXACT URL which You using to access Your
test page?
--
Sincerely Yours, AnrDaemon <anrdae...@freemail.ru>
Greetings, AnrDaemon
my exact URL iswww.bhaaratvarshmahaan.com, then I put /hello.php
after it but it doesn't run.
And I try to run this from the server m/c itself. If I put only URL
the default web page opens perfectly, but when I put the hello.php
behind then there is the problem. In the meantime I have experienced
that I'm not able to get my webpage from internet after recent problem
with my ISP. So I'm trying to get that resolved first. Then only I'll
focuse on this PHP problem.
Thanks anyway for your support / interest.
Vasu
Default page:

401 Unauthorized
Authorization required for the URL '/'.

/hello.php:

404 Not Found
The requested URL '/hello.php' was not found on this server.

But your message indicates your server is not set up properly to parse
.php pages as PHP code.

You need to check your web server configuration.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -

- Show quoted text -

Hi Jerry!

As you might have seen that recently my modem created some problem
then I approached my ISP and they reset it, but after resetting the
modem, I could open any website from the server but my web pages could
not be opened from internet. Although before I faced problem with the
modem, my web pages were opening quite perfectly from the internet.

Thanks anyway for the interest you have shown.

I'm in touch with my ISP to get it rectified and once it is taken care
then I'll ask your kind help on the matter.

Thanks once again.
Vasu
Are you sure when they reset your modem you didn't get a new dynamic IP
address?

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Feb 27 '08 #12

P: n/a
On Feb 27, 10:08*pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Vasu wrote:
On Feb 26, 8:41 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Vasu wrote:
On Feb 26, 12:13 pm, AnrDaemon <anrdae...@freemail.ruwrote:
Greetings, Vasu.
In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
Further! what is happening is that when
we browse to the place of php file a security alert message comes up
informing if we want to run the php script, but even if we click 'yes'
What means - You've wrong settings for Your webserver.
And by the way, can You please post EXACT URL which You using to access Your
test page?
--
Sincerely Yours, AnrDaemon <anrdae...@freemail.ru>
Greetings, AnrDaemon
my exact URL iswww.bhaaratvarshmahaan.com, then I put /hello.php
after it but it doesn't run.
And I try to run this from the server m/c itself. If I put only URL
the default web page opens perfectly, but when I put the hello.php
behind then there is the problem. *In the meantime I have experienced
that I'm not able to get my webpage from internet after recent problem
with my ISP. *So I'm trying to get that resolved first. Then only I'll
focuse on this PHP problem.
Thanks anyway for your support / interest.
Vasu
Default page:
401 Unauthorized
Authorization required for the URL '/'.
/hello.php:
404 Not Found
The requested URL '/hello.php' was not found on this server.
But your message indicates your server is not set up properly to parse
.php pages as PHP code.
You need to check your web server configuration.
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -
- Show quoted text -
Hi Jerry!
As you might have seen that recently my modem created some problem
then I approached my ISP and they reset it, but after resetting the
modem, I could open any website from the server but my web pages could
not be opened from internet. Although before I faced problem with the
modem, my web pages were opening quite perfectly from the internet.
Thanks anyway for the interest you have shown.
I'm in touch with my ISP to get it rectified and once it is taken care
then I'll ask your kind help on the matter.
Thanks once again.
Vasu

Are you sure when they reset your modem you didn't get a new dynamic IP
address?

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -

- Show quoted text -
Hi Jerry, AnrDaemon, and Franz!

My ISP has corrected the problem and my website is now fully online.
However, even now when I type www.bhaaratvarshmahaan.com\hello.php,
the browser keeps on loading but nothing comes up finally. At the same
time when I simply type the above mentioned URL without '\hello.php'
it opens excellent. So I seek help from people like you.

Thanks and regards
Vasu
Mar 30 '08 #13

P: n/a
Vasu wrote:
On Feb 27, 10:08 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
>Vasu wrote:
>>On Feb 26, 8:41 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Vasu wrote:
On Feb 26, 12:13 pm, AnrDaemon <anrdae...@freemail.ruwrote:
>Greetings, Vasu.
>In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
>>Further! what is happening is that when
>>we browse to the place of php file a security alert message comes up
>>informing if we want to run the php script, but even if we click 'yes'
>What means - You've wrong settings for Your webserver.
>And by the way, can You please post EXACT URL which You using to access Your
>test page?
>--
>Sincerely Yours, AnrDaemon <anrdae...@freemail.ru>
Greetings, AnrDaemon
my exact URL iswww.bhaaratvarshmahaan.com, then I put /hello.php
after it but it doesn't run.
And I try to run this from the server m/c itself. If I put only URL
the default web page opens perfectly, but when I put the hello.php
behind then there is the problem. In the meantime I have experienced
that I'm not able to get my webpage from internet after recent problem
with my ISP. So I'm trying to get that resolved first. Then only I'll
focuse on this PHP problem.
Thanks anyway for your support / interest.
Vasu
Default page:
401 Unauthorized
Authorization required for the URL '/'.
/hello.php:
404 Not Found
The requested URL '/hello.php' was not found on this server.
But your message indicates your server is not set up properly to parse
.php pages as PHP code.
You need to check your web server configuration.
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -
- Show quoted text -
Hi Jerry!
As you might have seen that recently my modem created some problem
then I approached my ISP and they reset it, but after resetting the
modem, I could open any website from the server but my web pages could
not be opened from internet. Although before I faced problem with the
modem, my web pages were opening quite perfectly from the internet.
Thanks anyway for the interest you have shown.
I'm in touch with my ISP to get it rectified and once it is taken care
then I'll ask your kind help on the matter.
Thanks once again.
Vasu
Are you sure when they reset your modem you didn't get a new dynamic IP
address?

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -

- Show quoted text -

Hi Jerry, AnrDaemon, and Franz!

My ISP has corrected the problem and my website is now fully online.
However, even now when I type www.bhaaratvarshmahaan.com\hello.php,
the browser keeps on loading but nothing comes up finally. At the same
time when I simply type the above mentioned URL without '\hello.php'
it opens excellent. So I seek help from people like you.

Thanks and regards
Vasu
URL's don't have backslashes.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================

Mar 30 '08 #14

P: n/a
On Mar 30, 6:43*pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Vasu wrote:
On Feb 27, 10:08 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Vasu wrote:
On Feb 26, 8:41 pm, Jerry Stuckle <jstuck...@attglobal.netwrote:
Vasu wrote:
On Feb 26, 12:13 pm, AnrDaemon <anrdae...@freemail.ruwrote:
Greetings, Vasu.
In reply to Your message dated Sunday, February 24, 2008, 16:49:08,
>Further! what is happening is that when
>we browse to the place of php file a security alert message comes up
>informing if we want to run the php script, but even if we click 'yes'
What means - You've wrong settings for Your webserver.
And by the way, can You please post EXACT URL which You using to access Your
test page?
--
Sincerely Yours, AnrDaemon <anrdae...@freemail.ru>
Greetings, AnrDaemon
my exact URL iswww.bhaaratvarshmahaan.com, then I put /hello.php
after it but it doesn't run.
And I try to run this from the server m/c itself. If I put only URL
the default web page opens perfectly, but when I put the hello.php
behind then there is the problem. *In the meantime I have experienced
that I'm not able to get my webpage from internet after recent problem
with my ISP. *So I'm trying to get that resolved first. Then only I'll
focuse on this PHP problem.
Thanks anyway for your support / interest.
Vasu
Default page:
401 Unauthorized
Authorization required for the URL '/'.
/hello.php:
404 Not Found
The requested URL '/hello.php' was not found on this server.
But your message indicates your server is not set up properly to parse
.php pages as PHP code.
You need to check your web server configuration.
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -
- Show quoted text -
Hi Jerry!
As you might have seen that recently my modem created some problem
then I approached my ISP and they reset it, but after resetting the
modem, I could open any website from the server but my web pages could
not be opened from internet. Although before I faced problem with the
modem, my web pages were opening quite perfectly from the internet.
Thanks anyway for the interest you have shown.
I'm in touch with my ISP to get it rectified and once it is taken care
then I'll ask your kind help on the matter.
Thanks once again.
Vasu
Are you sure when they reset your modem you didn't get a new dynamic IP
address?
--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -
- Show quoted text -
Hi Jerry, AnrDaemon, and Franz!
My ISP has corrected the problem and my website is now fully online.
However, even now when I typewww.bhaaratvarshmahaan.com\hello.php,
the browser keeps on loading but nothing comes up finally. At the same
time when I simply type the above mentioned URL without '\hello.php'
it opens excellent. So I seek help from people like you.
Thanks and regards
Vasu

URL's don't have backslashes.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
jstuck...@attglobal.net
==================- Hide quoted text -

- Show quoted text -
Hi Jerry, AnrDaemon, and Franz!

I thank you all. Jerry you are right. It was my mistake. It was
forward slash onlyu.

And for that matter, I found the solution. Now my script can say
'Hello' to the world. The culprit was cgi.force-redirect entry.

However! I once again thank you all for your interest and valuable
time spend for my problem.

Regards!

Vasu
Mar 31 '08 #15

This discussion thread is closed

Replies have been disabled for this discussion.