By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,831 Members | 2,296 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,831 IT Pros & Developers. It's quick & easy.

how to configure PHP5 to use MySQL in Windows XP

P: n/a
I use PHP5 in Windows XP Professional with Apache and MySQL installed. I
would like to use MySQL. Now, I cannot use mysql_* functions because
mysql_connect(...) returns
Fatal error: Call to undefined function mysql_connect()
PHP is problably not correctly configured to use MySQL. I think so, because
when I open:
localhost/phpinfo.php
I receive no information about MySQL.
So far, I have modified c:\windows\php.ini:
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
extension_dir = "c:/windows"
extension=php_mysql.dll
extension=php_mysqli.dll
extension=libmysql.dll
But it is probably not correct or not enough, I suspect. All *mysql*.dll
files are in c:\windows folder.
Could you help me plase?
/RAM/
Feb 20 '08 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On Feb 20, 5:09 am, "R.A.M." <r_ahims...@poczta.onet.plwrote:
I use PHP5 in Windows XP Professional with Apache and MySQL installed. I
would like to use MySQL. Now, I cannot use mysql_* functions because
mysql_connect(...) returns
Fatal error: Call to undefined function mysql_connect()
PHP is problably not correctly configured to use MySQL. I think so, because
when I open:
localhost/phpinfo.php
I receive no information about MySQL.
So far, I have modified c:\windows\php.ini:
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
extension_dir = "c:/windows"
extension=php_mysql.dll
extension=php_mysqli.dll
extension=libmysql.dll
But it is probably not correct or not enough, I suspect. All *mysql*.dll
files are in c:\windows folder.
Could you help me plase?
/RAM/
did you restart apache after changing your php.ini file? If your
running php as a module you need to restart.
Feb 20 '08 #2

P: n/a
Uzytkownik "ELINTPimp" <sm*****@gmail.comnapisal w wiadomosci
news:3c**********************************@b29g2000 hsa.googlegroups.com...
did you restart apache after changing your php.ini file? If your
running php as a module you need to restart.
Yes, I rebooted my computer. Still, the same problem.
/RAM/
Feb 20 '08 #3

P: n/a
Greetings, R.A.M..
In reply to Your message dated Wednesday, February 20, 2008, 13:09:19,
I use PHP5 in Windows XP Professional with Apache and MySQL installed. I
would like to use MySQL. Now, I cannot use mysql_* functions because
mysql_connect(...) returns
Fatal error: Call to undefined function mysql_connect()
PHP is problably not correctly configured to use MySQL. I think so, because
when I open:
localhost/phpinfo.php
I receive no information about MySQL.
So far, I have modified c:\windows\php.ini:
;;;;;;;;;;;;;;;;;;;;;;
; Dynamic Extensions ;
;;;;;;;;;;;;;;;;;;;;;;
extension_dir = "c:/windows"
?????????????????????????????????????
I *hope* You didn't install PHP into Your Windows directory...
extension=php_mysql.dll
extension=php_mysqli.dll
extension=libmysql.dll
But it is probably not correct or not enough, I suspect. All *mysql*.dll
files are in c:\windows folder.
Could you help me plase?
Install Your PHP into separate directory as intended.
It may be C:\php or whatever You prefer.
Point the extension_dir to the C:\php\ext (i.e.) where all extensions is
located.
--
Sincerely Yours, AnrDaemon <an*******@freemail.ru>

Feb 20 '08 #4

This discussion thread is closed

Replies have been disabled for this discussion.