By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,723 Members | 1,876 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,723 IT Pros & Developers. It's quick & easy.

PHP script is not running and leave a blank page

P: 82
For some reason when I try to run any login PHP script that comes with the roscript login package (http://www.roscripts.com/PHP_login_script-143.html ) in any browser I got a blank page with nothing inside it. . When I run in the same directory any simple script like one that contians PHPINFO every thing goes great. I can access and see the login directory and all sub-directories, Can someone advice.

I belive I configured both php.ini and apache htppd.conf files. it seems to me like a permission problem, I fighting with it in the couple last days.

My working root directory is:"F:\Internet\RCExperts\Development\" and the login package is sit under F:\Internet\RCExperts\Development\src\login\"

Changes I done to the httpd.conf file:
-------------------------------------------------------
Expand|Select|Wrap|Line Numbers
  1. DocumentRoot "F:/Internet/RCExperts/Development"
  2. # This should be changed to whatever you set DocumentRoot to.
  3. #
  4. #<Directory "E:/Program Files/Apache2.2/htdocs">
  5. <Directory "F:/Internet/RCExperts/Development">
  6. ************************************************** *****************
  7. # This should be changed to whatever you set DocumentRoot to.
  8. #
  9. #<Directory "E:/Program Files/Apache2.2/htdocs">
  10. <Directory "F:/Internet/RCExperts/Development">
  11. #
  12. # Possible values for the Options directive are "None", "All",
  13. # or any combination of:
  14. # Indexes Includes FollowSymLinks SymLinksifOwnerMatch ExecCGI MultiViews
  15. #
  16. # Note that "MultiViews" must be named *explicitly* --- "Options All"
  17. # doesn't give it to you.
  18. #
  19. # The Options directive is both complicated and important. Please see
  20. # http://httpd.apache.org/docs/2.2/mod/core.html#options
  21. # for more information.
  22. #
  23. Options Indexes FollowSymLinks
  24.  
  25. #
  26. # AllowOverride controls what directives may be placed in .htaccess files.
  27. # It can be "All", "None", or any combination of the keywords:
  28. # Options FileInfo AuthConfig Limit
  29. #
  30. AllowOverride None
  31. #
  32. # Controls who can get stuff from this server.
  33. #
  34. Order deny,Allow
  35. Allow from all
  36.  
  37. </Directory>
  38. **********************************
  39. ScriptAlias /php/ "E:/Program Files/PHP"
  40. AddType application/x-httpd-php .php .php5
  41. Action application/x-httpd-php "/php/php-cgi.exe"
  42. SetEnv PHPRC "E:/Program Files/PHP"
  43. ************************************************** ***********
  44.  
  45. Changes I done to the php.ini file:
  46. --------------------------------------------------
  47.  
  48. include_path = ".;E:\Program files\PHP\includes;F:\Internet\RCExperts\Developme nt\php\login\lib;F:\Internet\RCExperts\Development \php\login\lib\date_class;F:\Internet\RCExperts\De velopment\php\login\lib\phpmailer;F:\Internet\RCEx perts\Development\php\login\css;F:\Internet\RCExpe rts\Development\php\login\images"
  49.  
  50. ********************
  51.  
  52. doc_root =".;F:\Internet\RCExperts\Development"
  53.  
  54. *******************
  55.  
  56. user_dir =".;F:\Internet\RCExperts\Development"
  57.  
********************

------------------------------
My environment setting is:

Microsoft windows server 2003
1) PHP 5.2.5
2) Apache server 2.2

Can someone please help

Please adhere to the Posting Guidelines and show any code or statements wihin the appropriate code tags!! - moderator
Feb 18 '08 #1
Share this Question
Share on Google+
4 Replies


ronverdonk
Expert 2.5K+
P: 4,258
If you are able to run a simple phpinfo script, there is nothing wrong with the installation of php on your server.
But do you run your downloaded login script from a directory that is within your server's root folder's reach? If so, there must be an error in the script itself.

Best thing would be to put some trace/debug info in the script an see if you can pinpoint the problem.

Ronald
Feb 18 '08 #2

P: 82
ronverdonk,

Thanks, but when I run each of the scripts within my phped it is just run fine.
Can you look at the configuration changes that I made in the php.ini and in the httpd.cong file and tell me if something is missing/wrong or you can take a look at the linked that I attached with the source code.I want tofinish with the development environment settings.

Thanks
Ronen
Feb 18 '08 #3

P: 82
Ok,Thanks all after debugging I found and fixed the problem.
Feb 18 '08 #4

ronverdonk
Expert 2.5K+
P: 4,258
Glad you found it! Do you want to share your solution with our members, so they could also benefit from it? Thanks and until next time.

Ronald
Feb 18 '08 #5

Post your reply

Sign in to post your reply or Sign up for a free account.