By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
445,871 Members | 1,209 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 445,871 IT Pros & Developers. It's quick & easy.

Session Save Path

P: n/a
I thought that moving the session files would be as simple as changing

session.save_path = /tmp

to some other directory. Is there more that is required? I pointed at
/sess but the directory continues to be as empty as when I created it.
;)

TIA
Bill
Jul 17 '05 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Bill H wrote:
I thought that moving the session files would be as simple as changing

session.save_path = /tmp

to some other directory. Is there more that is required? I pointed at
/sess but the directory continues to be as empty as when I created it.


Did you restart the web server? When using PHP as an apache module,
php.ini is only read in at startup.

Make sure also that /sess is writable by the web server user or group.

-- brion vibber (brion @ pobox.com)
Jul 17 '05 #2

P: n/a
On Tue, 17 Aug 2004 15:26:14 -0700, Brion Vibber <br***@pobox.com>
wrote:
Bill H wrote:
I thought that moving the session files would be as simple as changing

session.save_path = /tmp

to some other directory. Is there more that is required? I pointed at
/sess but the directory continues to be as empty as when I created it.


Did you restart the web server? When using PHP as an apache module,
php.ini is only read in at startup.

Make sure also that /sess is writable by the web server user or group.

-- brion vibber (brion @ pobox.com)


Thanks for the push in the right direction (I think). I'm not to
bright in terms of NIX but I think the permissions might be the
problem... when I "ls -l" /sess I get nothing, while I'll get
something like:

lrwxrwxrwx 1 root root 13 May 21 16:18 tmp ->
usr/local/tmp

on all the other directories.

Jul 17 '05 #3

P: n/a
Bill H <maylar69@hot----.com> wrote in message news:<au********************************@4ax.com>. ..
On Tue, 17 Aug 2004 15:26:14 -0700, Brion Vibber <br***@pobox.com>
wrote:
Bill H wrote:
I thought that moving the session files would be as simple as changing

session.save_path = /tmp

to some other directory. Is there more that is required? I pointed at
/sess but the directory continues to be as empty as when I created it.
<snip>
Thanks for the push in the right direction (I think). I'm not to
bright in terms of NIX but I think the permissions might be the
problem... when I "ls -l" /sess I get nothing, while I'll get
something like:

lrwxrwxrwx 1 root root 13 May 21 16:18 tmp ->
usr/local/tmp

on all the other directories.

</snip>
Are you sure that /sess exists where you expect it to be? Any chance
you created it somewhere else (possibly your home directory or
something of that sort?) You should at least be seeing it in "ls -l
/". If not, possibly try "locate sess" to see where it actually was
created...

Also, try something like "tail -f /var/log/httpd/error_log | grep -i
'php'" and hit a page that should work with sessions...you'll see
something there if there's a directory problem. You'll need to replace
/var/log... with the appropriate path to your error_log
Jul 17 '05 #4

P: n/a
On 19 Aug 2004 12:39:38 -0700, go****@robot138.com (name?) wrote:
Bill H <maylar69@hot----.com> wrote in message news:<au********************************@4ax.com>. ..
On Tue, 17 Aug 2004 15:26:14 -0700, Brion Vibber <br***@pobox.com>
wrote:
>Bill H wrote:
>> I thought that moving the session files would be as simple as changing
>>
>> session.save_path = /tmp
>>
>> to some other directory. Is there more that is required? I pointed at
>> /sess but the directory continues to be as empty as when I created it.

<snip>

Thanks for the push in the right direction (I think). I'm not to
bright in terms of NIX but I think the permissions might be the
problem... when I "ls -l" /sess I get nothing, while I'll get
something like:

lrwxrwxrwx 1 root root 13 May 21 16:18 tmp ->
usr/local/tmp

on all the other directories.

</snip>
Are you sure that /sess exists where you expect it to be? Any chance
you created it somewhere else (possibly your home directory or
something of that sort?) You should at least be seeing it in "ls -l
/". If not, possibly try "locate sess" to see where it actually was
created...

Also, try something like "tail -f /var/log/httpd/error_log | grep -i
'php'" and hit a page that should work with sessions...you'll see
something there if there's a directory problem. You'll need to replace
/var/log... with the appropriate path to your error_log


Sorry, one day I'll learn to be more specific. When I said ls -l
didn't show anything I meant it didn't show any of the permissions or
the owner as it does with other directories. I'm sure it's in the
correct location.
Jul 17 '05 #5

P: n/a
Bill H wrote:
Thanks for the push in the right direction (I think). I'm not to
bright in terms of NIX but I think the permissions might be the
problem... when I "ls -l" /sess I get nothing, while I'll get
something like:

lrwxrwxrwx 1 root root 13 May 21 16:18 tmp ->
usr/local/tmp
[snip] Sorry, one day I'll learn to be more specific. When I said ls -l
didn't show anything I meant it didn't show any of the permissions or
the owner as it does with other directories. I'm sure it's in the
correct location.


'ls -l' normally will not show anything on an empty directory, because
this will show the files _contained in_ the directory, not the directory
itself.

(It looks like your /tmp is a symbolic link to a directory whose actual
location is elsewhere, so it displays differently.)

If you want to look at the directory itself, use 'ls -ld'. The d option
tells ls that when you've given it a directory you really want to look
at the directory itself, not its contents.

-- brion vibber (brion @ pobox.com)
Jul 17 '05 #6

This discussion thread is closed

Replies have been disabled for this discussion.