By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
434,998 Members | 2,773 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 434,998 IT Pros & Developers. It's quick & easy.

Help w/Zend Studio install...

P: n/a
Hi...

OK...I'm having difficulty understanding a problem with installing
Zend Studio 5.5 on an Intel Mac.

Prior to the install, I had the zend /library installed, and was able
to successfully run Zend_Db commands against a local mysql server
(5.1) from the commandline (e.g. php testdb.php). This stuff ran just
fine. The code is simply:

<?php
ini_set('include_path',ini_get('include_path').'.:/Users/joet/Zend/
ZendStudio-5.5.0/bin/ZendFramework/library/');

require_once 'Zend.php';
require_once 'Zend/Db.php';

$config = array(
'host' ='localhost',
'username' ='test',
'password' ='test',
'dbname' ='test',);
$db = Zend_Db::factory('PDO_MYSQL', $config);
print_r($db->fetchAll("SELECT * FROM testdata"));

?>

Now, if I run the exact same code from Zend Studio, I get the message:

<b>Fatal error</b>: Uncaught exception 'Zend_Db_Adapter_Exception'
with message 'The mysql driver is not currently installed' in /Users/
joet/Zend/ZendStudio-5.5.0/bin/ZendFramework/library/Zend/Db/Adapter/
Pdo/Abstract.php:80

I am assuming that there is some setup issue that is causing Zend
Studio to work incorrectly.

Can anyone shed some light on where I might look to resolve the issue?

Thanks,
Joe
Dec 19 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.