470,849 Members | 1,095 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 470,849 developers. It's quick & easy.

Problem Making php 4.3.8

Forgive me, this is probably a very simple problem, but it's new to
me.
When I attempt to make php 4.3.8, it exits, and I believe the relevant
message is:

libtool: link: cannot find the library `'

I suspect it may be a problem with the Makefile, but more likely, I
have failed to configure php correctly. Here's the configure command I
used:

./configure --enable-versioning --enable-memory-limit
--with-layout=GNU --enable-force-cgi-redirect --enable-discard-path
--enable-fastcgi --with-openssl --with-zlib --enable-bcmath --with-bz2
--enable-calendar --with-crack --with-curl --with-cyrus --with-db4
--with-inifile --enable-dio --with-dom --enable-exif
--with-zlib-dir=/usr/lib --with-dom-xslt --with-dom-exslt
--enable-exif --enable-ftp --with-gd --with-gettext --with-gmp
--with-hyperwave --with-iconv --with-imap --with-imap-ssl
--enable-mbstring --with-mcal --with-mcrypt --with-mcve
--with-openssl-dir --with-mhash --with-mime-magic --with-ming
--with-mnogosearch=/usr/local --with-mysql --with-pspell
--enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm
--with-zip --with-apxs

I'd be grateful for any help anyone can provide.
Jul 17 '05 #1
2 1407
Befuddled wrote:
--with-openssl-dir --with-mhash --with-mime-magic --with-ming
--with-mnogosearch=/usr/local --with-mysql --with-pspell
--enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm
--with-zip --with-apxs

I'd be grateful for any help anyone can provide.


I had a similar problem when I was trying to make php from a path with
special characters like SPACE, ', "", etc. but I don't remember which
one exactly, was many years ago...

darko
--
"Cosa sono i milioni, quando in cambio ti danno le scarpe ?"
http://www.autistici.org/darko
Jul 17 '05 #2
Befuddled skrev:
Forgive me, this is probably a very simple problem, but it's new to
me.
When I attempt to make php 4.3.8, it exits, and I believe the relevant
message is:

libtool: link: cannot find the library `'

I suspect it may be a problem with the Makefile, but more likely, I
have failed to configure php correctly. Here's the configure command I
used:

./configure --enable-versioning --enable-memory-limit
--with-layout=GNU --enable-force-cgi-redirect --enable-discard-path
--enable-fastcgi --with-openssl --with-zlib --enable-bcmath --with-bz2
--enable-calendar --with-crack --with-curl --with-cyrus --with-db4
--with-inifile --enable-dio --with-dom --enable-exif
--with-zlib-dir=/usr/lib --with-dom-xslt --with-dom-exslt
--enable-exif --enable-ftp --with-gd --with-gettext --with-gmp
--with-hyperwave --with-iconv --with-imap --with-imap-ssl
--enable-mbstring --with-mcal --with-mcrypt --with-mcve
--with-openssl-dir --with-mhash --with-mime-magic --with-ming
--with-mnogosearch=/usr/local --with-mysql --with-pspell
--enable-sockets --enable-sysvmsg --enable-sysvsem --enable-sysvshm
--with-zip --with-apxs

I'd be grateful for any help anyone can provide.


1) you haven't specified a dir to --with-openssl-dir.
I know that ./configure --help describes it as optional, but in my
experience it's not
2) try disabling/enabling the directives in groups to find the one
that's giving you trouble

--
Bjarne D Mathiesen http://mozilla.mathiesen.info/
København N ; Danmark ; Europa
----------------------------------------------------------------------
denne besked er skrevet i et totalt M$/Intel-frit miljø
MacOS X 10.3.4 Panther ; Mozilla 1.7rc1+ ; PowerPC G4 800MHz
Jul 17 '05 #3

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

28 posts views Thread by Jon Davis | last post: by
11 posts views Thread by ASP newbie | last post: by
2 posts views Thread by Richard Lionheart | last post: by
30 posts views Thread by Einstein30000 | last post: by
1 post views Thread by Uwe Kotyczka | last post: by
6 posts views Thread by James Dow Allen | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.