469,358 Members | 1,633 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 469,358 developers. It's quick & easy.

PHPMyAdmin

SCS
Running PHP 4.5.7
PHPMyAdmin 2.5.7-pl1
IIS 6

I am thrying to get phpmyadmin to work, but whenever I click a link or try
to browse a database I get a 404 error, because the PmaAbsoluteUri
auto-detection is nor working properly.
Im pretty sure it is a problem with my php.ini file, but Im not sure where
to look... can someone please help

Many Thanks
Jul 17 '05 #1
7 6157
SCS wrote:
I am thrying to get phpmyadmin to work, but whenever I click a link or try
to browse a database I get a 404 error, because the PmaAbsoluteUri
auto-detection is nor working properly.
Im pretty sure it is a problem with my php.ini file, but Im not sure where
to look... can someone please help


Try the phpMyAdmin configuration file - it's called config.inc.php and
is in the root directory of your phpMyadmin installation.

It should look something like
$cfg['PmaAbsoluteUri'] = 'http://<server name>/phpmyadmin';

Or whatever the path to your installation is *through* the server.

HTH, Regards,

Andy

Jul 17 '05 #2
SCS
I have looked at that yeah, but I want to be able to run PHPMyAdmin from
within my Network (e.g http://localhost) and also from the internet
(http://www.mydomain.co.uk) any ideas on that one.. also the Auto thingy
should work..

Thanks Again

"Andy Barfield" <ab**********@yahoo.com> wrote in message
news:hv********************@nildram.net...
SCS wrote:
I am thrying to get phpmyadmin to work, but whenever I click a link or try to browse a database I get a 404 error, because the PmaAbsoluteUri
auto-detection is nor working properly.
Im pretty sure it is a problem with my php.ini file, but Im not sure where to look... can someone please help


Try the phpMyAdmin configuration file - it's called config.inc.php and
is in the root directory of your phpMyadmin installation.

It should look something like
$cfg['PmaAbsoluteUri'] = 'http://<server name>/phpmyadmin';

Or whatever the path to your installation is *through* the server.

HTH, Regards,

Andy

Jul 17 '05 #3
SCS wrote:
I have looked at that yeah, but I want to be able to run PHPMyAdmin from
within my Network (e.g http://localhost) and also from the internet
(http://www.mydomain.co.uk) any ideas on that one.. also the Auto thingy
should work..


Hmmmmm - interesting - seems to work fing on a LAMP setup I'm running
here. A brief glance at the docs suggests that you can set it
dynamically, though I'm not sure it would help, it may be worth a try.

http://www.phpmyadmin.net/documentation/#config for details.

Regards,

Andy
Jul 17 '05 #4

"SCS" <en*******@scswise.co.uk> wrote in message
news:cd**********@sparta.btinternet.com...
"Andy Barfield" <ab**********@yahoo.com> wrote in message
news:hv********************@nildram.net...
SCS wrote:
I am thrying to get phpmyadmin to work, but whenever I click a link or try to browse a database I get a 404 error, because the PmaAbsoluteUri
auto-detection is nor working properly.
Im pretty sure it is a problem with my php.ini file, but Im not sure where to look... can someone please help


Try the phpMyAdmin configuration file - it's called config.inc.php and
is in the root directory of your phpMyadmin installation.

It should look something like
$cfg['PmaAbsoluteUri'] = 'http://<server name>/phpmyadmin';

Or whatever the path to your installation is *through* the server.

HTH, Regards,

Andy

I have looked at that yeah, but I want to be able to run PHPMyAdmin from
within my Network (e.g http://localhost) and also from the internet
(http://www.mydomain.co.uk) any ideas on that one.. also the Auto thingy
should work..


Since the instance of phpMyAdmin will only run on the one server, what
difference to you expect to see when accessing it from intranet versus
internet? The path in question is the path that the server on which
phpMyAdmin is running must use to access the database. Little to do with who
happens to be accessing phpMyAdmin or how.

- Virgil
Jul 17 '05 #5
Virgil Green wrote:
Since the instance of phpMyAdmin will only run on the one server, what
difference to you expect to see when accessing it from intranet versus
internet? The path in question is the path that the server on which
phpMyAdmin is running must use to access the database. Little to do with who
happens to be accessing phpMyAdmin or how.


Not in this case, PmaAbsoluteUri is the base of the phpMyadmin
installation while the parameter in $cfg['Servers'][$i]['host'] is the
host of the MySql Server
Jul 17 '05 #6
"Andy Barfield" <ab**********@yahoo.com> wrote in message
news:Ut********************@nildram.net...
Virgil Green wrote:
> Since the instance of phpMyAdmin will only run on the one server, what
difference to you expect to see when accessing it from intranet versus
internet? The path in question is the path that the server on which
phpMyAdmin is running must use to access the database. Little to do with who happens to be accessing phpMyAdmin or how.


Not in this case, PmaAbsoluteUri is the base of the phpMyadmin
installation while the parameter in $cfg['Servers'][$i]['host'] is the
host of the MySql Server


Yep, my error on the particulars. However the premise stands. The URL is to
the phpMyAdmin installation so it is still a single value no matter the
manner in which it is accessed.

- Virgil
Jul 17 '05 #7
On Tue, 20 Jul 2004 08:55:30 +0100, Andy Barfield
<ab**********@yahoo.com> wrote:
SCS wrote:
I am thrying to get phpmyadmin to work, but whenever I click a link or try
to browse a database I get a 404 error, because the PmaAbsoluteUri
auto-detection is nor working properly.
Im pretty sure it is a problem with my php.ini file, but Im not sure where
to look... can someone please help


Try the phpMyAdmin configuration file - it's called config.inc.php and
is in the root directory of your phpMyadmin installation.

It should look something like
$cfg['PmaAbsoluteUri'] = 'http://<server name>/phpmyadmin';

Or whatever the path to your installation is *through* the server.

HTH, Regards,

Andy


Try this (All on one line of course):

$cfg['PmaAbsoluteUri'] = (!empty($_SERVER['HTTPS']) ? 'https' :
'http') . '://' . $_SERVER['HTTP_HOST'] .
(!empty($_SERVER['SERVER_PORT']) ? ':' . $_SERVER['SERVER_PORT'] : '')
.. substr($_SERVER['PHP_SELF'], 0, strpos($_SERVER['PHP_SELF'],
'/')+1);

I run phpMyAdmin on three different domains, and it works flawlessly
for me. And note, in the above code, I only used single-quotes; no
double-quotes at all.
Jul 17 '05 #8

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

3 posts views Thread by mojo jojo | last post: by
reply views Thread by Gnarlodious | last post: by
3 posts views Thread by cofused | last post: by
5 posts views Thread by Marcus | last post: by
2 posts views Thread by Victor | last post: by
3 posts views Thread by Susanne | last post: by
8 posts views Thread by Jonathan Sachs | last post: by
2 posts views Thread by seanh | last post: by
1 post views Thread by CARIGAR | last post: by
1 post views Thread by Marylou17 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.