By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,743 Members | 1,018 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,743 IT Pros & Developers. It's quick & easy.

PHP5 - Installation Error - 400 Bad Request

P: n/a
Hi,

I've been eager to try out PHP5, so I've dumped it on my little dev
machine. It's running WinXP with IIS5. I've put the php-cgi.exe in the
"mappings" page as I'm used to doing with PHP4. I've got my php.ini all
set in C:\Windows.

I created an index.php containing: <?php phpinfo(); ?>
When I try to view the page, I get "HTTP 400 - Bad Request".

Can anyone out there help me? Where am I going wrong?!

- neur0maniak
Jul 17 '05 #1
Share this Question
Share on Google+
11 Replies


P: n/a
neur0maniak wrote:
Hi,

I've been eager to try out PHP5, so I've dumped it on my little dev
machine. It's running WinXP with IIS5. I've put the php-cgi.exe in the
"mappings" page as I'm used to doing with PHP4. I've got my php.ini
all set in C:\Windows.

I created an index.php containing: <?php phpinfo(); ?>
When I try to view the page, I get "HTTP 400 - Bad Request".

Can anyone out there help me? Where am I going wrong?!

- neur0maniak


Have you defined the .php extension in IIS?

--
If the Internet is a Marx Brothers movie, and Web, e-mail, and IRC are
Groucho, Chico, and Harpo, then Usenet is Zeppo.
Jul 17 '05 #2

P: n/a
Berislav Lopac wrote:
Have you defined the .php extension in IIS?


Yeah, I've done it the same way that I've used to get php4 working.

This is how I've done it: http://www.neur0maniak.co.uk/phpsetup.png
Jul 17 '05 #3

P: n/a
"neur0maniak" <us****@neur0maniak.co.uk> wrote in message
news:40***********************@ptn-nntp-reader02.plus.net...
Berislav Lopac wrote:
Have you defined the .php extension in IIS?


Yeah, I've done it the same way that I've used to get php4 working.

This is how I've done it: http://www.neur0maniak.co.uk/phpsetup.png


yep - same problem here - 4.3.8 works perfect, cannot get 5 to display
anything - XP SP1 Pro
Jul 17 '05 #4

P: n/a

News wrote:
"neur0maniak" <us****@neur0maniak.co.uk> wrote in message
news:40***********************@ptn-nntp-reader02.plus.net...
Berislav Lopac wrote:
Have you defined the .php extension in IIS?


Yeah, I've done it the same way that I've used to get php4 working.

This is how I've done it: http://www.neur0maniak.co.uk/phpsetup.png

yep - same problem here - 4.3.8 works perfect, cannot get 5 to display
anything - XP SP1 Pro


Same here ... tried IIS, KFWS, and Abyss WS. 4.3.8 works ... even with the PHP5
php.ini file settings.
Jul 17 '05 #5

P: n/a
RonS wrote:

News wrote:
"neur0maniak" <us****@neur0maniak.co.uk> wrote in message
news:40***********************@ptn-nntp-reader02.plus.net...
Berislav Lopac wrote:

Have you defined the .php extension in IIS?
Yeah, I've done it the same way that I've used to get php4 working.

This is how I've done it: http://www.neur0maniak.co.uk/phpsetup.png


yep - same problem here - 4.3.8 works perfect, cannot get 5 to display
anything - XP SP1 Pro

Same here ... tried IIS, KFWS, and Abyss WS. 4.3.8 works ... even with
the PHP5 php.ini file settings.

Forgot another oddity ... I also ran PHP5.RC2 for a while successfully.
Jul 17 '05 #6

P: n/a
> >> yep - same problem here - 4.3.8 works perfect, cannot get 5 to display
anything - XP SP1 Pro
Same here ... tried IIS, KFWS, and Abyss WS. 4.3.8 works ... even with
the PHP5 php.ini file settings.

Forgot another oddity ... I also ran PHP5.RC2 for a while successfully.


I have roughly the same problem, but the error returned is 'CGI
timeout'. Tried it on XP Pro/IIS5 and Win2K server/IIS5. 4.3.8 runs
fine. When I substitute the v5 files it stops working. I wondered if
it was a file permissions issue. But the file system is FAT on the XP
Pro machine and I've checked the NTFS machine so I don't think it is.

Chris
Jul 17 '05 #7

P: n/a
ChrisN wrote:
yep - same problem here - 4.3.8 works perfect, cannot get 5 to display
anything - XP SP1 Pro
Same here ... tried IIS, KFWS, and Abyss WS. 4.3.8 works ... even with
the PHP5 php.ini file settings.


Forgot another oddity ... I also ran PHP5.RC2 for a while successfully.

I have roughly the same problem, but the error returned is 'CGI
timeout'. Tried it on XP Pro/IIS5 and Win2K server/IIS5. 4.3.8 runs
fine. When I substitute the v5 files it stops working. I wondered if
it was a file permissions issue. But the file system is FAT on the XP
Pro machine and I've checked the NTFS machine so I don't think it is.

Chris


My file system is FAT also

y'know, it could be that which is causing the problem... (?)
Jul 17 '05 #8

P: n/a
neur0maniak wrote:
Hi,

I've been eager to try out PHP5, so I've dumped it on my little dev
machine. It's running WinXP with IIS5. I've put the php-cgi.exe in the
"mappings" page as I'm used to doing with PHP4. I've got my php.ini all
set in C:\Windows.

I created an index.php containing: <?php phpinfo(); ?>
When I try to view the page, I get "HTTP 400 - Bad Request".

Can anyone out there help me? Where am I going wrong?!

- neur0maniak


I just ran the php4.3.8 installer for windows (the 1Mb version), and set
up 4.3.8 replacing my PHP.ini

Then set up the mappings to point to PHP-CGI for php5, and all seems to
be working now. Though, I don't know why in php4, extension folder was
named "extensions" and in php5 it's called "ext".

Well, that's how I got PHP5 working...
Jul 17 '05 #9

P: n/a
neur0maniak wrote:
neur0maniak wrote:
Hi,

I've been eager to try out PHP5, so I've dumped it on my little dev
machine. It's running WinXP with IIS5. I've put the php-cgi.exe in the
"mappings" page as I'm used to doing with PHP4. I've got my php.ini
all set in C:\Windows.

I created an index.php containing: <?php phpinfo(); ?>
When I try to view the page, I get "HTTP 400 - Bad Request".

Can anyone out there help me? Where am I going wrong?!

- neur0maniak

I just ran the php4.3.8 installer for windows (the 1Mb version), and set
up 4.3.8 replacing my PHP.ini

Then set up the mappings to point to PHP-CGI for php5, and all seems to
be working now. Though, I don't know why in php4, extension folder was
named "extensions" and in php5 it's called "ext".

Well, that's how I got PHP5 working...


Can you explain this a bit more? I understand you're using the PHP.ini from PHP4
with PHP5. What directories do you have PHP4 and PHP5 in?
Jul 17 '05 #10

P: n/a
> Can you explain this a bit more? I understand you're using the PHP.ini
from PHP4 with PHP5. What directories do you have PHP4 and PHP5 in?


I have PHP5 in C:\inetpub\php5
I have PHP4 in C:\inetpub\php4

I downloaded the 1Mb installer version of PHP4, and let it set up IIS
for me with PHP4. Overwriting any and all changes it needed/wanted to.
I ran my test page and it worked fine, so 4.3.8 was installed successfully.

The only thing for me to change then was to go back into the mappings,
and map .php back to c:\inetpub\php5\php-cgi.exe, the installer had put
it pointing to c:\inetpub\php4\php.exe

I refreshed the test page and it worked and reported PHP5.
Jul 17 '05 #11

P: n/a
neur0maniak wrote:
Can you explain this a bit more? I understand you're using the PHP.ini
from PHP4 with PHP5. What directories do you have PHP4 and PHP5 in?

I have PHP5 in C:\inetpub\php5
I have PHP4 in C:\inetpub\php4

I downloaded the 1Mb installer version of PHP4, and let it set up IIS
for me with PHP4. Overwriting any and all changes it needed/wanted to.
I ran my test page and it worked fine, so 4.3.8 was installed successfully.

The only thing for me to change then was to go back into the mappings,
and map .php back to c:\inetpub\php5\php-cgi.exe, the installer had put
it pointing to c:\inetpub\php4\php.exe

I refreshed the test page and it worked and reported PHP5.


PHP5 finally working! I didn't read your response closely enough. It took me a
while to figure out that I had to use php-cgi.exe instead of php.exe as in
previous versions, which is what you said above. Thanks
Jul 17 '05 #12

This discussion thread is closed

Replies have been disabled for this discussion.