By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,650 Members | 1,823 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,650 IT Pros & Developers. It's quick & easy.

php.ini sets max time to 90 seconds, yet I get a "Max execution time of 30 seconds exceeded"

P: n/a

This is weird. When I use getId3 to try to read meta tags out of
multimedia files, I get this error:

Fatal error: Maximum execution time of 30 seconds exceeded in /home/
httpd/vhosts/bluewallmultimedia.com/httpdocs/getid3/getid3/
getid3.lib.php on line 54
But if I run phpinfo(), I get this:

max_execution_time 95 95
and if I ssh to the server and look in php.ini, this is confirmed:

max_execution_time = 95 ; Maximum execution time of each script,
in seconds
This is on a RackSpace server, running RedHat. It's got Plesk
installed.

Can anyone guess what is going on? Is there some place the settings in
php.ini can get over written or ignored?

Aug 18 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On Aug 18, 3:35 am, lawrence k <lkrub...@geocities.comwrote:
Fatal error: Maximum execution time of 30 seconds exceeded in /home/
httpd/vhosts/bluewallmultimedia.com/httpdocs/getid3/getid3/
getid3.lib.php on line 54

But if I run phpinfo(), I get this:

max_execution_time 95 95

and if I ssh to the server and look in php.ini, this is confirmed:

max_execution_time = 95 ; Maximum execution time of each script,
in seconds

This is on a RackSpace server, running RedHat. It's got Plesk
installed.

Can anyone guess what is going on? Is there some place the settings in
php.ini can get over written or ignored?

I should add that if I navigate to the directory where the code and I
do this:

grep -R ini_set *

I get nothing. As near as I can figure, ini_set is not being used to
override the php.ini settings.

Aug 18 '07 #2

P: n/a
Try looking for set_time_limit as well as ini_set. That is the only
thing that springs to mind.

On Aug 18, 3:49 am, lawrence k <lkrub...@geocities.comwrote:
On Aug 18, 3:35 am, lawrence k <lkrub...@geocities.comwrote:
Fatal error: Maximum execution time of 30 seconds exceeded in /home/
httpd/vhosts/bluewallmultimedia.com/httpdocs/getid3/getid3/
getid3.lib.php on line 54
But if I run phpinfo(), I get this:
max_execution_time 95 95
and if I ssh to the server and look in php.ini, this is confirmed:
max_execution_time = 95 ; Maximum execution time of each script,
in seconds
This is on a RackSpace server, running RedHat. It's got Plesk
installed.
Can anyone guess what is going on? Is there some place the settings in
php.ini can get over written or ignored?

I should add that if I navigate to the directory where the code and I
do this:

grep -R ini_set *

I get nothing. As near as I can figure, ini_set is not being used to
override the php.ini settings.

Aug 18 '07 #3

P: n/a
lawrence k <lk******@geocities.comwrites:
>
Fatal error: Maximum execution time of 30 seconds exceeded in /home/
httpd/vhosts/bluewallmultimedia.com/httpdocs/getid3/getid3/
getid3.lib.php on line 54
But if I run phpinfo(), I get this:

max_execution_time 95 95
and if I ssh to the server and look in php.ini, this is confirmed:

max_execution_time = 95 ; Maximum execution time of each script,
in seconds
This is on a RackSpace server, running RedHat. It's got Plesk
installed.

Can anyone guess what is going on? Is there some place the settings in
php.ini can get over written or ignored?
You may want to check your Apache config file. It is also
possible to set a CPU limit on the entire Apache process (which
would include your script execution). The Apache directive in
1.3.x is: RLimitCPU (that might be set to 30).

Best regards!
--
John
__________________________________________________ _________________
John Murtari Software Workshop Inc.
jmurtari@following domain 315.635-1968(x-211) "TheBook.Com" (TM)
http://thebook.com/
Aug 21 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.