By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,965 Members | 1,702 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,965 IT Pros & Developers. It's quick & easy.

PHP.ini and SMTP

P: n/a
Hi
it seems this has been discussed various times. Although I cannot
find a solution.
Ebvironment:
Win 2k
Apache 2
PHP 4.3.7

I use the module mode and not the cgi mode.
I cannot send email from this setup.
php.ini is in winnt
It has the following lines:
[mail function]
; For Win32 only.
SMTP = mailhost.where.am.com
smtp_port = 25

I tried this and I get:
SYSTEM WARNING: mail(): Failed to connect to mailserver at
"localhost" port 25, verify your "SMTP" and
"smtp_port" setting in php.ini or use ini_set()
PROBLEMS SENDING MAIL TO:

OK, it takes localhost.
Apache restart
No change
Log out and log in
No change
Reboot
no change

OK, now I search the entire harddisk for another php.ini.
No other php.ini found than the one in winnt
Now I run out of options.
Who can help?
Thanks
Kay
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
King Kong wrote:
(snip)
OK, now I search the entire harddisk for another php.ini.
No other php.ini found than the one in winnt
Now I run out of options.
Who can help?

Run phpinfo() and verify what path PHP is looking for the php.ini file.
That should appear in "Configuration File (php.ini) Path".

Copy your \winnt\php.ini file there; restart Apache; and test again :)
HTH

--
USENET would be a better place if everybody read: | to email me: use |
http://www.catb.org/~esr/faqs/smart-questions.html | my name in "To:" |
http://www.netmeister.org/news/learn2quote2.html | header, textonly |
http://www.expita.com/nomime.html | no attachments. |
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.