By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,965 Members | 1,702 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,965 IT Pros & Developers. It's quick & easy.

PHP code not displaying in IE 6

P: n/a
I'm a newbie to PHP and am have problems getting simple PHP page
(php_test_page.php) to display correctly. The page is:

<html>

<body>

<H1>Test Line 1</h1>

<?PHP echo '<H1>Test Line 2</h1>'; ?>

</body>

</html>

Test Line 1 displays fine by not the PHP line. If I look at the source with
the browser (IE 6), the line is still there.

I'm not sure if the following is the problem. I might have two problems
here. However, my default web server is not running and I can't seem to
start it. The following is the scenario with XP Professional:

- Click Control Panel

- Click Performance and Maintenance

- Click Administrative Tools

- Double Click Computer Management

- Open Services and Applications

- Open Internet Information Services

- Open Web Sites

- The "Default Web Site" is has a red error sign is marked as
stopped. Clicking "Default Web Site" and click "Start" yield an error dialog
with the following message. "Unexpected error 0x8ffe2740 occurred."




Jul 17 '05 #1
Share this Question
Share on Google+
13 Replies


P: n/a
Bruce A. Julseth wrote:
I'm a newbie to PHP and am have problems getting simple PHP page
(php_test_page.php) to display correctly. The page is:
. ..
Test Line 1 displays fine by not the PHP line. If I look at the source with
the browser (IE 6), the line is still there.

I'm not sure if the following is the problem. I might have two problems
here. However, my default web server is not running and I can't seem to
start it. The following is the scenario with XP Professional:

- Click Control Panel

- Click Performance and Maintenance

- Click Administrative Tools

- Double Click Computer Management

- Open Services and Applications

- Open Internet Information Services

- Open Web Sites

- The "Default Web Site" is has a red error sign is marked as
stopped. Clicking "Default Web Site" and click "Start" yield an error dialog
with the following message. "Unexpected error 0x8ffe2740 occurred."


In general, 'unexpected error' is a bad sign, sort of like a newspaper
article that starts out 'Among the injured...'. Are you in a
position to re-install XP and see whether that helps? If not, you
might try a workaround by getting and installing a copy of Apache,
unless there's some reason why you positively must use the XP default
one.

Good luck.

Margaret
--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)
Jul 17 '05 #2

P: n/a
I have Apache installed and it is started. Am I not connecting to it
correctly?

Thanks..

Bruce

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:rq********************************@4ax.com...
Bruce A. Julseth wrote:
I'm a newbie to PHP and am have problems getting simple PHP page
(php_test_page.php) to display correctly. The page is:
. ..
Test Line 1 displays fine by not the PHP line. If I look at the source withthe browser (IE 6), the line is still there.

I'm not sure if the following is the problem. I might have two problems
here. However, my default web server is not running and I can't seem to
start it. The following is the scenario with XP Professional:

- Click Control Panel

- Click Performance and Maintenance

- Click Administrative Tools

- Double Click Computer Management

- Open Services and Applications

- Open Internet Information Services

- Open Web Sites

- The "Default Web Site" is has a red error sign is marked as
stopped. Clicking "Default Web Site" and click "Start" yield an error dialogwith the following message. "Unexpected error 0x8ffe2740 occurred."


In general, 'unexpected error' is a bad sign, sort of like a newspaper
article that starts out 'Among the injured...'. Are you in a
position to re-install XP and see whether that helps? If not, you
might try a workaround by getting and installing a copy of Apache,
unless there's some reason why you positively must use the XP default
one.

Good luck.

Margaret
--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)

Jul 17 '05 #3

P: n/a
Hi Bruce
Test Line 1 displays fine by not the PHP line. If I look at the source with the browser (IE 6), the line is still there.
As you assumed, your webserver seems not to work correctly, or it doesn't
has support for PHP included. However, if it isn't running, then you
wouldn't get anything of output in your browser (that means, if you point
your browser correctly to http://...... and not to file:///....)
- The "Default Web Site" is has a red error sign is marked as
stopped. Clicking "Default Web Site" and click "Start" yield an error dialog with the following message. "Unexpected error 0x8ffe2740 occurred."


Btw, there is a nice package, 'xamp', which includes apache, mysql, php,
phpmyadmin, etc. Easy-to-install, works on windows, nice for beginners...:
http://www.apachefriends.org/en/. Perhaps you may try this one, if your
current webserver won't start.

Greetings, Greg
Jul 17 '05 #4

P: n/a
Okay. Please tell me if I have discovered my problem. I entered:

http://localhost/Serenade/php_test_page.php

and now all is good.

Both lines appear and no PHP code appears in the when I look at the source
with the browser.

Is this what I needed to do?

Thank you..

Bruce
"Bruce A. Julseth" <br*****@attglobal.net> wrote in message
news:40********@news1.prserv.net...
I have Apache installed and it is started. Am I not connecting to it
correctly?

Thanks..

Bruce

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:rq********************************@4ax.com...
Bruce A. Julseth wrote:
I'm a newbie to PHP and am have problems getting simple PHP page
(php_test_page.php) to display correctly. The page is:
. ..
Test Line 1 displays fine by not the PHP line. If I look at the source withthe browser (IE 6), the line is still there.

I'm not sure if the following is the problem. I might have two problems
here. However, my default web server is not running and I can't seem to
start it. The following is the scenario with XP Professional:

- Click Control Panel

- Click Performance and Maintenance

- Click Administrative Tools

- Double Click Computer Management

- Open Services and Applications

- Open Internet Information Services

- Open Web Sites

- The "Default Web Site" is has a red error sign is marked as
stopped. Clicking "Default Web Site" and click "Start" yield an error dialogwith the following message. "Unexpected error 0x8ffe2740 occurred."


In general, 'unexpected error' is a bad sign, sort of like a newspaper
article that starts out 'Among the injured...'. Are you in a
position to re-install XP and see whether that helps? If not, you
might try a workaround by getting and installing a copy of Apache,
unless there's some reason why you positively must use the XP default
one.

Good luck.

Margaret
--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)


Jul 17 '05 #5

P: n/a
Bruce A. Julseth wrote:
I have Apache installed and it is started. Am I not connecting to it
correctly?
Sorry, I got confused--I didn't realise you're using Apache.

Can you serve a straight html page? e.g.
http://localhost/somepage.html ?

If you can, then the server is working correctly. Test it, if
possible, using (e.g.) Mozilla as well as IE6, though.

Then try serving some html page that does not exist, so that you get a
404 error and can see what server is lodging the complaint. You want
to make sure that it's really Apache doing the serving!

The next thing to test is whether you have php installed correctly.
If you call a testpage with this content:

<?php
phpinfo() ;
?>

do you get output?

If you don't, walk through the installation instructions again, making
sure Apache's config file knows about php and that you've copied the
correct dlls to the correct locations. Make sure php.ini is in the
windows system32 directory. Do the walkthrough line-by-line fairly
obsessively, because there are a lot of fiddly bits. Whether or not
you make changes, restart Apache just for fun (it's that little
feather icon in the system tray, very nice). Try the phpinfo() test
program again.

Let us know how it comes out.

Margaret

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:rq********************************@4ax.com.. .
Bruce A. Julseth wrote:
>I'm a newbie to PHP and am have problems getting simple PHP page
>(php_test_page.php) to display correctly. The page is:
>. ..
>Test Line 1 displays fine by not the PHP line. If I look at the sourcewith >the browser (IE 6), the line is still there.
>
>
>
>I'm not sure if the following is the problem. I might have two problems
>here. However, my default web server is not running and I can't seem to
>start it. The following is the scenario with XP Professional:
>
>
>
>- Click Control Panel
>
>- Click Performance and Maintenance
>
>- Click Administrative Tools
>
>- Double Click Computer Management
>
>- Open Services and Applications
>
>- Open Internet Information Services
>
>- Open Web Sites
>
>- The "Default Web Site" is has a red error sign is marked as
>stopped. Clicking "Default Web Site" and click "Start" yield an errordialog >with the following message. "Unexpected error 0x8ffe2740 occurred."


In general, 'unexpected error' is a bad sign, sort of like a newspaper
article that starts out 'Among the injured...'. Are you in a
position to re-install XP and see whether that helps? If not, you
might try a workaround by getting and installing a copy of Apache,
unless there's some reason why you positively must use the XP default
one.

Good luck.

Margaret
--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)

--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)
Jul 17 '05 #6

P: n/a
I have a feeling we're going to get out of sync here. :-(

What does Apache think your docroot is? docroot is the apparent root
of all pages to be served. So if docroot is X:/foo/bar then to serve
the file that the filesystem knows as X:\foo\bar\test.html, you'd
type localhost/test.html because Apache doesn't serve anything from
any location other than the subtrees below x:\foo\bar
Bruce A. Julseth wrote:
Okay. Please tell me if I have discovered my problem. I entered:

http://localhost/Serenade/php_test_page.php

and now all is good.

Both lines appear and no PHP code appears in the when I look at the source
with the browser.

Is this what I needed to do?

Thank you..

Bruce
"Bruce A. Julseth" <br*****@attglobal.net> wrote in message
news:40********@news1.prserv.net...
I have Apache installed and it is started. Am I not connecting to it
correctly?

Thanks..

Bruce

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:rq********************************@4ax.com...
> Bruce A. Julseth wrote:
>
> >I'm a newbie to PHP and am have problems getting simple PHP page
> >(php_test_page.php) to display correctly. The page is:
> >. ..
> >Test Line 1 displays fine by not the PHP line. If I look at the source

with
> >the browser (IE 6), the line is still there.
> >
> >
> >
> >I'm not sure if the following is the problem. I might have two problems
> >here. However, my default web server is not running and I can't seem to
> >start it. The following is the scenario with XP Professional:
> >
> >
> >
> >- Click Control Panel
> >
> >- Click Performance and Maintenance
> >
> >- Click Administrative Tools
> >
> >- Double Click Computer Management
> >
> >- Open Services and Applications
> >
> >- Open Internet Information Services
> >
> >- Open Web Sites
> >
> >- The "Default Web Site" is has a red error sign is marked as
> >stopped. Clicking "Default Web Site" and click "Start" yield an error

dialog
> >with the following message. "Unexpected error 0x8ffe2740 occurred."
>
> In general, 'unexpected error' is a bad sign, sort of like a newspaper
> article that starts out 'Among the injured...'. Are you in a
> position to re-install XP and see whether that helps? If not, you
> might try a workaround by getting and installing a copy of Apache,
> unless there's some reason why you positively must use the XP default
> one.
>
> Good luck.
>
> Margaret
> --
> (To mail me, please change .not.invalid to .net, first.
> Apologies for the inconvenience.)



--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)
Jul 17 '05 #7

P: n/a
Sorry I didn't mention I had Apache.

Here are the test results.

- http://localhost/ returns Apache's default page
- Running a pure HTML page: Displays okay
- Running a nonexistent page returns a 404 error with "Internet Explorer"
under the error number.
- Running PHP Info displaces a formated listing of the config file.

Does this mean that Apache is running correctly?

I want to upgrade to PHP 4.3.7. Did the configuration file change between
4.3.2 and 4.3.7?

Thanks for the help..

Bruce
"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:95********************************@4ax.com...
Bruce A. Julseth wrote:
I have Apache installed and it is started. Am I not connecting to it
correctly?


Sorry, I got confused--I didn't realise you're using Apache.

Can you serve a straight html page? e.g.
http://localhost/somepage.html ?

If you can, then the server is working correctly. Test it, if
possible, using (e.g.) Mozilla as well as IE6, though.

Then try serving some html page that does not exist, so that you get a
404 error and can see what server is lodging the complaint. You want
to make sure that it's really Apache doing the serving!

The next thing to test is whether you have php installed correctly.
If you call a testpage with this content:

<?php
phpinfo() ;
?>

do you get output?

If you don't, walk through the installation instructions again, making
sure Apache's config file knows about php and that you've copied the
correct dlls to the correct locations. Make sure php.ini is in the
windows system32 directory. Do the walkthrough line-by-line fairly
obsessively, because there are a lot of fiddly bits. Whether or not
you make changes, restart Apache just for fun (it's that little
feather icon in the system tray, very nice). Try the phpinfo() test
program again.

Let us know how it comes out.

Margaret

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:rq********************************@4ax.com.. .
Bruce A. Julseth wrote:

>I'm a newbie to PHP and am have problems getting simple PHP page
>(php_test_page.php) to display correctly. The page is:
>. ..
>Test Line 1 displays fine by not the PHP line. If I look at the source

with
>the browser (IE 6), the line is still there.
>
>
>
>I'm not sure if the following is the problem. I might have two problems >here. However, my default web server is not running and I can't seem to >start it. The following is the scenario with XP Professional:
>
>
>
>- Click Control Panel
>
>- Click Performance and Maintenance
>
>- Click Administrative Tools
>
>- Double Click Computer Management
>
>- Open Services and Applications
>
>- Open Internet Information Services
>
>- Open Web Sites
>
>- The "Default Web Site" is has a red error sign is marked as
>stopped. Clicking "Default Web Site" and click "Start" yield an error

dialog
>with the following message. "Unexpected error 0x8ffe2740 occurred."

In general, 'unexpected error' is a bad sign, sort of like a newspaper
article that starts out 'Among the injured...'. Are you in a
position to re-install XP and see whether that helps? If not, you
might try a workaround by getting and installing a copy of Apache,
unless there's some reason why you positively must use the XP default
one.

Good luck.

Margaret
--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)

--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)

Jul 17 '05 #8

P: n/a
docroot is c:\inetpub\wwwroot

Serenade is an alias in Apache's conf file for a directory under the docroot
in the example below:

http://localhost/Serenade/php_test_page.php

which is the php page I was having problems with initially.

Thank you.

Bruce

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:66********************************@4ax.com...
I have a feeling we're going to get out of sync here. :-(

What does Apache think your docroot is? docroot is the apparent root
of all pages to be served. So if docroot is X:/foo/bar then to serve
the file that the filesystem knows as X:\foo\bar\test.html, you'd
type localhost/test.html because Apache doesn't serve anything from
any location other than the subtrees below x:\foo\bar
Bruce A. Julseth wrote:
Okay. Please tell me if I have discovered my problem. I entered:

http://localhost/Serenade/php_test_page.php

and now all is good.

Both lines appear and no PHP code appears in the when I look at the sourcewith the browser.

Is this what I needed to do?

Thank you..

Bruce
"Bruce A. Julseth" <br*****@attglobal.net> wrote in message
news:40********@news1.prserv.net...
I have Apache installed and it is started. Am I not connecting to it
correctly?

Thanks..

Bruce

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:rq********************************@4ax.com...
> Bruce A. Julseth wrote:
>
> >I'm a newbie to PHP and am have problems getting simple PHP page
> >(php_test_page.php) to display correctly. The page is:
> >. ..
> >Test Line 1 displays fine by not the PHP line. If I look at the source with
> >the browser (IE 6), the line is still there.
> >
> >
> >
> >I'm not sure if the following is the problem. I might have two problems > >here. However, my default web server is not running and I can't seem to > >start it. The following is the scenario with XP Professional:
> >
> >
> >
> >- Click Control Panel
> >
> >- Click Performance and Maintenance
> >
> >- Click Administrative Tools
> >
> >- Double Click Computer Management
> >
> >- Open Services and Applications
> >
> >- Open Internet Information Services
> >
> >- Open Web Sites
> >
> >- The "Default Web Site" is has a red error sign is marked as > >stopped. Clicking "Default Web Site" and click "Start" yield an error dialog
> >with the following message. "Unexpected error 0x8ffe2740 occurred."
>
> In general, 'unexpected error' is a bad sign, sort of like a newspaper > article that starts out 'Among the injured...'. Are you in a
> position to re-install XP and see whether that helps? If not, you
> might try a workaround by getting and installing a copy of Apache,
> unless there's some reason why you positively must use the XP default
> one.
>
> Good luck.
>
> Margaret
> --
> (To mail me, please change .not.invalid to .net, first.
> Apologies for the inconvenience.)


--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)

Jul 17 '05 #9

P: n/a
In message <40********@news1.prserv.net>, Bruce A. Julseth
<br*****@attglobal.net> writes
Sorry I didn't mention I had Apache.

Here are the test results.

- http://localhost/ returns Apache's default page
- Running a pure HTML page: Displays okay
- Running a nonexistent page returns a 404 error with "Internet Explorer"
under the error number.
- Running PHP Info displaces a formated listing of the config file.

Does this mean that Apache is running correctly?
Sounds like both are OK.

I want to upgrade to PHP 4.3.7. Did the configuration file change between
4.3.2 and 4.3.7?
If it ain't broke....

Thanks for the help..

Bruce
"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:95********************************@4ax.com.. .
Bruce A. Julseth wrote:
>I have Apache installed and it is started. Am I not connecting to it
>correctly?


Sorry, I got confused--I didn't realise you're using Apache.

Can you serve a straight html page? e.g.
http://localhost/somepage.html ?

If you can, then the server is working correctly. Test it, if
possible, using (e.g.) Mozilla as well as IE6, though.

Then try serving some html page that does not exist, so that you get a
404 error and can see what server is lodging the complaint. You want
to make sure that it's really Apache doing the serving!

The next thing to test is whether you have php installed correctly.
If you call a testpage with this content:

<?php
phpinfo() ;
?>

do you get output?

If you don't, walk through the installation instructions again, making
sure Apache's config file knows about php and that you've copied the
correct dlls to the correct locations. Make sure php.ini is in the
windows system32 directory. Do the walkthrough line-by-line fairly
obsessively, because there are a lot of fiddly bits. Whether or not
you make changes, restart Apache just for fun (it's that little
feather icon in the system tray, very nice). Try the phpinfo() test
program again.

Let us know how it comes out.

Margaret
>
>"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
>news:rq********************************@4ax.com.. .
>> Bruce A. Julseth wrote:
>>
>> >I'm a newbie to PHP and am have problems getting simple PHP page
>> >(php_test_page.php) to display correctly. The page is:
>> >. ..
>> >Test Line 1 displays fine by not the PHP line. If I look at the source
>with
>> >the browser (IE 6), the line is still there.
>> >
>> >
>> >
>> >I'm not sure if the following is the problem. I might have twoproblems >> >here. However, my default web server is not running and I can't seemto >> >start it. The following is the scenario with XP Professional:
>> >
>> >
>> >
>> >- Click Control Panel
>> >
>> >- Click Performance and Maintenance
>> >
>> >- Click Administrative Tools
>> >
>> >- Double Click Computer Management
>> >
>> >- Open Services and Applications
>> >
>> >- Open Internet Information Services
>> >
>> >- Open Web Sites
>> >
>> >- The "Default Web Site" is has a red error sign is marked as
>> >stopped. Clicking "Default Web Site" and click "Start" yield an error
>dialog
>> >with the following message. "Unexpected error 0x8ffe2740 occurred."
>>
>> In general, 'unexpected error' is a bad sign, sort of like a newspaper
>> article that starts out 'Among the injured...'. Are you in a
>> position to re-install XP and see whether that helps? If not, you
>> might try a workaround by getting and installing a copy of Apache,
>> unless there's some reason why you positively must use the XP default
>> one.
>>
>> Good luck.
>>
>> Margaret
>> --
>> (To mail me, please change .not.invalid to .net, first.
>> Apologies for the inconvenience.)
>

--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)



--
Five Cats
Email to: cats_spam at uk2 dot net
Jul 17 '05 #10

P: n/a
Bruce A. Julseth wrote:

- Running PHP Info displaces a formated listing of the config file.
What do you mean by this? Do you get nicely formatted blue and grey
tables showing all php's config settings when you call phpinfo() ?
That's what you should be getting, so if you are getting that you're
in great shape and can go forward with confidence.

I'd suggest, though, that if all your files are going to be under
'sycamore' (or whatever that was...I can't remember it), that you
consider including that in docroot so that you only need call
hostname/pagename.php to get at the main pages.

Does this mean that Apache is running correctly?

I want to upgrade to PHP 4.3.7. Did the configuration file change between
4.3.2 and 4.3.7?
I don't think anything's changed. I thought I was running the Latest
& Greatest, but maybe that's only on my laptop. Phpinfo() on my dev
machine claims to be v4.3.0. I know I've upgraded at least twice, but
the config file didn't change, so in your place I'd presume no changes
unless it complains. If there's a problem, it'll complain--it's very
good about that.

If you want to be completely sure, go to www.php.net and grub around
for the relevant release notes--they'll tell you if there've been any
significant changes.

As Cats says, it looks as tho you're all set.

Best luck!
Margaret


Thanks for the help..

Bruce
"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:95********************************@4ax.com.. .
Bruce A. Julseth wrote:
>I have Apache installed and it is started. Am I not connecting to it
>correctly?


Sorry, I got confused--I didn't realise you're using Apache.

Can you serve a straight html page? e.g.
http://localhost/somepage.html ?

If you can, then the server is working correctly. Test it, if
possible, using (e.g.) Mozilla as well as IE6, though.

Then try serving some html page that does not exist, so that you get a
404 error and can see what server is lodging the complaint. You want
to make sure that it's really Apache doing the serving!

The next thing to test is whether you have php installed correctly.
If you call a testpage with this content:

<?php
phpinfo() ;
?>

do you get output?

If you don't, walk through the installation instructions again, making
sure Apache's config file knows about php and that you've copied the
correct dlls to the correct locations. Make sure php.ini is in the
windows system32 directory. Do the walkthrough line-by-line fairly
obsessively, because there are a lot of fiddly bits. Whether or not
you make changes, restart Apache just for fun (it's that little
feather icon in the system tray, very nice). Try the phpinfo() test
program again.

Let us know how it comes out.

Margaret
>
>"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
>news:rq********************************@4ax.com.. .
>> Bruce A. Julseth wrote:
>>
>> >I'm a newbie to PHP and am have problems getting simple PHP page
>> >(php_test_page.php) to display correctly. The page is:
>> >. ..
>> >Test Line 1 displays fine by not the PHP line. If I look at the source
>with
>> >the browser (IE 6), the line is still there.
>> >
>> >
>> >
>> >I'm not sure if the following is the problem. I might have twoproblems >> >here. However, my default web server is not running and I can't seemto >> >start it. The following is the scenario with XP Professional:
>> >
>> >
>> >
>> >- Click Control Panel
>> >
>> >- Click Performance and Maintenance
>> >
>> >- Click Administrative Tools
>> >
>> >- Double Click Computer Management
>> >
>> >- Open Services and Applications
>> >
>> >- Open Internet Information Services
>> >
>> >- Open Web Sites
>> >
>> >- The "Default Web Site" is has a red error sign is marked as
>> >stopped. Clicking "Default Web Site" and click "Start" yield an error
>dialog
>> >with the following message. "Unexpected error 0x8ffe2740 occurred."
>>
>> In general, 'unexpected error' is a bad sign, sort of like a newspaper
>> article that starts out 'Among the injured...'. Are you in a
>> position to re-install XP and see whether that helps? If not, you
>> might try a workaround by getting and installing a copy of Apache,
>> unless there's some reason why you positively must use the XP default
>> one.
>>
>> Good luck.
>>
>> Margaret
>> --
>> (To mail me, please change .not.invalid to .net, first.
>> Apologies for the inconvenience.)
>

--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)


--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)
Jul 17 '05 #11

P: n/a
Yes, I get the nice formatted listing.

I went through my php.ini and the php.ini_dist in 4.3.7. There were a couple
of changes that I don't think will effect me.

What I can find is where I "point" to 4.3.7.. When I run phpinfo.php, I
still get 4.3.2 as my release. Somewhere there must be an .ini that sets
this up.. Can you point me to this .ini file?

Thanks.

Bruce

"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:qo********************************@4ax.com...
Bruce A. Julseth wrote:

- Running PHP Info displaces a formated listing of the config file.


What do you mean by this? Do you get nicely formatted blue and grey
tables showing all php's config settings when you call phpinfo() ?
That's what you should be getting, so if you are getting that you're
in great shape and can go forward with confidence.

I'd suggest, though, that if all your files are going to be under
'sycamore' (or whatever that was...I can't remember it), that you
consider including that in docroot so that you only need calldi
hostname/pagename.php to get at the main pages.

Does this mean that Apache is running correctly?

I want to upgrade to PHP 4.3.7. Did the configuration file change between
4.3.2 and 4.3.7?


I don't think anything's changed. I thought I was running the Latest
& Greatest, but maybe that's only on my laptop. Phpinfo() on my dev
machine claims to be v4.3.0. I know I've upgraded at least twice, but
the config file didn't change, so in your place I'd presume no changes
unless it complains. If there's a problem, it'll complain--it's very
good about that.

If you want to be completely sure, go to www.php.net and grub around
for the relevant release notes--they'll tell you if there've been any
significant changes.

As Cats says, it looks as tho you're all set.

Best luck!
Margaret


Thanks for the help..

Bruce
"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
news:95********************************@4ax.com.. .
Bruce A. Julseth wrote:

>I have Apache installed and it is started. Am I not connecting to it
>correctly?

Sorry, I got confused--I didn't realise you're using Apache.

Can you serve a straight html page? e.g.
http://localhost/somepage.html ?

If you can, then the server is working correctly. Test it, if
possible, using (e.g.) Mozilla as well as IE6, though.

Then try serving some html page that does not exist, so that you get a
404 error and can see what server is lodging the complaint. You want
to make sure that it's really Apache doing the serving!

The next thing to test is whether you have php installed correctly.
If you call a testpage with this content:

<?php
phpinfo() ;
?>

do you get output?

If you don't, walk through the installation instructions again, making
sure Apache's config file knows about php and that you've copied the
correct dlls to the correct locations. Make sure php.ini is in the
windows system32 directory. Do the walkthrough line-by-line fairly
obsessively, because there are a lot of fiddly bits. Whether or not
you make changes, restart Apache just for fun (it's that little
feather icon in the system tray, very nice). Try the phpinfo() test
program again.

Let us know how it comes out.

Margaret

>
>"Margaret MacDonald" <sc**********@att.not.invalid> wrote in message
>news:rq********************************@4ax.com.. .
>> Bruce A. Julseth wrote:
>>
>> >I'm a newbie to PHP and am have problems getting simple PHP page
>> >(php_test_page.php) to display correctly. The page is:
>> >. ..
>> >Test Line 1 displays fine by not the PHP line. If I look at the source >with
>> >the browser (IE 6), the line is still there.
>> >
>> >
>> >
>> >I'm not sure if the following is the problem. I might have two

problems
>> >here. However, my default web server is not running and I can't seem
to
>> >start it. The following is the scenario with XP Professional:
>> >
>> >
>> >
>> >- Click Control Panel
>> >
>> >- Click Performance and Maintenance
>> >
>> >- Click Administrative Tools
>> >
>> >- Double Click Computer Management
>> >
>> >- Open Services and Applications
>> >
>> >- Open Internet Information Services
>> >
>> >- Open Web Sites
>> >
>> >- The "Default Web Site" is has a red error sign is marked

as >> >stopped. Clicking "Default Web Site" and click "Start" yield an error >dialog
>> >with the following message. "Unexpected error 0x8ffe2740 occurred."
>>
>> In general, 'unexpected error' is a bad sign, sort of like a newspaper >> article that starts out 'Among the injured...'. Are you in a
>> position to re-install XP and see whether that helps? If not, you
>> might try a workaround by getting and installing a copy of Apache,
>> unless there's some reason why you positively must use the XP default >> one.
>>
>> Good luck.
>>
>> Margaret
>> --
>> (To mail me, please change .not.invalid to .net, first.
>> Apologies for the inconvenience.)
>
--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)


--
(To mail me, please change .not.invalid to .net, first.
Apologies for the inconvenience.)

Jul 17 '05 #12

P: n/a
In message <40********@news1.prserv.net>, Bruce A. Julseth
<br*****@attglobal.net> writes
Yes, I get the nice formatted listing.

I went through my php.ini and the php.ini_dist in 4.3.7. There were a couple
of changes that I don't think will effect me.

What I can find is where I "point" to 4.3.7.. When I run phpinfo.php, I
still get 4.3.2 as my release. Somewhere there must be an .ini that sets
this up.. Can you point me to this .ini file?


There are two ways of getting Apache to invoke PHP (at least for Apache
2.0). You don't say which one you have done, but some copying around of
files can be involved. Maybe this is where the problem is - either that
or you have two versions of PHP installed and the Apache configuration
is picking up the earlier version. I think you need to spend a little
while checking the Apache documentation on this. The following is a
good starting place:

http://www.php.net/manual/en/install.windows.php
<snip>

--
Five Cats
Email to: cats_spam at uk2 dot net
Jul 17 '05 #13

P: n/a
On Fri, 25 Jun 2004 23:37:11 -0400, Bruce A. Julseth wrote:
Yes, I get the nice formatted listing.

I went through my php.ini and the php.ini_dist in 4.3.7. There were a
couple of changes that I don't think will effect me.

What I can find is where I "point" to 4.3.7.. When I run phpinfo.php, I
still get 4.3.2 as my release. Somewhere there must be an .ini that sets
this up.. Can you point me to this .ini file?

Thanks.

Bruce


After upgrading PHP, you _have_ to restart Apache. Also, you should clear
your browser's cache to make sure you get the current version of the page.

HTH,
La'ie Techie
Jul 17 '05 #14

This discussion thread is closed

Replies have been disabled for this discussion.