By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,722 Members | 1,904 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,722 IT Pros & Developers. It's quick & easy.

Apache/ Win XP Home/ PHP5/ MySQL

P: n/a
OK, I can get PHP5 running on Apache 2 installed on Windows XP Home
Edition. Now I want to add MySQL4 to the package. I installed it but
I'm not sure what to do now. My PHP5 scripts are running fine.
The MySQL server seems to be running though actually I'm not sure. When
I write
$link = mysql_connect("localhost", "mysql");
I get the PHP5 error message
"Call to undefined function mysql_connect()"

Can anyone help? (Or should I be using SQLite?)

--
Google Blogoscoped
http://blog.outer-court.com
Jul 17 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
You have to enable the extension mysql.dll in php.ini.
note : On php5, mysql extension is not loaded by default.

Savut

"Philipp Lenssen" <in**@outer-court.com> wrote in message
news:2j*************@uni-berlin.de...
OK, I can get PHP5 running on Apache 2 installed on Windows XP Home
Edition. Now I want to add MySQL4 to the package. I installed it but
I'm not sure what to do now. My PHP5 scripts are running fine.
The MySQL server seems to be running though actually I'm not sure. When
I write
$link = mysql_connect("localhost", "mysql");
I get the PHP5 error message
"Call to undefined function mysql_connect()"

Can anyone help? (Or should I be using SQLite?)

--
Google Blogoscoped
http://blog.outer-court.com


Jul 17 '05 #2

P: n/a
Savut wrote:
You have to enable the extension mysql.dll in php.ini.
note : On php5, mysql extension is not loaded by default.


Thanks. However even after adding the extension and restarting Apache
it cannot be found...?

--
Google Blogoscoped
http://blog.outer-court.com
Jul 17 '05 #3

P: n/a
On 24 Jun 2004 14:24:40 GMT, "Philipp Lenssen" <in**@outer-court.com> wrote:
Savut wrote:
You have to enable the extension mysql.dll in php.ini.
note : On php5, mysql extension is not loaded by default.


Thanks. However even after adding the extension and restarting Apache
it cannot be found...?


Create a script containing <?php phpinfo(); ?> and search the output for
'mysql'. It probably isn't actually loaded.

--
Andy Hassall <an**@andyh.co.uk> / Space: disk usage analysis tool
http://www.andyh.co.uk / http://www.andyhsoftware.co.uk/space
Jul 17 '05 #4

P: n/a
"Savut" <we***@hotmail.com> wrote in message
news:jY********************@news20.bellglobal.com. ..
You have to enable the extension mysql.dll in php.ini.
note : On php5, mysql extension is not loaded by default.

Savut


Just wondering, should one use the new mysqli extension instead in PHP 5?
Jul 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.