By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,521 Members | 1,447 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,521 IT Pros & Developers. It's quick & easy.

Apache 2.0.49 and PHP 4.3.7

P: n/a
Hello,

I posted this message earlier, but nobody replied, so I'm thinking my
news-server did not transfer it to other servers.

I installed PHP 4.3.7 from source (and Apache 2.0.49):
../configure --prefix=/usr/local --sysconfdir=/etc --with-mysql
--with-apxs2=/usr/local/apache2/bin/apxs --enable-dbase
make
make install

I added

AddType application/x-httpd-php .php
AddHandler server-parsed .php

to the httpd.conf file, and yet every time I try to load a PHP page my
browser wants to download it instead of parsing it.

If I copy an old libphp4.so file (version 4.2.3 which was compiled with
exactly the same commands) it DOES work...

Now it works, but this is no solution for me...
It's already the second time I have this problem (now it's 4.3.7 on Mandrake
10.0 Official, last time it was 4.3.6 on Mandrake 9.2)
Does anybody have any idea????

thx

Nico Declerck

--
Nico Declerck - netwerkbeheerder
UZGent - Dienst voor Inwendige Ziekten - afdeling Pneumologie
ni*************************@ugent.be - 09/2402626
Jul 17 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.