By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
431,805 Members | 1,273 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 431,805 IT Pros & Developers. It's quick & easy.

PHP .msi installer nightmare

P: n/a
I recently reinstalled php 5.2.2 on vista using the .msi installer.

In the "Choose Items to Install" dialog shown by the installer, I
foolishly enabled:
PHP->Program->Script Executable->Register *.php files to
automatically open with PHP.

Now every time I type a URL that ends with .php in Firefox or IE, the
browser pops up a "Save or Run" dialog box instead rendering the
output in the browser window.

I've removed and reinstalled PHP several times, to no avail. Does
anybody know how to undo "Register *.php files to automatically open
with PHP"?

spyke

May 31 '07 #1
Share this Question
Share on Google+
3 Replies


P: n/a
On 31 Mai, 09:01, gnu...@yahoo.com wrote:
I recently reinstalled php 5.2.2 on vista using the .msi installer.
i do not use vista, but it should be similar to xp.
I've removed and reinstalled PHP several times, to no avail. Does
anybody know how to undo "Register *.php files to automatically open
with PHP"?
open the registry editor (regedit on xp). jump to HKEY_CLASSES_ROOT-
>php (and maybe pgp3. php4 and phtml also). you have to change the
data-key, it must be "ZDE.file". f. e.:

HKEY_CLASSES_ROOT->php: Name=Default; Type=REG_SZ; Data=ZDE.file

you need administrator priviledges to do this (and i'm sure, on vista
you have to submit a dozen alerts at least :-) ). maybe you have to
restart the system to make this changes work.

if you don't know anything about registry settings, do not change the
registry!!! if you do something wrong, in worst case you'll need to
reinstall windows!!!
>
spyke
regards
May 31 '07 #2

P: n/a
gn****@yahoo.com wrote:
I recently reinstalled php 5.2.2 on vista using the .msi installer.

In the "Choose Items to Install" dialog shown by the installer, I
foolishly enabled:
PHP->Program->Script Executable->Register *.php files to
automatically open with PHP.

Now every time I type a URL that ends with .php in Firefox or IE, the
browser pops up a "Save or Run" dialog box instead rendering the
output in the browser window.

I've removed and reinstalled PHP several times, to no avail. Does
anybody know how to undo "Register *.php files to automatically open
with PHP"?

spyke
Less dangerous than editing the registry directly, from a command prompt
type:

assoc .php=

(just press enter after the = sign). This removes the association with
..php files.

--
==================
Remove the "x" from my email address
Jerry Stuckle
JDS Computer Training Corp.
js*******@attglobal.net
==================
May 31 '07 #3

P: n/a
Thanks a bunch!

I simply deleted the registry key HKEY_CLASSES_ROOT->php_autofile
subtree and php works as expected in firefox.

On May 31, 12:43 am, Lammi <Lorenz.Lammersd...@gmail.comwrote:
On 31 Mai, 09:01, gnu...@yahoo.com wrote:
I recently reinstalled php 5.2.2 on vista using the .msi installer.

i do not use vista, but it should be similar to xp.
I've removed and reinstalled PHP several times, to no avail. Does
anybody know how to undo "Register *.php files to automatically open
with PHP"?

open the registry editor (regedit on xp). jump to HKEY_CLASSES_ROOT->php (and maybe pgp3. php4 and phtml also). you have to change the

data-key, it must be "ZDE.file". f. e.:

HKEY_CLASSES_ROOT->php: Name=Default; Type=REG_SZ; Data=ZDE.file

you need administrator priviledges to do this (and i'm sure, on vista
you have to submit a dozen alerts at least :-) ). maybe you have to
restart the system to make this changes work.

if you don't know anything about registry settings, do not change the
registry!!! if you do something wrong, in worst case you'll need to
reinstall windows!!!
spyke

regards

Jun 1 '07 #4

This discussion thread is closed

Replies have been disabled for this discussion.