By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
424,986 Members | 2,086 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 424,986 IT Pros & Developers. It's quick & easy.

php webservice extensions on IIS, IIS returns 404 on php

P: n/a
Hi,
I'm trying to get the PHP isapi filter to work on IIS.

as per the manual http://php.net/manual/en/install.windows.iis.php
I have done the following:
"# If you don't want to perform HTTP Authentication using PHP, you
can (and should) skip this step. Under ISAPI Filters, add a new ISAPI
filter. Use PHP as the filter name, and supply a path to the
php4isapi.dll / php5isapi.dll.
# Under 'Home Directory', 'Virtual Directory', or 'Directory', do the
following:
# Change the Execute Permissions to 'Scripts only' "

and then
"Click on the 'Configuration' button, and choose the Application
Mappings tab. Click Add and set the Executable path to the appropriate
ISAPI DLL. An example PHP 5 value is: C:\php\php5isapi.dll
Supply .php as the extension. Leave 'Method exclusions' blank, and
check the 'Script engine' checkbox. Now, click OK a few times."

That seems to already be done.

"# Stop IIS completely (NET STOP iisadmin)
# Start IIS again (NET START w3svc) "

have done so several times by now

"With IIS 6 (2003 Server), open up the IIS Manager, go to Web Service
Extensions, choose "Add a new Web service extension", enter in a name
such as PHP, choose the Add button and for the value browse to either
the ISAPI file (php4isapi.dll or php5isapi.dll) or CGI (php.exe or php-
cgi.exe) then check "Set extension status to Allowed" and click OK."

since I have IIS 6 this is probably what I want to do, I guess, but
when I do this it comes with a tooltip over my path to the dll that
says:

This file is already required by PHP: Hypertext Processor.

so what should I do to get around the Windows IIS return 404 on php
files?

Thanks,
Bryan

May 18 '07 #1
Share this Question
Share on Google+
1 Reply


P: n/a
On May 18, 11:47 am, pantagruel <rasmussen.br...@gmail.comwrote:
Hi,
I'm trying to get the PHP isapi filter to work on IIS.

so what should I do to get around the Windows IIS return 404 on php
files?

Thanks,
Bryan
I don't think the ISAPI filter works unless you have IIS set up (try
Web.config) to handle PHP files through the filter. Set it up as you
would set up any ASP.net filter.

-Mike PII

May 24 '07 #2

This discussion thread is closed

Replies have been disabled for this discussion.