By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
437,890 Members | 1,050 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 437,890 IT Pros & Developers. It's quick & easy.

xampp installation

P: n/a
Hi,

I installed basic xampp with the installer from
http://www.apachefriends.org/en/xampp-windows.html#524.

When I started Apache from the panel, I got a window with the error
message:
This application has failed to start because php_mbstring.dll was
not found. Re-installing ...

I tried to re-install but it did not help.

I found in the web references to this problem but everything that they
suggest is already correct at my php.ini: definition of extension_dir
and php_exif.dll appears after mbstring.

In the control-panel - the status of Apache is running and the start
button was replaced by a stop button.

Apache and PHP are new for me.

Thanks,
David

May 3 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
On May 3, 5:17 pm, DavidNorep <avdavid.nore...@gmail.comwrote:
Hi,

I installed basic xampp with the installer fromhttp://www.apachefriends.org/en/xampp-windows.html#524.

When I started Apache from the panel, I got a window with the error
message:
This application has failed to start because php_mbstring.dll was
not found. Re-installing ...

I tried to re-install but it did not help.

I found in the web references to this problem but everything that they
suggest is already correct at my php.ini: definition of extension_dir
and php_exif.dll appears after mbstring.

In the control-panel - the status of Apache is running and the start
button was replaced by a stop button.

Apache and PHP are new for me.

Thanks,
David
did you install apache as a service? filzilla/mysql all should be
services unless you have a need for them not to be.
if they are use services.msc to check on the status of apache mysql
and filezilla, ignore the control panel, in my experience - which isnt
much, is that it lies. if the application failed to start, then it
failed to start no matter what some gui says.
are you editing the right php.ini file? that in apache/bin directory,
have you added any lines to xampp from a website, or is it default -
are you running php as a module. If you did add lines did you add the
reference to the wrong module, if you are running apache 2.2.x are you
using the php for apache2.2.x dll?
did you check that php_mbstring.dll actually does exist? If you can
download the latest dll from the php (pecl) website for your version
of php.
did you have a preiexisting setup which you have tried to install over
the top of, perhaps there are config or files still hanging around
from before?

May 3 '07 #2

P: n/a
On May 3, 8:19 pm, shimmyshack <matt.fa...@gmail.comwrote:
On May 3, 5:17 pm, DavidNorep <avdavid.nore...@gmail.comwrote:


Hi,
I installed basic xampp with the installer fromhttp://www.apachefriends.org/en/xampp-windows.html#524.
When I started Apache from the panel, I got a window with the error
message:
This application has failed to start because php_mbstring.dllwas
not found. Re-installing ...
I tried to re-install but it did not help.
I found in the web references to this problem but everything that they
suggest is already correct at my php.ini: definition of extension_dir
and php_exif.dll appears after mbstring.
In the control-panel - the status of Apache is running and the start
button was replaced by a stop button.
Apache and PHP are new for me.
Thanks,
David

did you install apache as a service?
No. Must I?

filzilla/mysql all should be
services unless you have a need for them not to be.
I assume that this is not the reason for the php error on Apache
start.
if they are use services.msc to check on the status of apache mysql
and filezilla, ignore the control panel, in my experience - which isnt
much, is that it lies. if the application failed to start, then it
failed to start no matter what some gui says.
When I clicked start in the control-panel - an apache.exe process
appeared in the processes table and that error message. When I clicked
OK on the error-window a similar error appeared for OCI.dll, then for
several other dll. After the last error-message - a second apache.exe
appeared in the processes table. Are there supposed to be two
processes?

When I direct the browser to http://localhost I get an empty page.
When I direct it to http://localhost:8080/ I get an error message.
are you editing the right php.ini file? that in apache/bin directory,
No.
have you added any lines to xampp from a website, or is it default -
Yes, the default.
are you running php as a module. If you did add lines did you add the
reference to the wrong module, if you are running apache 2.2.x are you
using the php for apache2.2.x dll?
I just started it from the panel.
did you check that php_mbstring.dll actually does exist? If you can
download the latest dll from the php (pecl) website for your version
of php.
The file exists.
did you have a preiexisting setup which you have tried to install over
the top of, perhaps there are config or files still hanging around
from before?
No.

Also, which book and which online manual can you suggest me to read in
order to study Apache?

Thanks.

May 3 '07 #3

P: n/a
On May 3, 7:25 pm, avdavid <avda...@gmail.comwrote:
On May 3, 8:19 pm, shimmyshack <matt.fa...@gmail.comwrote:
On May 3, 5:17 pm, DavidNorep <avdavid.nore...@gmail.comwrote:
Hi,
I installed basic xampp with the installer fromhttp://www.apachefriends.org/en/xampp-windows.html#524.
When I started Apache from the panel, I got a window with the error
message:
This application has failed to start because php_mbstring.dllwas
not found. Re-installing ...
I tried to re-install but it did not help.
I found in the web references to this problem but everything that they
suggest is already correct at my php.ini: definition of extension_dir
and php_exif.dll appears after mbstring.
In the control-panel - the status of Apache is running and the start
button was replaced by a stop button.
Apache and PHP are new for me.
Thanks,
David
did you install apache as a service?

No. Must I?

filzilla/mysql all should beservices unless you have a need for them not to be.

I assume that this is not the reason for the php error on Apache
start.
if they are use services.msc to check on the status of apache mysql
and filezilla, ignore the control panel, in my experience - which isnt
much, is that it lies. if the application failed to start, then it
failed to start no matter what some gui says.

When I clicked start in the control-panel - an apache.exe process
appeared in the processes table and that error message. When I clicked
OK on the error-window a similar error appeared for OCI.dll, then for
several other dll. After the last error-message - a second apache.exe
appeared in the processes table. Are there supposed to be two
processes?

When I direct the browser tohttp://localhostI get an empty page.
When I direct it tohttp://localhost:8080/I get an error message.
are you editing the right php.ini file? that in apache/bin directory,

No.
have you added any lines to xampp from a website, or is it default -

Yes, the default.
are you running php as a module. If you did add lines did you add the
reference to the wrong module, if you are running apache 2.2.x are you
using the php for apache2.2.x dll?

I just started it from the panel.
did you check that php_mbstring.dll actually does exist? If you can
download the latest dll from the php (pecl) website for your version
of php.

The file exists.
did you have a preiexisting setup which you have tried to install over
the top of, perhaps there are config or files still hanging around
from before?

No.

Also, which book and which online manual can you suggest me to read in
order to study Apache?

Thanks.
hmm! well the only thing I would suggest is have a look at the php.ini
in xampp/apache/bin rather than the one in xampp/php/ you might see in
that php.ini that the settings which are correct in the xampp/php are
not repeated, thi s is what i think it is. The one in php folder is
for command line work.

well i use the online manual for apache, and if you're using firefox
just type
"apache 2 docs mod_rewrite" and you will get the link to mod_rewrite,
its a great site actually, couple that with alt.apache.configuration
and you're there.
I would recommend not running to much xampp stuff at first as its
rather insecure and bulky, and install as services means that
everything starts when your computer does, no hassle.

THere should indeed be two apache processes on windows, one is the
child process that does all the work.
php is set to show errors on startup, which is why you get a whole
load of pop ups, useful for debugging, but I can say that xampp is
very very stable, its likely to be the wrong php.ini file,

In fact IMHO there should be two but the command line one should be
named php-cli.ini for clarity.

May 3 '07 #4

P: n/a
hmm! well the only thing I would suggest is have a look at the php.ini
inxampp/apache/bin rather than the one inxampp/php/ you might see in
that php.ini that the settings which are correct in thexampp/php are
not repeated, thi s is what i think it is. The one in php folder is
for command line work.
When in xampp - "diff apache/bin/php.ini php/php.ini" shows that they
are identical.

After I start Apache and I get those error messages, I browse to :
http://localhost/ and get an empty page
http://localhost/index.html and get a page with the text "it works"
http://localhost:8080 and get an error message

does it mean that apache is running and I only have some php problem?
>
well i use the online manual for apache, and if you're using firefox
just type
"apache 2 docs mod_rewrite" and you will get the link to mod_rewrite,
its a great site actually, couple that with alt.apache.configuration
and you're there.
I would recommend not running to muchxamppstuff at first as its
rather insecure and bulky, and install as services means that
everything starts when your computer does, no hassle.

THere should indeed be two apache processes on windows, one is the
child process that does all the work.
php is set to show errors on startup, which is why you get a whole
load of pop ups, useful for debugging, but I can say thatxamppis
very very stable, its likely to be the wrong php.ini file,

In fact IMHO there should be two but the command line one should be
named php-cli.ini for clarity.- Hide quoted text -

- Show quoted text -

May 4 '07 #5

P: n/a
On May 4, 8:12 am, avdavid <avda...@gmail.comwrote:
hmm! well the only thing I would suggest is have a look at the php.ini
inxampp/apache/bin rather than the one inxampp/php/ you might see in
that php.ini that the settings which are correct in thexampp/php are
not repeated, thi s is what i think it is. The one in php folder is
for command line work.

When in xampp - "diff apache/bin/php.ini php/php.ini" shows that they
are identical.

After I start Apache and I get those error messages, I browse to :http://localhost/ and get an empty pagehttp://localhost/index.html and get a page with the text "it works"http://localhost:8080 and get an error message

does it mean that apache is running and I only have some php problem?
You get an error using port 8080, which is Tomcat right, so there are
issues there. But I cant think why you are having problems loading the
dlls for php I am afraid unless the dlls are not matched with the
version of the apache module or something liek taht which can happen.

May 4 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.