By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
438,278 Members | 1,359 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 438,278 IT Pros & Developers. It's quick & easy.

Getting PEAR modules to work

P: n/a
Hello, I'm new to Linux, setting up and running webservers. I
purchased an unmanaged server that came with a lamp configuration and
Plesk installed. I am trying to get PEAR functioning. I put a
php_info() page up and in the "Configure Command" section there is a
long list of things and "--without-pear" is listed. I know this should
probably say "--with-pear". How do I change this?

When I do a "pear list" command I get the following error:

Failed loading /usr/lib/php4/php_ioncube_loader_lin_4.3.so: /usr/lib/
php4/php_ioncube_loader_lin_4.3.so: undefined symbol:
zend_hash_add_or_update

This is after I upgraded from PHP4 to PHP5.

Any help would be greatly appreciated. Thanks!

Apr 30 '07 #1
Share this Question
Share on Google+
2 Replies


P: n/a
On Apr 30, 4:26 pm, mpar612 <mpar...@gmail.comwrote:
in the "Configure Command" section there is a
long list of things and "--without-pear" is listed. I know this should
probably say "--with-pear". How do I change this?
You have to configure those things when you are compiling PHP. Ex:

../configure --with-mysql

So you need to recompile PHP. The PHP documentation has some useful
information on building and installing both Apache and PHP:

(Apache 1.x)
http://php.net/manual/en/install.unix

(Apache 2.x)
http://php.net/manual/en/install.unix.apache2

-Mike PII

Apr 30 '07 #2

P: n/a
On Apr 30, 6:22 pm, Mike P2 <sumguyovrt...@gmail.comwrote:
On Apr 30, 4:26 pm, mpar612 <mpar...@gmail.comwrote:
in the "Configure Command" section there is a
long list of things and "--without-pear" is listed. I know this should
probably say "--with-pear". How do I change this?

You have to configure those things when you are compiling PHP. Ex:

./configure --with-mysql

So you need to recompile PHP. The PHP documentation has some useful
information on building and installing both Apache and PHP:

(Apache 1.x)http://php.net/manual/en/install.unix

(Apache 2.x)http://php.net/manual/en/install.unix.apache2

-Mike PII
Got that fixed. Thanks!

May 1 '07 #3

This discussion thread is closed

Replies have been disabled for this discussion.