468,305 Members | 1,517 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,305 developers. It's quick & easy.

$_SESSION

Hi!

I have installed EasyPHP on my computer for testing PHP-Scripts. I have also
written a whole System and it works fine when I Upload it to the actual
server where it should be. The problem is, on my local server..the global
$_SESSION variable does not work! Which server (or PHP) settings should be
changed for getting this Global variable to work??

Thanks in advance
//Behrang
Jul 17 '05 #1
3 1859
Behrang Karimibabak wrote:
Hi!

I have installed EasyPHP on my computer for testing PHP-Scripts. I have also
written a whole System and it works fine when I Upload it to the actual
server where it should be. The problem is, on my local server..the global
$_SESSION variable does not work! Which server (or PHP) settings should be
changed for getting this Global variable to work??


Quickest way to answer a question like this for yourself is to create a
file with:

<?php phpinfo() ?>

Put this on both servers, compare output, then adjust yours to match the
target server.

--
Justin Koivisto - sp**@koivi.com
PHP POSTERS: Please use comp.lang.php for PHP related questions,
alt.php* groups are not recommended.
Jul 17 '05 #2
I guess you use a EasyPHP with a PHP version older than 4.1.0. Superglobal
variables only exist since 4.1.0. Most web hosting company use at least the
4.3.x

Savut

"Behrang Karimibabak" <y0******@tu-bs.de> wrote in message
news:ca**********@rzcomm2.rz.tu-bs.de...
Hi!

I have installed EasyPHP on my computer for testing PHP-Scripts. I have
also
written a whole System and it works fine when I Upload it to the actual
server where it should be. The problem is, on my local server..the global
$_SESSION variable does not work! Which server (or PHP) settings should be
changed for getting this Global variable to work??

Thanks in advance
//Behrang


Jul 17 '05 #3
Also forget, make sure to check your session config in php.ini and also if
your session autostart

Savut

"Savut" <we***@hotmail.com> wrote in message
news:Ip******************@news20.bellglobal.com...
I guess you use a EasyPHP with a PHP version older than 4.1.0. Superglobal
variables only exist since 4.1.0. Most web hosting company use at least the
4.3.x

Savut

"Behrang Karimibabak" <y0******@tu-bs.de> wrote in message
news:ca**********@rzcomm2.rz.tu-bs.de...
Hi!

I have installed EasyPHP on my computer for testing PHP-Scripts. I have
also
written a whole System and it works fine when I Upload it to the actual
server where it should be. The problem is, on my local server..the global
$_SESSION variable does not work! Which server (or PHP) settings should
be
changed for getting this Global variable to work??

Thanks in advance
//Behrang


Jul 17 '05 #4

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

reply views Thread by Phil Powell | last post: by
12 posts views Thread by Michael Windsor | last post: by
4 posts views Thread by dpinion | last post: by
4 posts views Thread by Pseudonyme | last post: by
4 posts views Thread by Daz | last post: by
3 posts views Thread by JRough | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.