By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
440,727 Members | 757 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 440,727 IT Pros & Developers. It's quick & easy.

updating PHP problem

P: n/a
I've installed PHP 4.3.6 on my laptop.

My dev machine is on PHP 4.3.3

Since, some lines doesn't work anymore:
2: header("Cache-Control: max-age=" . $this->allowcache_expire * 60);

gives me those errors:
Notice: Undefined variable: this in
c:\inetpub\wwwroot\Connections\config.php on line 2

Warning: Cannot modify header information - headers already sent by (output
started at c:\inetpub\wwwroot\Connections\config.php:8) in
c:\inetpub\wwwroot\Connections\config.php on line 2

Warning: session_start(): Cannot send session cookie - headers already sent
by (output started at c:\inetpub\wwwroot\Connections\config.php:8) in
c:\inetpub\wwwroot\default.php on line 3

Warning: session_start(): Cannot send session cache limiter - headers
already sent (output started at c:\inetpub\wwwroot\Connections\config.php:8)
in c:\inetpub\wwwroot\default.php on line 3
also those line:
3: session_start();
4: if ($_SESSION["UID"] != "") {
5: $UserID = $_SESSION["UID"];
6: }
this line gives me this error:
Notice: Undefined index: UID in c:\inetpub\wwwroot\default.php on line 4

The same code on the PHP 4.3.3 works just fine.

WHAT I'M MISSING ???

Bob
Jul 17 '05 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.