By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
432,257 Members | 928 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 432,257 IT Pros & Developers. It's quick & easy.

Informix error with ifx_pconnect()

P: n/a
I have had this problem in the past on another machine and fixed it by
setting the environment variables for INFORMIXDIR and INFORMIXSERVER. When
adding the same lines on the new machine I still get the following message:

Warning: ifx_pconnect(): E [SQLSTATE=IX 001 SQLCODE=-1829] in
:\webroot\PHPinclude\db_vars.inc on line 7

I tried doing what I did before, but still is not working. Doing
"phpinfo();" The following information is displayed:

PHP Version 4.3.6

System Windows NT DAVIDS 5.1 build 2600
Build Date Apr 14 2004 17:17:11
Server API Apache 2.0 Handler

Under apache2handler:
Apache Version Apache/2.0.49 (Win32) PHP/4.3.6

Under Apache Environment:
INFORMIXDIR C:\informix
INFORMIXSERVER dbserver

And under Environment I have:
INFORMIXDIR C:\informix

I am using the Informix-Client 9.21 2.30.TC1. I have been able to connect to
the Informix database using ILogin Demo and I have been able to connect
using WinSQL.

Any help would be appreciated.

Thanks,
David
Jul 17 '05 #1
Share this Question
Share on Google+
4 Replies


P: n/a
Hi,

On Thu, 20 May 2004 14:44:30 -0400, "D. Sandmann"
<ds*******@emcosales.com> wrote:
I have had this problem in the past on another machine and fixed it by
setting the environment variables for INFORMIXDIR and INFORMIXSERVER. When
adding the same lines on the new machine I still get the following message:

Warning: ifx_pconnect(): E [SQLSTATE=IX 001 SQLCODE=-1829] in
:\webroot\PHPinclude\db_vars.inc on line 7


Check out http://www.oninit.com/errorcode/index.html

Meaning, your $INFORMIX is not set in your environment. You also need
$INFORMIXSERVER.

Don't forget to restart Apache.

HTH, Jochen
--
Jochen Daum - Cabletalk Group Ltd.
PHP DB Edit Toolkit -- PHP scripts for building
database editing interfaces.
http://sourceforge.net/projects/phpdbedittk/
Jul 17 '05 #2

P: n/a
Thanks Jochen.

I assume you ment $INFORMIXDIR when you said $INFORMIX. Yes I do have these
two set. And yes I did make sure to restart Apache. I set them in
httpd.conf. I have also set them in my windows environment. These are the
lines I have in httpd.conf and they happen after the standard LoadModule
area:

#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule ssl_module modules/mod_ssl.so

######
# Start - Informix Stuff
######
SetEnv INFORMIXDIR "C:\informix
SetEnv INFORMIXSERVER "emco5"
######
# End - Informix Stuff
######

LoadModule php4_module c:\PHP\sapi\php4apache2.dll
#AddModule mod_php4.c
AddType application/x-httpd-php .php
#
# ExtendedStatus controls whether Apache will generate "full" status
# information (ExtendedStatus On) or just basic information (ExtendedStatus
# Off) when the "server-status" handler is called. The default is Off.
#
#ExtendedStatus On

David

"Jochen Daum" <jo*********@cabletalk.co.nz> wrote in message
news:pq********************************@4ax.com...
Hi,

On Thu, 20 May 2004 14:44:30 -0400, "D. Sandmann"
<ds*******@emcosales.com> wrote:
I have had this problem in the past on another machine and fixed it by
setting the environment variables for INFORMIXDIR and INFORMIXSERVER. Whenadding the same lines on the new machine I still get the following message:
Warning: ifx_pconnect(): E [SQLSTATE=IX 001 SQLCODE=-1829] in
:\webroot\PHPinclude\db_vars.inc on line 7


Check out http://www.oninit.com/errorcode/index.html

Meaning, your $INFORMIX is not set in your environment. You also need
$INFORMIXSERVER.

Don't forget to restart Apache.

HTH, Jochen
--
Jochen Daum - Cabletalk Group Ltd.
PHP DB Edit Toolkit -- PHP scripts for building
database editing interfaces.
http://sourceforge.net/projects/phpdbedittk/

Jul 17 '05 #3

P: n/a
Just noticed a quote missing from the INFORMIXDIR assignment. Added the
quote there, but still no luck.

David

"D. Sandmann" <ds*******@emcosales.com> wrote in message
news:10*************@corp.supernews.com...
Thanks Jochen.

I assume you ment $INFORMIXDIR when you said $INFORMIX. Yes I do have these two set. And yes I did make sure to restart Apache. I set them in
httpd.conf. I have also set them in my windows environment. These are the
lines I have in httpd.conf and they happen after the standard LoadModule
area:

#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule ssl_module modules/mod_ssl.so

######
# Start - Informix Stuff
######
SetEnv INFORMIXDIR "C:\informix
SetEnv INFORMIXSERVER "emco5"
######
# End - Informix Stuff
######

LoadModule php4_module c:\PHP\sapi\php4apache2.dll
#AddModule mod_php4.c
AddType application/x-httpd-php .php
#
# ExtendedStatus controls whether Apache will generate "full" status
# information (ExtendedStatus On) or just basic information (ExtendedStatus # Off) when the "server-status" handler is called. The default is Off.
#
#ExtendedStatus On

David

"Jochen Daum" <jo*********@cabletalk.co.nz> wrote in message
news:pq********************************@4ax.com...
Hi,

On Thu, 20 May 2004 14:44:30 -0400, "D. Sandmann"
<ds*******@emcosales.com> wrote:
I have had this problem in the past on another machine and fixed it by
setting the environment variables for INFORMIXDIR and INFORMIXSERVER. Whenadding the same lines on the new machine I still get the following message:
Warning: ifx_pconnect(): E [SQLSTATE=IX 001 SQLCODE=-1829] in
:\webroot\PHPinclude\db_vars.inc on line 7


Check out http://www.oninit.com/errorcode/index.html

Meaning, your $INFORMIX is not set in your environment. You also need
$INFORMIXSERVER.

Don't forget to restart Apache.

HTH, Jochen
--
Jochen Daum - Cabletalk Group Ltd.
PHP DB Edit Toolkit -- PHP scripts for building
database editing interfaces.
http://sourceforge.net/projects/phpdbedittk/


Jul 17 '05 #4

P: n/a
Hi,

On Fri, 21 May 2004 09:30:03 -0400, "D. Sandmann"
<ds*******@emcosales.com> wrote:
Thanks Jochen.

I assume you ment $INFORMIXDIR when you said $INFORMIX. Yes I do have these
two set. And yes I did make sure to restart Apache. I set them in
httpd.conf. I have also set them in my windows environment. These are the
lines I have in httpd.conf and they happen after the standard LoadModule
area:

#LoadModule usertrack_module modules/mod_usertrack.so
#LoadModule vhost_alias_module modules/mod_vhost_alias.so
#LoadModule ssl_module modules/mod_ssl.so

######
# Start - Informix Stuff
######
SetEnv INFORMIXDIR "C:\informix
SetEnv INFORMIXSERVER "emco5"


I don't have them in quotes. I'm not on Windows though. Also also use
Apache 1.3.

HTH, Jochen
--
Jochen Daum - Cabletalk Group Ltd.
PHP DB Edit Toolkit -- PHP scripts for building
database editing interfaces.
http://sourceforge.net/projects/phpdbedittk/
Jul 17 '05 #5

This discussion thread is closed

Replies have been disabled for this discussion.