By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,718 Members | 1,383 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,718 IT Pros & Developers. It's quick & easy.

MySQL does not show on php info

P: n/a
I installed Apache, php5 and MySQL 5. The usual <?php phpinfo(); ?gives
the php info, but there is no sign of MySQL, so something is wrong.
I installed the latest connectors. Can someone help me getting php and
MySQL interconnect?

--
Groet,
Adriana
[ gooi de vuilnis weg als je me wilt mailen ]
www.spinsister.nl
Feb 5 '07 #1
Share this Question
Share on Google+
8 Replies


P: n/a
A.Translator schrieb:
I installed Apache, php5 and MySQL 5. The usual <?php phpinfo(); ?>
gives the php info, but there is no sign of MySQL, so something is wrong.
I installed the latest connectors. Can someone help me getting php and
MySQL interconnect?
Are the connectors in the binary? If not check if they are loaded in the
php.ini
Feb 5 '07 #2

P: n/a
adlerweb schreef op 5-2-2007
Are the connectors in the binary? If not check if they are loaded in the
php.ini
Thanks for your prompt reply but sorry, I am new to all this. You mean in
the MySql bin folder? No, I understood I had to put them in the PHP and
PHP extensions folders.
I cannot find anything about them getting loaded in de php.ini either.
What should I add?

--
Groet,
Adriana
[ gooi de vuilnis weg als je me wilt mailen ]
www.spinsister.nl
Feb 5 '07 #3

P: n/a
Try to add this line to your php.ini

extension = mysql.so

then restart apache and try again. This should load the MySQL-Extension.

A.Translator schrieb:
Thanks for your prompt reply but sorry, I am new to all this. You mean
in the MySql bin folder? No, I understood I had to put them in the PHP
and PHP extensions folders.
I cannot find anything about them getting loaded in de php.ini either.
What should I add?
Feb 5 '07 #4

P: n/a
A.Translator wrote:
Thanks for your prompt reply but sorry, I am new to all this. You mean
in the MySql bin folder? No, I understood I had to put them in the PHP
and PHP extensions folders.
I cannot find anything about them getting loaded in de php.ini either.
What should I add?
On Windows you should have a line in php.ini such as:
extension=php_mysql.dll (or extension=php_mysqli.dll when using mysqli).
On Linux it should be something like: extension=mysql.so
Also make sure the extension_dir setting is set to the right directory.

HTH.
Ruben.
Feb 5 '07 #5

P: n/a
Ruben van Engelenburg schreef op 5-2-2007
On Windows you should have a line in php.ini such as:
extension=php_mysql.dll (or extension=php_mysqli.dll when using mysqli).
OK, thanks. (dank je,aan je naam te zien). The dir is pointing to the
right place, but I had enabled extension_msql.

--
Groet,
Adriana
[ gooi de vuilnis weg als je me wilt mailen ]
www.spinsister.nl
Feb 5 '07 #6

P: n/a
A.Translator schreef op 5-2-2007
but I had enabled extension_msql.
No change now that I activated the right extension. I think the problem
has to do with the path to the php.ini. It is actually in C:\PHP\ but the
php.info shows it to be in C:\Windows. So I copied it there. The info
says: C:\WINDOWS not C:\WINDOWS\php.ini as I have seen in several
examples. Can I fix that?

--
Groet,
Adriana
[ gooi de vuilnis weg als je me wilt mailen ]
www.spinsister.nl
Feb 5 '07 #7

P: n/a
A.Translator schreef op 5-2-2007
I installed Apache, php5 and MySQL 5. The usual <?php phpinfo(); ?>
gives the php info, but there is no sign of MySQL, so something is
wrong.
Fixed it. The path to windows was messed up.

--
Groet,
Adriana
[ gooi de vuilnis weg als je me wilt mailen ]
www.spinsister.nl
Feb 6 '07 #8

P: n/a
A.Translator wrote:
A.Translator schreef op 5-2-2007
>but I had enabled extension_msql.

No change now that I activated the right extension. I think the problem
has to do with the path to the php.ini. It is actually in C:\PHP\ but
the php.info shows it to be in C:\Windows. So I copied it there. The
info says: C:\WINDOWS not C:\WINDOWS\php.ini as I have seen in several
examples. Can I fix that?
Not sure what web server you're using, but Apache "likes" the php.ini to
be in apache/bin
Feb 6 '07 #9

This discussion thread is closed

Replies have been disabled for this discussion.