By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
454,721 Members | 1,468 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 454,721 IT Pros & Developers. It's quick & easy.

phpize and autoconf, custom installation of libssh2

P: n/a
I've been trying to install the PECL library libssh2 for secure shell2
functions. I'm on a shared webhost which allows custom php
installations that run as a CGI binary. I've been trying to configure
libssh2 but I cannot get the server I'm on to find autoconf... it
originally was not installed on the server, so I downloaded, unpacked,
and installed it successfully to a custom folder in my /home directory
(along with autoheader). However, when I run phpize with ./configure,
I get this error no matter what I do:

[server]$ /home/username/php5/bin/phpize ./configure --with-ssh2 &&
Configuring for:
PHP Api Version: 20041225
Zend Module Api No: 20060613
Zend Extension Api No: 220060519
Cannot find autoconf. Please check your autoconf installation and the
environment variable is set correctly and then rerun this script.

I know what I need to do is tell phpize where autoconf is located, but
I do not know how to do this, nor can I find any newsgroup post or
manual site that explains how or where this is done. I've tried
manually assigning the path to $PHP_AUTOCONF directly in phpize
itself, like this:

[around line 102]
+ $PHP_AUTOCONF='/home/username/my/custom/path/to/autoconf'
test -z "$PHP_AUTOCONF" && PHP_AUTOCONF=autoconf
test -z "$PHP_AUTOHEADER" && PHP_AUTOHEADER=autoheader

But when I run phpize I still get the same error message.

So, question is how do I override the default environment variables
$PHP_AUTOCONF and $PHP_AUTOHEADER? An easier solution (if it's
possible) would be to just point to autoconf as a command line option,

[server]$ /home/username/php5/bin/phpize PHP_AUTOCONF=/some/path/
autoconf ./configure --with-ssh2 && make

I realize it could also be that my installation of autoconf is
corrupt, but I've installed and reinstalled it several times with no
error messages from ./configure and make. I also realize that my host
may also restrict usage of programs like autoconf altogether... in
which case this all for nothing, but either way I'd like to get phpize
to at least try and find the program!

Thanks in advance --

Feb 1 '07 #1
Share this question for a faster answer!
Share on Google+

This discussion thread is closed

Replies have been disabled for this discussion.