By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
425,646 Members | 1,175 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 425,646 IT Pros & Developers. It's quick & easy.

MySql 4.1.1 Password problem - client can't connect

P: n/a
Hello,

Newbie here..... Searching and working this for a week now.

We too are having the same problems.

Using MySql 4.0.14 and there are "no problems" at all.

However when we went to MySql 4.1.1

we cannot connect using clients (such as PhpMyAdmin or PhpAdsNew) if
there is any password.

Remove the password and 4.1.1 is fine.

I have also tried to start the database using both

bin/mysqld_safe &

bin/mysqld_safe --old-passwords &

with no luck

We have added users via telnet....

**************************

INSERT INTO user VALUES
('localhost,'test','','Y','Y','Y','Y','Y','Y','Y', 'Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y','Y ','Y','','','','',0,0,0);

Then we can get in using PhpMyAdmin

If we do...

UPDATE user SET PASSWORD=PASSWORD ('test123') WHERE User='test' and
host='localhost';

FLUSH PRIVILEGES;

Then we can no longer connect using PhpMyAdmin

***************************

If we then run... (removing the password) it again will connect fine.

UPDATE user SET PASSWORD=PASSWORD ('') WHERE User='test' and
host='localhost';

FLUSH PRIVILEGES;

also using the GRANT command does not work...

GRANT ALL PRIVILEGES ON *.* to 'test'@'localhost' IDENTIFIED BY
'test123';

FLUSH PRIVILEGES;

*******************************

Logging into PhpAdmin as root (without a password) let's me in.

From the GUI I get the same exact results.

Add a user such as test@localhost without password and I can log into
that

user/database just fine. As soon as I add a password (via the GUI,
PhpAdmin) the user now longer connect.

Here is the error....

Welcome to phpMyAdmin 2.6.0-alpha1
phpMyAdmin tried to connect to the MySQL server, and the server
rejected the connection. You should check the host, username and
password in config.inc.php and make sure that they correspond to the
information given by the administrator of the MySQL server.

Error

MySQL said:

Cannot connect: invalid settings.
*************************

Here is the config.inc.php settings....

$i++;

$cfg['Servers'][$i]['host'] = 'localhost';

$cfg['Servers'][$i]['port'] = '';

$cfg['Servers'][$i]['socket'] = '';

$cfg['Servers'][$i]['connect_type'] = 'tcp';

$cfg['Servers'][$i]['extension'] = 'mysql';

$cfg['Servers'][$i]['compress'] = FALSE;

$cfg['Servers'][$i]['controluser'] = '';

$cfg['Servers'][$i]['controlpass'] = '';

$cfg['Servers'][$i]['auth_type'] = 'config';

$cfg['Servers'][$i]['user'] = 'test';

$cfg['Servers'][$i]['password'] = 'test123';

$cfg['Servers'][$i]['only_db'] = '';

$cfg['Servers'][$i]['verbose'] = '';

$cfg['Servers'][$i]['pmadb'] = ''; // 'phpmyadmin' - see
scripts/create_tables.sql

$cfg['Servers'][$i]['bookmarktable'] = ''; // 'pma_bookmark'

$cfg['Servers'][$i]['relation'] = ''; // 'pma_relation'

$cfg['Servers'][$i]['table_info'] = ''; // 'pma_table_info'

$cfg['Servers'][$i]['table_coords'] = ''; // 'pma_table_coords'

$cfg['Servers'][$i]['pdf_pages'] = ''; // 'pma_pdf_pages'

$cfg['Servers'][$i]['column_info'] = ''; // 'pma_column_info'

$cfg['Servers'][$i]['history'] = ''; // 'pma_history'

$cfg['Servers'][$i]['verbose_check'] = TRUE;

$cfg['Servers'][$i]['AllowDeny']['order']

= '';

$cfg['Servers'][$i]['AllowDeny']['rules']

= array();

We have even tried a complete fresh reinstall of 4.1.1 and having the
same results.

Any help appreciated......

Thanks

Marc
Jul 17 '05 #1
Share this Question
Share on Google+
1 Reply


P: n/a
Marc wrote:
(snip)
Any help appreciated......


http://dev.mysql.com/doc/mysql/en/Up...-from-4.0.html

--
USENET would be a better place if everybody read: : mail address :
http://www.catb.org/~esr/faqs/smart-questions.html : is valid for :
http://www.netmeister.org/news/learn2quote2.html : "text/plain" :
http://www.expita.com/nomime.html : to 10K bytes :
Jul 17 '05 #2

This discussion thread is closed

Replies have been disabled for this discussion.