By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
455,828 Members | 1,409 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 455,828 IT Pros & Developers. It's quick & easy.

bad performance with php 5.2.0

P: n/a
Hi!

I'm running OmniHTTPd/2.10 with php on a Win2k SP4 machine with various php applications (for
example phpMyAdmin and cacti).
Until now I was using php 5.0.4 without problems. I updated to php 5.2.0 and now all the php
applications are running *very* slow.
A cacti page with some graphs on it took 16 sec to show up completly with php 5.0.4 now takes 50 sec
with php 5.2.0. Same with other php scipts.
I monitored php with the taskman. With php 5.0.4 some php-cgi.exe show up, using up to 99% cpu never
going to 0%. With php 5.2.0 the same php-cgi.exe show up, but using only 30% to 40% cpu, dropping
periodically to 0% cpu, then back to 30%, then back to 0% and so on.
Any hints how to solve this problem?

Best regards, Sickboy.
Jan 21 '07 #1
Share this Question
Share on Google+
5 Replies


P: n/a
Have you tried running Apache web server instead? Looks to me that it's
been awhile since OmniHTTPd updated anything...

If interested I'll send you a few helpful links.

Regards

T

On Jan 21, 4:07 pm, Sebastian 'Sickboy' Keichel
<sebastian.keic...@stud.tu-ilmenau.dewrote:
Hi!

I'm running OmniHTTPd/2.10 with php on a Win2k SP4 machine with various php applications (for
example phpMyAdmin and cacti).
Until now I was using php 5.0.4 without problems. I updated to php 5.2.0 and now all the php
applications are running *very* slow.
A cacti page with some graphs on it took 16 sec to show up completly with php 5.0.4 now takes 50 sec
with php 5.2.0. Same with other php scipts.
I monitored php with the taskman. With php 5.0.4 some php-cgi.exe show up, using up to 99% cpu never
going to 0%. With php 5.2.0 the same php-cgi.exe show up, but using only 30% to 40% cpu, dropping
periodically to 0% cpu, then back to 30%, then back to 0% and so on.
Any hints how to solve this problem?

Best regards, Sickboy.
Jan 22 '07 #2

P: n/a
<nt*******@gmail.comwrote:
: Have you tried running Apache web server instead? Looks to me
: that it's been awhile since OmniHTTPd updated anything...
:
: If interested I'll send you a few helpful links.

I started up PHP 5.2 on Apache and noticed it is slightly slower
than the latest version of PHP 4.x (Apache 1.3.37/Windows NT).

It might perhaps have to do with anything in the PHP.INI file?

I've also run into another problem which I'm going to ask for some
help under a new thread.

--
Jim Carlock
Post replies to the group.
Jan 22 '07 #3

P: n/a
On Jan 22, 1:48 pm, "Jim Carlock" <anonym...@127.0.0.1wrote:
<ntvtho...@gmail.comwrote:: Have you tried running Apache web server instead? Looks to me
: that it's been awhile since OmniHTTPd updated anything...
:
: If interested I'll send you a few helpful links.

I started up PHP 5.2 on Apache and noticed it is slightly slower
than the latest version of PHP 4.x (Apache 1.3.37/Windows NT).

It might perhaps have to do with anything in the PHP.INI file?

I've also run into another problem which I'm going to ask for some
help under a new thread.

--
Jim Carlock
Post replies to the group.
Are you running PHP as an Apache module, or as a CGI?

Jan 24 '07 #4

P: n/a
On Jan 22, 1:48 pm, "Jim Carlock" posted...
: I started up PHP 5.2 on Apache and noticed it is slightly slower
: than the latest version of PHP 4.x (Apache 1.3.37/Windows NT).
:
: It might perhaps have to do with anything in the PHP.INI file?
"Curtis" asked:
: Are you running PHP as an Apache module, or as a CGI?

It's loaded as a module.

<httpd.conf>

# Load the php 4 module
# LoadModule php4_module "E:/php4/php4apache.dll"
# Load the php 5 module
LoadModule php5_module "E:/php5/php5apache.dll"
# ... more stuff ...
# [Whenever changing LoadModules above, update items below!]
ClearModuleList
# ... bunch of AddModule stuff ...

# Add the mod_php4.c
# AddModule mod_php4.c
AddModule mod_php5.c

</httpd.conf>

Apache seems to start up and load just as quickly as it used to,
but I noticed a slightly longer delay in presenting PHP pages under
PHP 5 (not much but enough). But perhaps it's caused because of
added extensions in PHP 5. I installed PHP 5 to get to php_pdo.dll,
php_pdo_sqlite.dll and php_sqlite.dll extensions (?).

--
Jim Carlock
Post replies to the group.
Jan 24 '07 #5

P: n/a
nt*******@gmail.com schrieb:
Have you tried running Apache web server instead?
Not yet. But I think I will.
Looks to me that it's
been awhile since OmniHTTPd updated anything...
Yeah, using this installation since php 4.
If interested I'll send you a few helpful links.
Thanks, but it's not necessary. I already installed apache on some linux and windows machines.

Best regards, Sickboy.
Jan 25 '07 #6

This discussion thread is closed

Replies have been disabled for this discussion.