By using this site, you agree to our updated Privacy Policy and our Terms of Use. Manage your Cookies Settings.
448,485 Members | 1,031 Online
Bytes IT Community
+ Ask a Question
Need help? Post your question and get tips & solutions from a community of 448,485 IT Pros & Developers. It's quick & easy.

Sessions and Shared Hosting Provider issue

P: n/a
I am in the middle of debugging a script that is hanging on
"session_start()", which, if I recall, can occur if session.save_path
points to a directory onto which you do not have permission to access
(I verified and yep, no love on that folder).

So I figured I'd simply rewrite session.save_path:

<? ini_set('session.save_path', '/path/where/there/is/love'); ?>

To no avail, because the shared hosting provider also informed me that
you are not permitted to overwrite the default settings of php.ini
because it's a shared hosting provider.

UGH!

So my next and last idea is to copy over a local copy of php.ini to my
/[account root folder] directory, however, I am only given access to
/htdocs and /cgi-bin.

Obviously /htdocs = BAD IDEA since the known universe can read the
contents of php.ini via browser, but the shared hosting provider will
not allow me to move it outside of /htdocs document root folder.

That leaves /cgi-bin. Is that a good idea? Or do you all have a better
idea as to what to do? Bottom line: I just want to be able to use
session_start(), optionally, ini_set().

I need an answer rather quick as the site is breaking and my boss wants
an answer before COB today and I am trying to come up with one stat!

Thanx
Phil

Nov 29 '06 #1
Share this Question
Share on Google+
2 Replies


P: n/a
Hi,

session_start might hang if another page already has that session open
and is running. If that's a possibility, you might want to call
session_write_close() on the other page, or make sure the page
completes first. There's a note in the comments at
php.net/session_start about this.

Changing the session path usually works using ini_set, or .htaccess:

php_value session.save_path /my/home/php-sessions

The directory should be writable by the web user.

comp.lang.php wrote:
I am in the middle of debugging a script that is hanging on
"session_start()", which, if I recall, can occur if session.save_path
points to a directory onto which you do not have permission to access
(I verified and yep, no love on that folder).

So I figured I'd simply rewrite session.save_path:

<? ini_set('session.save_path', '/path/where/there/is/love'); ?>

To no avail, because the shared hosting provider also informed me that
you are not permitted to overwrite the default settings of php.ini
because it's a shared hosting provider.

UGH!

So my next and last idea is to copy over a local copy of php.ini to my
/[account root folder] directory, however, I am only given access to
/htdocs and /cgi-bin.

Obviously /htdocs = BAD IDEA since the known universe can read the
contents of php.ini via browser, but the shared hosting provider will
not allow me to move it outside of /htdocs document root folder.

That leaves /cgi-bin. Is that a good idea? Or do you all have a better
idea as to what to do? Bottom line: I just want to be able to use
session_start(), optionally, ini_set().

I need an answer rather quick as the site is breaking and my boss wants
an answer before COB today and I am trying to come up with one stat!

Thanx
Phil
Nov 29 '06 #2

P: n/a

petersprc wrote:
Hi,

session_start might hang if another page already has that session open
and is running. If that's a possibility, you might want to call
session_write_close() on the other page, or make sure the page
completes first. There's a note in the comments at
php.net/session_start about this.
Actually it's at the top of the main page that's hanging and it is
calling no other page when it hangs. Should I include
session_write_close() anyway?
>
Changing the session path usually works using ini_set, or .htaccess:
We are not given permission to use ini_set() to make any local changes
to any variable, including session.save_path
php_value session.save_path /my/home/php-sessions

The directory should be writable by the web user.
Yeah I tried that, to no avail. We're not allowed to make changes via
ini_set(); I tried uploading php.ini but I am only given permission to
load onto either /htdocs or /cgi-bin, neither of which are secure nor
allow for the local php.ini to function; we are not allowed to write to
our own chroot.

Phil
comp.lang.php wrote:
I am in the middle of debugging a script that is hanging on
"session_start()", which, if I recall, can occur if session.save_path
points to a directory onto which you do not have permission to access
(I verified and yep, no love on that folder).

So I figured I'd simply rewrite session.save_path:

<? ini_set('session.save_path', '/path/where/there/is/love'); ?>

To no avail, because the shared hosting provider also informed me that
you are not permitted to overwrite the default settings of php.ini
because it's a shared hosting provider.

UGH!

So my next and last idea is to copy over a local copy of php.ini to my
/[account root folder] directory, however, I am only given access to
/htdocs and /cgi-bin.

Obviously /htdocs = BAD IDEA since the known universe can read the
contents of php.ini via browser, but the shared hosting provider will
not allow me to move it outside of /htdocs document root folder.

That leaves /cgi-bin. Is that a good idea? Or do you all have a better
idea as to what to do? Bottom line: I just want to be able to use
session_start(), optionally, ini_set().

I need an answer rather quick as the site is breaking and my boss wants
an answer before COB today and I am trying to come up with one stat!

Thanx
Phil
Nov 29 '06 #3

This discussion thread is closed

Replies have been disabled for this discussion.