467,166 Members | 960 Online
Bytes | Developer Community
Ask Question

Home New Posts Topics Members FAQ

Post your question to a community of 467,166 developers. It's quick & easy.

safe_mode ON on local but not in global

My PHP.INI configuration have safe_mode = Off but in local execution it
get On.
I noticed this strange behaviour with a script that shows an error in
move_uploaded_file.
I write a minimal script with

<?php
phpinfo();
?>

It shows safe_mode On (local) and safe_mode Off (global).

Anyway I tried this other script

<?php
ini_set('safe_mode',FALSE);
phpinfo();
?>

and the results were the same.

Anyone can help me? The web server is under my complete control and is
used only for one website; I don't need SAFE MODE. I don't want it.

Nov 9 '06 #1
  • viewed: 5115
Share:
1 Reply
ra****@tiscali.it wrote:
My PHP.INI configuration have safe_mode = Off but in local execution it
get On.
I noticed this strange behaviour with a script that shows an error in
move_uploaded_file.
I write a minimal script with

<?php
phpinfo();
?>

It shows safe_mode On (local) and safe_mode Off (global).

Anyway I tried this other script

<?php
ini_set('safe_mode',FALSE);
phpinfo();
?>
Well it wouldn't be a very safe safe_mode if it were that easy to turn off!

IIRC, master is the value in the config file, but this can be overridden in
the apache config / .htaccess files or in the script. Check your config
files - also watch out for include files, particularly if auto-prepended.

HTH

C.

Nov 9 '06 #2

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

1 post views Thread by Henrik Oddershede | last post: by
reply views Thread by Gerrit Kuilder | last post: by
1 post views Thread by David Ruiz | last post: by
1 post views Thread by Felix Natter | last post: by
2 posts views Thread by ZMAN | last post: by
3 posts views Thread by Kyle Root | last post: by
23 posts views Thread by Timothy Madden | last post: by
reply views Thread by Zeilkman | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.