468,296 Members | 1,301 Online
Bytes | Developer Community
New Post

Home Posts Topics Members FAQ

Post your question to a community of 468,296 developers. It's quick & easy.

Binary incompalibilities in PHP extensions

A client of mine reported the following error message that occurred
whilst trying to load a third-party PHP extension through PHP v4.1.1
(running under Apache v1.3/Windows XP). The module was originally
compiled using the v4.2.3 code base.

===
Module compiled with module API=20020429, debug=0, thread-safety=1
PHP compiled with module API=20010901, debug=0, thread-safety=1
===

I thought binary incompatibilities (with respect to extensions) only
occurred across major PHP version upgrades (e.g. v3 -> v4).

Does anyone know of a list of critical PHP version upgrades at which
point it is necessary to rebuild PHP extensions ?

There appear to be plenty of references to problems of this nature in
the various PHP support forums but no clear directives with regards how
to avoid these compatibility issues in the first place.

Thanks in advance !
--
----------------------------------------------------------
Chris Munt
ITA Consulting Ltd
M/Gateway Developments Ltd : http://www.mgateway.tzo.com
Royal Marsden NHS Trust : http://www.royalmarsden.org
----------------------------------------------------------
Jul 17 '05 #1
0 1232

This discussion thread is closed

Replies have been disabled for this discussion.

Similar topics

11 posts views Thread by rbt | last post: by
103 posts views Thread by Steven T. Hatton | last post: by
6 posts views Thread by | last post: by
15 posts views Thread by David Marsh | last post: by
8 posts views Thread by Aaron Turner | last post: by
8 posts views Thread by brainflakes.org | last post: by
9 posts views Thread by Hatzigiannakis Nikos | last post: by
5 posts views Thread by Ambush Commander | last post: by
reply views Thread by NPC403 | last post: by
By using this site, you agree to our Privacy Policy and Terms of Use.